ISA(4) BSD Kernel Interfaces Manual ISA(4)
isa -- introduction to machine-independent ISA bus support and drivers
Attachments are machine-dependent and depend on the bus topology and ISA bus interface of your system. See intro(4) for your system for
NetBSD includes a machine-independent ISA bus subsystem and several machine-independent ISA device drivers.
Your system may support additional ISA devices. Drivers for ISA devices not listed here are machine-dependent. Consult your system's
intro(4) for additional information.
NetBSD includes machine-independent ISA drivers, sorted by device type and driver name:
adv Advansys SCSI interfaces.
aha Adaptec AHA-154x family (154xA, 154xB, 154xC, and 154xCF) and the BusLogic BT54x SCSI interfaces.
ahc Adaptec 29xx, 39xx, and other AIC-7xxx-based SCSI interfaces.
aic Adaptec AIC-6260 and Adaptec AIC-6360 based SCSI interfaces, including the Adaptec 152x, SoundBlaster SCSI interfaces, and a
variety of compatibles.
bha BusLogic BT-445 SCSI interfaces.
dpt DPT SmartCache/SmartRAID III and IV SCSI interfaces.
esp NCR 53C9x, Emulex ESP406, and Qlogic FAS408 SCSI interfaces.
sea Seagate/Future Domain SCSI cards. ST01/02, Future Domain TMC-885, and Future Domain TMC-950.
uha Ultrastor 14f SCSI interfaces.
wds WD-7000 family of bus-mastering SCSI interfaces.
Disk and tape controllers
mcd Mitsumi CD-ROM drives.
wdc Standard Western Digital type hard drive controllers: MFM, RLL, ESDI, and IDE/ATAPI.
wt Wangtek and compatible QIC-02 and QIC-36 tape drives.
Serial and parallel interfaces
ast Multi-port serial communications card first made by AST.
boca Boca BB100 and BB2016 multiplexing serial communications cards.
com NS8250-, NS16450-, and NS16550-based serial ports.
cy Cyclades Cyclom-4Y, -8Y, and -16Y asynchronous serial communications cards.
ioat BOCA Research IOAT66 serial interfaces.
lpt Standard ISA parallel port interface.
rtfps IBM RT four-port serial interfaces.
tcom Byte Runner Technologies TC-400 and TC-800 series serial interfaces.
ai AT&T StarLan Ethernet interfaces.
ate Allied Telesis AT1700 series and RE2000 series Ethernet interfaces.
cs Cirrus Logic Crystal CS8900 Ethernet interfaces.
ec 3Com EtherLink II (3c503) Ethernet interfaces.
ef 3Com EtherLink II (3c507) Ethernet interfaces.
eg 3Com EtherLink Plus (3c505) Ethernet interfaces.
el 3Com EtherLink (3c501) Ethernet interfaces.
ep 3Com EtherLink III (3c509) Ethernet interfaces.
fmv Fujitsu FMV-181 and FMV-182 interfaces.
ix Intel EtherExpress/16 Ethernet interfaces.
iy Intel i82595-based Ethernet interfaces, including the EtherExpress Pro/10.
lc DEC EtherWORKS III Ethernet interfaces (DE203, DE204, and DE205).
le Ethernet interfaces based on the AMD LANCE chip, including BICC Isolan, Novell NE2100, Digital DEPCA, and PCnet-ISA.
ne Novel NE2000 and compatible Ethernet interfaces.
ntwoc SDL Communications Riscom/N2 synchronous serial interfaces.
sm SMC91C9x-based Ethernet interfaces.
tr TROPIC based token ring interfaces.
we Western Digital/SMC 80x3, SMC Elite Ultra, and SMC EtherEZ Ethernet interfaces.
Sound cards and MIDI interfaces
aria Sierra's Aria based sound cards.
cms Creative Music System.
ess ESS Technology AudioDrive 1788-, 1888-, 1887-, and 888-based sound cards.
gus Gravis Ultrasound sound cards.
mpu Roland MPU401 (and compatible) MIDI UARTs.
opl Yamaha OPL2 and OPL3 FM MIDI synthesizers.
pas ProAudio Spectrum sound cards.
sb SoundBlaster, SoundBlaster 16, and SoundBlaster Pro sound cards.
wss Windows Sound System-compatible sound cards based on the AD1848 and compatible chips.
az Aztech/PackardBell radio card.
ega EGA graphics boards.
lm National Semiconductor LM78, LM79 and compatible hardware monitors.
pcdisplay PC display adapters.
pcic PCI PCMCIA controllers, including the Cirrus Logic GD6729.
pckbc PC keyboard controllers.
pcppi PC control and timer ports.
pms PS/2 auxiliary port mice (including wheel mice).
rt AIMS Lab Radiotrack FM radio.
rtii AIMS Lab Radiotrack II FM radio.
sf2r SoundForte RadioLink SF16-FMR2 FM radio.
tcic Databook DB86082, DB86084, DB86184, and DB86072 PCMCIA controllers.
vga VGA graphics boards.
wbsio Winbond LPC Super I/O.
Note that some ISA devices also have newer ISA Plug-and-Play variants. These are listed in isapnp(4). Some i386 platforms use pnpbios(4) to
attach ISA devices.
Stray interrupt on IRQ 7 It means the interrupt controller reported an unmasked interrupt on IRQ 7, but no driver attached to that IRQ
There are two reasons this can happen:
o In anything other than i386, it would almost always mean that there is a driver attached to the IRQ, but it is the wrong driver.
o On i386, there is the more obscure issue of `default IRQ7's. That is, when a device asserts an IRQ, but the IRQ is deasserted after the
PIC latches the interrupt and before the CPU acknowledges it, the PIC just flat out lies about which IRQ it was. It is usually due to a
suboptimally coded driver.
adv(4), aha(4), ahc(4), ai(4), aic(4), aria(4), ast(4), ate(4), az(4), bha(4), boca(4), cms(4), com(4), cs(4), cy(4), dpt(4), ec(4), ef(4),
eg(4), el(4), ep(4), esp(4), ess(4), fmv(4), gus(4), intro(4), ioat(4), isapnp(4), ix(4), iy(4), joy(4), lc(4), le(4), lm(4), lpt(4), mcd(4),
mpu(4), nca(4), ne(4), ntwoc(4), opl(4), pas(4), pcdisplay(4), pcic(4), pckbc(4), pcppi(4), pms(4), pnpbios(4), rt(4), rtfps(4), rtii(4),
sb(4), sea(4), sf2r(4), sm(4), tcic(4), tcom(4), tr(4), uha(4), vga(4), wbsio(4), wd(4), wdc(4), wds(4), we(4), wss(4), wt(4)
The machine-independent ISA subsystem appeared in NetBSD 1.2.
February 21, 2010 BSD