Visit Our UNIX and Linux User Community


Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Lilo
# 1  
Old 01-07-2002
Question Lilo

Any idea how to Install Lilo after Instal linux 7.2 ( 2.4.7 ). At first when i was installing Linux 7.2 i didnt install LILO because i have alllready installed Boot Magic from Power Quest (Having dual boot Windows2000 Server and Linux Red Hat7.2 ). I didnt install LILO because i was having a problem last time using Linux 7.1 where i got LILO problem which it Wipes of my boot magic. So this time i didnt install that (LILO) when installing Linux. But after install linux Boot Magic (PowerQuest ) doesnt seems to detect Linux, but i able to Boot linux using (Boot Disc) *sigh* Luckily i created one. So any idea how to install LILO Especially after Installing Red Hat Linux...

# 2  
Old 01-07-2002
You can only have one boot loader right? Not two... either lilo or the other one... not both..... configured properly, either will work.

Which one are you going to use?
# 3  
Old 01-07-2002

Neo, hie there. I understand only one boot loader can be used, but ive did this linux installation more then 7 times in diffrent Hard Disk after every singe of them ruin my HDD. First i tried Lilo, but when i installed lilo during Linux installation i find out it doesnt maps my Win2K Server OS for me. I tried to edit the /.config file for the Lilo but it crashed up ending on HDD error. Next i tried to Install linux but this time using Boot magic from Power Quest, but this ends up with succesfull installation of both Linux and Win2K Server OS but only the Win2k is visible upon Boot time. The linux.. i cant find it or even configure for it to make visible. But now after i install Linux i thought i wanted to Install the Lilo ( reverse ) probarbaly who know this might can be work out for the Linux and Win2k to boot up... Pls advise..

# 4  
Old 01-08-2002
# 5  
Old 01-08-2002

Thanx livinfree, hope that link could help me...
# 6  
Old 01-10-2002
Hie, i tried the link that given by Livinfree but still it doesnt help me much. i remember when i was to install linux, i didnt install lilo at all. So now how to install the lilo back. i tried to installed it:
<root@trillium>$ rpm -ivh lilo-21.4.4-14.i386.rpm

it did say installed ##### [[100%] Sucessfully !
but i confuse why i still unable to see my lilo conf file in /etc/lilo.conf it doesnt exists.

<root@trilium>lilo - C
/etc/lilo.conf : Bash command not found.

Here's some info i got regarding my HDD structure.
/dev/hda5 -Swap
/dev/hda6 -Ext2
/dev/hda1 -Pri {win2k}

Hope someone can give some idea to solve this problem of mine. Smilie
# 7  
Old 01-11-2002
Read the manual pages for lilo and lilo.conf. It will give you everything you need to know, and then some... If you're still having problems, let me know, although it's been a while since I used a dual-boot machine...

Previous Thread | Next Thread
Test Your Knowledge in Computers #674
Difficulty: Medium
Wi-Fi does not use any parts of the IEEE 803 protocol.
True or False?

10 More Discussions You Might Find Interesting

1. Red Hat

lilo question

I use redhat7.0, and I want to update kernel to 2.4.0,I make following steps: #gzip -cd linux-2.4.0.tar.gz | tar xvf - #cd linux #make mrproper #make config #make dep #make bzdisk #make modules #make modules_install #cp linux/arch/i386/boot/bzImage /boot then I modify lilo.conf,like... (0 Replies)
Discussion started by: konvalo
0 Replies

2. Red Hat

lilo.conf for lvm

Does anyone know how to write a lilo.conf for lvm configurations. I have the devices addressed as: /dev/VolGroup00/LogVol00 / (root) /dev/VolGroup00/LogVol01 (swap) When running lilo, Error states: can't put the boot sector on logical partition 0xFD02 Would... (2 Replies)
Discussion started by: imrank27
2 Replies

3. UNIX for Dummies Questions & Answers

removing lilo

I have a machine that dual boots win2k and linux, and we are handing it off so it no longer needs linux. Linux is a separate partition so I can delete the partition, but I need to remove lilo- how do I do that ? (7 Replies)
Discussion started by: dangral
7 Replies

4. UNIX for Dummies Questions & Answers

LILO question again. Need help.

I know that this question has been asked here many times before, but after 4hours of reading and conf file changing I'm still where I started. Here's the scenario. I have a machine that has 60GB HDD, RedHat 7.3 & Win2K. 19 first GB are win2k (FAT32; /dev/hda1). Then comes RedHat 7.3: hda2 -> /boot... (2 Replies)
Discussion started by: D-Lexy
2 Replies

5. UNIX for Dummies Questions & Answers

Linux Lilo

i hade and Win 2000 and and Linux 6.2 on a machine, the Lilo boot worked properly . . after i had changed the Partion size with Partion Magic in w2k and rebooted my computer hangs and just says "Li" in the upper left corner . . can some one plz explain to me where the problem is, can i get the... (2 Replies)
Discussion started by: sajjan2
2 Replies

6. Filesystems, Disks and Memory

I need help with lilo

:confused: I've been trying to figure out what happen to Windows 2000 since I upgrade my partition of Red Hat 7.1 to 7.2. Before I even upgraded my system would dual boot both OS's now it only sees Linux in lilo. Can some one help me I'm in need of help. Can you tell me what I'm missing in my... (3 Replies)
Discussion started by: aojmoj
3 Replies

7. Filesystems, Disks and Memory

Lilo Boot

i hade and Win 2000 and and Linux 6.2 on a machine, the Lilo boot worked properly . . after i had changed the Partion size with Partion Magic in w2k and rebooted my computer hangs and just says "Li" in the upper left corner . . can some one plz explain to me where the problem is, can i get the... (1 Reply)
Discussion started by: sajjan2
1 Replies

8. UNIX for Dummies Questions & Answers


I have installed linux.. but it wont boot.. it says: "LI" and then my computer freezes.. it has worked before.. A couple of days ago, I tried to install OpenBSD.. I used the whole disk for it.. I think it's something with the MBR-settings I made in the OpenBSD installation.. How can... (1 Reply)
Discussion started by: Hamcha
1 Replies

9. UNIX for Dummies Questions & Answers


Does anyone know what LILO stands for and what it exactly does during the boot process? (1 Reply)
Discussion started by: jensam
1 Replies

10. UNIX for Dummies Questions & Answers

Red Hat and LILO

Hi well ive got a slight prob with LILO, ive been trying to delete my linux partition and merge my entire hard drive back into one but when I do so LILO is still there, even after I erase the linux partition and I was pretty sure that it was on the boot record or something anyway, but all it... (2 Replies)
Discussion started by: Drainy
2 Replies

Featured Tech Videos