Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Lilo
# 15  
Old 01-23-2002
I'm not sure where you are in your setup, but have you run /sbin/lilo since you created /etc/lilo.conf? If not, please do that. If so, did you get any errors? Did you get any feedback at all?

Also, what is happening when you try to boot? Are you getting a black screen with a blinking cursor at the top-left, or an error?

Please give me as much info as possible, and I'll try to help you out with this one.
# 16  
Old 01-24-2002
Actually i got to the lilo.conf in my /etc folder byitself after several install attempt of lilo. And i did /sbin/lilo as u said. It doesnt show anything. Also when i boot up there is no any black screen or blinking cursors. It goes to my Win2k directly without accesing the Lilo. If i put in the boot disk then i can go to Linux.
# 17  
Old 01-24-2002
Any other info that u wanted...? /var/log ? for anyone to help me..
this problem is quite frustrated but inneed an help. Pls help..
# 18  
Old 01-25-2002

OK, i did several self test on my system. I went to the /etc/lilo.conf and check all ok. But i found somehing unusual. does anyone have any idea ?? Here is what i got :
[root@trilium root] # /sbin/lilo
Warning: device0X0306 exceeds 1024 cylinder limit
Fatal: geo_comp_addr: Cylinder number is to big (1962 > 1023)

Any idea ???

here is how my /etc/lilo.conf looks like

boot= "/dev/hda"




Guys any one have any idea making Lilo alive back ??
Pls post. Smilie
# 19  
Old 01-25-2002
Hmm... Try adding "lba32" at the top of your lilo.conf.
What happens is that your kernel / boot files (system map, etc...) do not all completely lie in the first 1024 cylinders of your drive.

Please give that a shot - if it doesn't work, please post right back. I'll be here for a few more hours...
# 20  
Old 01-28-2002
I did try as you said. Its giving me the same error. One Question. Does it got anything to do with my HDD Size. Currently my hdd size is 20GB. And also yesterday, after backup my data i did try to reinstall my Linux. All the lilo installation and other installation is 100% Succesfull. But, lilo failed again. /etc/lilo.conf exists. cat the file all info is exactly the same. But no prompt up menu at all. Checked thru the KDE Control list for LILO. All are the same.
Any idea. Smilie
# 21  
Old 01-29-2002
I believe it does have to do with not only your HDD size, but where the boot files are placed on the disk...
I may be wrong here, but you MIGHT need your bootup files within the first 8 gig of disk (due to your bios)...

Also, try (I think the syntax is)
/sbin/lilo -v -lba32

I added the -v, so we can get a better idea of what's going on...
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

lilo question

I use redhat7.0, and I want to update kernel to 2.4.0,I make following steps: #gzip -cd linux-2.4.0.tar.gz | tar xvf - #cd linux #make mrproper #make config #make dep #make bzdisk #make modules #make modules_install #cp linux/arch/i386/boot/bzImage /boot then I modify lilo.conf,like... (0 Replies)
Discussion started by: konvalo
0 Replies

2. Red Hat

lilo.conf for lvm

Does anyone know how to write a lilo.conf for lvm configurations. I have the devices addressed as: /dev/VolGroup00/LogVol00 / (root) /dev/VolGroup00/LogVol01 (swap) When running lilo, Error states: can't put the boot sector on logical partition 0xFD02 Would... (2 Replies)
Discussion started by: imrank27
2 Replies

3. UNIX for Dummies Questions & Answers

removing lilo

I have a machine that dual boots win2k and linux, and we are handing it off so it no longer needs linux. Linux is a separate partition so I can delete the partition, but I need to remove lilo- how do I do that ? (7 Replies)
Discussion started by: dangral
7 Replies

4. UNIX for Dummies Questions & Answers

LILO question again. Need help.

I know that this question has been asked here many times before, but after 4hours of reading and conf file changing I'm still where I started. Here's the scenario. I have a machine that has 60GB HDD, RedHat 7.3 & Win2K. 19 first GB are win2k (FAT32; /dev/hda1). Then comes RedHat 7.3: hda2 -> /boot... (2 Replies)
Discussion started by: D-Lexy
2 Replies

5. UNIX for Dummies Questions & Answers

Linux Lilo

i hade and Win 2000 and and Linux 6.2 on a machine, the Lilo boot worked properly . . after i had changed the Partion size with Partion Magic in w2k and rebooted my computer hangs and just says "Li" in the upper left corner . . can some one plz explain to me where the problem is, can i get the... (2 Replies)
Discussion started by: sajjan2
2 Replies

6. Filesystems, Disks and Memory

I need help with lilo

:confused: I've been trying to figure out what happen to Windows 2000 since I upgrade my partition of Red Hat 7.1 to 7.2. Before I even upgraded my system would dual boot both OS's now it only sees Linux in lilo. Can some one help me I'm in need of help. Can you tell me what I'm missing in my... (3 Replies)
Discussion started by: aojmoj
3 Replies

7. Filesystems, Disks and Memory

Lilo Boot

i hade and Win 2000 and and Linux 6.2 on a machine, the Lilo boot worked properly . . after i had changed the Partion size with Partion Magic in w2k and rebooted my computer hangs and just says "Li" in the upper left corner . . can some one plz explain to me where the problem is, can i get the... (1 Reply)
Discussion started by: sajjan2
1 Replies

8. UNIX for Dummies Questions & Answers


I have installed linux.. but it wont boot.. it says: "LI" and then my computer freezes.. it has worked before.. A couple of days ago, I tried to install OpenBSD.. I used the whole disk for it.. I think it's something with the MBR-settings I made in the OpenBSD installation.. How can... (1 Reply)
Discussion started by: Hamcha
1 Replies

9. UNIX for Dummies Questions & Answers


Does anyone know what LILO stands for and what it exactly does during the boot process? (1 Reply)
Discussion started by: jensam
1 Replies

10. UNIX for Dummies Questions & Answers

Red Hat and LILO

Hi well ive got a slight prob with LILO, ive been trying to delete my linux partition and merge my entire hard drive back into one but when I do so LILO is still there, even after I erase the linux partition and I was pretty sure that it was on the boot record or something anyway, but all it... (2 Replies)
Discussion started by: Drainy
2 Replies
Login or Register to Ask a Question