Visit Our UNIX and Linux User Community


LILO question again. Need help.


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers LILO question again. Need help.
# 1  
Old 09-08-2002
LILO question again. Need help.

I know that this question has been asked here many times before, but after 4hours of reading and conf file changing I'm still where I started. Here's the scenario. I have a machine that has 60GB HDD, RedHat 7.3 & Win2K.
19 first GB are win2k (FAT32; /dev/hda1). Then comes RedHat 7.3: hda2 -> /boot 45.6MB, hda3 -> /usr 4.8GB, hda5 -> / 2.9GB, hda7 -> /home 28.5GB. The problem ofcourse is that the RedHat doesn't boot. When I power on I win2k starts booting. I installed Win2k before Linux. Linux boot loader was installed to hda2.

Here's my lilo.conf file:
=========================
prompt
timeout=50
default=linux
boot=/dev/hda2
map=/boot/map
install=/boot/boot.b
message=/boot/message
linear

image=/boot/vmlinuz-2.4.18-3
label=linux
initrd=/boot/initrd-2.4.18-3.img
read-only
root=/dev/hda5

other=/dev/hda1
optional
label=DOS
=================================
I just have no clue what to do to make lilo start and let me choose what OS to start. I know that I should have left all the startup info within 2GB but reinstalling everything would be a real pain since the machine has been used for a while. If anyone can help me I'd be glad!
TIA!!!
# 2  
Old 09-08-2002
Quote:
boot=/dev/hda2
This only writes to the boot sector of the PARTITION, not the master boot record (MBR). Change the line to /dev/hda and it should work.
# 3  
Old 09-09-2002
changed it to /dev/hda and wrote to MBR. same thing. The first time i installed redhat i actually wrote lilo to MBR and it was still Win2k booting.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #584
Difficulty: Easy
Binary files generally requires less space and are more efficient to process.
True or False?

10 More Discussions You Might Find Interesting

1. Slackware

Dealing with lilo and uefi

Recently I have been trying to boot into slackware on a new laptop that came preinstalled with windows 8. I have successfully installed slackware and Lilo, but I have had great difficult attempting to boot into it. Since the laptop contains no optical drive, I have been attempting to boot into... (2 Replies)
Discussion started by: a sandwhich
2 Replies

2. Red Hat

lilo question

I use redhat7.0, and I want to update kernel to 2.4.0,I make following steps: #gzip -cd linux-2.4.0.tar.gz | tar xvf - #cd linux #make mrproper #make config #make dep #make bzdisk #make modules #make modules_install #cp linux/arch/i386/boot/bzImage /boot then I modify lilo.conf,like... (0 Replies)
Discussion started by: konvalo
0 Replies

3. UNIX for Dummies Questions & Answers

removing lilo

I have a machine that dual boots win2k and linux, and we are handing it off so it no longer needs linux. Linux is a separate partition so I can delete the partition, but I need to remove lilo- how do I do that ? (7 Replies)
Discussion started by: dangral
7 Replies

4. UNIX for Dummies Questions & Answers

Linux Lilo

i hade and Win 2000 and and Linux 6.2 on a machine, the Lilo boot worked properly . . after i had changed the Partion size with Partion Magic in w2k and rebooted my computer hangs and just says "Li" in the upper left corner . . can some one plz explain to me where the problem is, can i get the... (2 Replies)
Discussion started by: sajjan2
2 Replies

5. Filesystems, Disks and Memory

I need help with lilo

:confused: I've been trying to figure out what happen to Windows 2000 since I upgrade my partition of Red Hat 7.1 to 7.2. Before I even upgraded my system would dual boot both OS's now it only sees Linux in lilo. Can some one help me I'm in need of help. Can you tell me what I'm missing in my... (3 Replies)
Discussion started by: aojmoj
3 Replies

6. Filesystems, Disks and Memory

Lilo Boot

i hade and Win 2000 and and Linux 6.2 on a machine, the Lilo boot worked properly . . after i had changed the Partion size with Partion Magic in w2k and rebooted my computer hangs and just says "Li" in the upper left corner . . can some one plz explain to me where the problem is, can i get the... (1 Reply)
Discussion started by: sajjan2
1 Replies

7. UNIX for Dummies Questions & Answers

Lilo

I have installed linux.. but it wont boot.. it says: "LI" and then my computer freezes.. it has worked before.. A couple of days ago, I tried to install OpenBSD.. I used the whole disk for it.. I think it's something with the MBR-settings I made in the OpenBSD installation.. How can... (1 Reply)
Discussion started by: Hamcha
1 Replies

8. UNIX for Dummies Questions & Answers

Lilo

Guys, Any idea how to Install Lilo after Instal linux 7.2 ( 2.4.7 ). At first when i was installing Linux 7.2 i didnt install LILO because i have alllready installed Boot Magic from Power Quest (Having dual boot Windows2000 Server and Linux Red Hat7.2 ). I didnt install LILO because i was... (20 Replies)
Discussion started by: killerserv
20 Replies

9. UNIX for Dummies Questions & Answers

Lilo

Does anyone know what LILO stands for and what it exactly does during the boot process? (1 Reply)
Discussion started by: jensam
1 Replies

10. UNIX for Dummies Questions & Answers

Red Hat and LILO

Hi well ive got a slight prob with LILO, ive been trying to delete my linux partition and merge my entire hard drive back into one but when I do so LILO is still there, even after I erase the linux partition and I was pretty sure that it was on the boot record or something anyway, but all it... (2 Replies)
Discussion started by: Drainy
2 Replies

Featured Tech Videos