WI(4) BSD Kernel Interfaces Manual WI(4)
wi -- WaveLAN/IEEE and PRISM-II 802.11 wireless network driver
wi* at pcmcia? function ?
wi* at pci? dev ? function ?
The wi driver provides support for Lucent Technologies WaveLAN/IEEE PCCARD adapters (also
known as WaveLAN II cards) and various PCI/MiniPCI/PCCARD adapters which use Intersil PRISM-
II and PRISM-2.5 chipsets. Note that while Lucent sells both ISA and PCMCIA WaveLAN/IEEE
devices, the ISA product is actually a PCMCIA card in an ISA to PCMCIA bridge adapter. Con-
sequently, the wi driver is required for both the ISA and PCMCIA NICs. Also note that some
of the PRISM-II adapters works only at 3.3V, hence cardbus(4) support is required for those
cards to set VCC correctly, even though they are 16-bit cards.
The core of the WaveLAN/IEEE is the Lucent Hermes controller. All host/device interaction
is via programmed I/O with the Hermes. The Hermes supports 802.11 and 802.3 frames, power
management, BSS, WDS and ad-hoc operation modes. The Silver and the Gold cards of the Wave-
LAN/IEEE also support WEP. Unlike the other IEEE 802.11 network cards, the WaveLAN Gold
cards accept 104 bits key (13 characters) for WEP encryption. The Intersil PRISM-II con-
troller supports WEP as well.
The wi driver encapsulates all traffic as 802.11 frames, however it can receive either
802.11 or 802.3 frames. Transmit speed is selectable between 1Mbps fixed, 2Mbps fixed or
2Mbps with auto fallback. For WaveLAN/IEEE Turbo adapters, speeds up to 6Mbps are avail-
able. For WaveLAN/IEEE Turbo 11Mbps adapters and PRISM-II adapters, speeds up to 11Mbps are
The wi driver supports configuration of Lucent cards for special ad-hoc operation. In this
mode, the nwid is ignored and stations can communicate among each other without the aid of
an access point. Note that this mode is specific to Lucent chips, and not in the IEEE
802.11 specification. Due to changes in the implementation of this special ad-hoc mode,
Lucent-based cards with different firmware revisions may not interoperate in this mode.
This mode is no longer the default and must be selected using the ifconfig(8) (media option
Recent versions of Lucent and PRISM-II firmware support IBSS creation. IBSS is the standard
IEEE 802.11 ad-hoc mode. In this mode, the nwid should be specified. At least one node
must be able to create IBSS. The IBSS mode is enabled by ``adhoc'' or ``ibss'' media
option. IBSS creation is automatically enabled if supported.
The wi driver defaults to infrastructure mode (i.e., using an access point).
Recent versions of PRISM-II firmware support operating as an 802.11 Access Point. In this
mode, the Access Point station should set the nwid. This will create a standard 802.11 net-
work, and the Access Point station will show up in an Access Point scan. This mode is
enabled using the ``hostap'' media option.
For more information on configuring this device, see ifconfig(8) and ifmedia(4).
Cards supported by the wi driver include:
Lucent WaveLAN/IEEE 2.0Mb Bronze
Lucent WaveLAN/IEEE 2.0Mb Silver
Lucent WaveLAN/IEEE Turbo
Lucent WaveLAN/IEEE Turbo 11Mbps
Melco AIR CONNECT WLI-PCM-L11, WLI-PCM-L11G
Melco AIR CONNECT WLI-CF-S11G
Compaq WL100 11Mbps Wireless
Corega Wireless LAN PCC-11, PCCA_11, PCCB_11
DEC/Cabletron RoamAbout 802.11 DS High Rate
D-Link DWL-520 11Mbps PCI Card, Revs. A1,A2,B1,B2
D-Link DWL-520 11Mbps PCI Card, Rev. C1 not supported, see atw(4)
D-Link DWL-520 11Mbps PCI Card, Rev. D not supported, see rtw(4)
D-Link DWL-650 11Mbps WLAN Card
D-Link DWL-650 11Mbps WLAN Card, Rev. P not supported (Prism 3 chipset)
D-Link DCF-650W CF Card
ELECOM Air@Hawk LD-WL11
ELSA AirLancer MC-11
Ericsson Wireless LAN
Farallon Skyline 11Mbps Wireless
Intel PRO/Wireless 2011 LAN PC Card
Intersil PRISM Mini-PCI
Linksys Group, Inc. Instant Wireless Network PC Card, CF Card
Linksys Group, Inc. Instant Wireless Network WMP11 PCI Card
Linksys Group, Inc. Instant Wireless Network WMP11v4 PCI Card not supported
NEC Wireless Card CMZ-RT-WP, PK-WL001, PC-WL/11C
Symbol Spectrum24 Wireless Networker PC Card, CF Card
SMC EZ Connect 11M Wireless CF Card SMC2642W
SMC EliteConnect Wireless Adapter PC Card SMC2531W-B
Z-Com XI-626 PCI Card
The original PRISM-I chipset is supported by the awi(4) driver.
wi%d: init failed The WaveLAN failed to come ready after an initialization command was
wi%d: failed to allocate %d bytes on NIC The driver was unable to allocate memory for
transmit frames in the NIC's on-board RAM.
wi%d: device timeout The WaveLAN failed to generate an interrupt to acknowledge a transmit
arp(4), ifmedia(4), netintro(4), pci(4), pcmcia(4), ifconfig(8), wiconfig(8)
HCF Light programming specification, http://www.wavelan.com.
The wi device driver first appeared in NetBSD 1.5.
The wi driver was written by Bill Paul <email@example.com>.
The execution of wiconfig(8) while the interface is down can produce some error messages.
BSD July 6, 2005 BSD