Visit Our UNIX and Linux User Community


OpenSSH


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers OpenSSH
# 1  
Old 03-09-2002
Question OpenSSH

Help! SSH is returning the following error message:

OpenSSL version mismatch. Built against 90581f, you have 90602f

How can I correct this?
# 2  
Old 03-09-2002
Question OpenSSH

By the way, I did download OpenSSH 3.1, which was just released on Thursday, but I have no idea what do do with it. The command line

./install

does nothing, and the command line

sh install-sh

runs into trouble with the "C compiler." Does anyone out there have the foggiest notion of what's going on? As far as I know, my system has all of FreeBSD 4.4 as part of its subsystem, so these scripts/programs/whatever shouldn't have trouble, right?[B]
# 3  
Old 03-09-2002
Do you have the latest GNU compiler (GCC) installed?
# 4  
Old 03-09-2002
Question OpenSSH

I'm guesing not. I've got a mostly stock Mac OS X 10.1.3. How can I check?
# 5  
Old 03-09-2002
IMHO ....

Actually if you are running FreeBSD, the easiest way to do these kinds of updates is to synchronize your ports tree.

Here are some instructions on how to do that.

After that you simply do:

1. cd /usr/ports/security/openssh

2. make

3. make install

4. make clean

And you should be all set (assuming that your DSA/RSA and host keys were already configured).

Of course, if you have problems with compilation, you also may have to update your gcc which I believe is under /ports/lang (I am not 100% sure, but since you have 4.4, you should be fairly current on gcc).

One more thing to look for: old crypto files, they may be
lurking around under /usr/lib.

Good Luck! Of course, remember to come back and share with us your solutions Smilie

Last edited by #1freebsddude; 03-09-2002 at 10:34 PM..
# 6  
Old 03-09-2002
Data OpenSSH

D'oh! The below was pasted from the command line:

[msp-??-???-??:~] root# cd /usr/ports/security/openssh
/usr/ports/security/openssh: No such file or directory.
[msp-??-???-??:~] root# cd /usr
[msp-??-???-??:~] root# cd /usr/ports
/usr/ports: No such file or directory.

No ports directory! Smilie
# 7  
Old 03-09-2002
OK that's no problem, you can just create /usr/ports as root yourself and follow the link I suggested to download and build (if you wish).

Again, the assumption is that you have a FreeBSD Unix machine, the procedures for an OSX install may be somewhat different.

Also, check to ensure that you do not have 2 different versions of libcrypto libraries, it may be picking up the old one.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #608
Difficulty: Easy
Python does not need compilation to binary to run.
True or False?

10 More Discussions You Might Find Interesting

1. Red Hat

Openssh 6.8

Hi im using redhat enterprise linux 7 im trying to update to the latest openssh version 6.8 i ran the command yum update openssh and this upgraded only to version 6.6 how can i update to the latest version 6.8? thanks! (5 Replies)
Discussion started by: guy3145
5 Replies

2. AIX

OpenSSH always ask for password

Hello together, I have a Problem with openssh on AIX 5.3. We have a big amount of AIX-hosts that run with openssh but one donīt! Every time we try to connect via ssh to the host, we get a password prompt. The myth ist, that there is no Error or somthing else. Here the output of ssh -vvvv to... (14 Replies)
Discussion started by: heifei
14 Replies

3. Fedora

OpenSSH Problem

Hello, I cannot seem to loggon to a machine using ssh/scp. Whenevr I do it closes the connection (error message : lost connection)but it appears to be the host machine closing rather than the destination which puzzles me even more. What is even weirder is that as a root user it works but as a... (1 Reply)
Discussion started by: mojoman
1 Replies

4. UNIX for Dummies Questions & Answers

SFTP with OpenSSH

Hi All, I am using SFTP command to download some files from a remote server. My both the servers are SFTP enabled. I am sending SFTP request to a Windows server from my Linux server via openSSH. and i have already exchanged publickey between both the servers. But still remote server is asking... (1 Reply)
Discussion started by: vipparlas
1 Replies

5. Solaris

openssh and chroot.

Hi all. I have installed openssh 5.3 and set up jailed root. It works almost as I want it to I cant cd to any directory above my ch root. my config : entry in passwd: test2:x:103:113::/users2/test2:/bin/false sshd_conf: Match User test2 ChrootDirectory /users2/%u # ... (4 Replies)
Discussion started by: vettec3
4 Replies

6. UNIX Desktop Questions & Answers

OpenSSH

Hello, I downloaded Cygwin to practice on my coursework from home. I was told to download the OpenSSH from Cygwin website so that I can access my files from home. However, the file saves itself with a cgi extension and I have no idea as to what I am supposed to do next. I found info on some... (1 Reply)
Discussion started by: feliks0
1 Replies

7. UNIX for Dummies Questions & Answers

A problem about openssh

When I first link a computer with ssh , the information "Warning: Permanently added ... (RSA) to the list of known hosts." will be occured. How can i avoid this information without use the parameter '-q'? tks!!! (2 Replies)
Discussion started by: ragehunter
2 Replies

8. AIX

openssh 5.0 with aix 5.3

Hi All, I upgraded my openssh to 5.0. Now I need to modify the sshd_config file to my company's new policy. My problem? There are two config file on my system: /usr/local/etc/sshd_config and /etc/ssh/sshd_config Which should I edit? Please help. Thanks. (1 Reply)
Discussion started by: itik
1 Replies

9. HP-UX

OpenSSH install

I'm trying to install OpenSSH on HP-UX 11.11, so, first of all, I was going to install OpenSSL, but I get an error message during "make test"... 23324:error:24064064:random number generator:SSLEAY_RAND_BYTES:PRNG not seeded:md_rand.c:503:You need to read the OpenSSL FAQ,... (8 Replies)
Discussion started by: untamed
8 Replies

10. UNIX for Dummies Questions & Answers

OpenSSH Patch

Hi there, I am trying to install a patch for OpenSSH that will allow for a HeartBeat function to keep me from going idle. I am using a Powerbook G4 with Tiger OS 10.4. I have downloaded the patch but when I try and run it using the command: I get the following information: I have tried... (1 Reply)
Discussion started by: perryl7
1 Replies

Featured Tech Videos