Visit Our UNIX and Linux User Community


A problem about openssh


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers A problem about openssh
# 1  
Old 08-21-2009
A problem about openssh

When I first link a computer with ssh ,
the information "Warning: Permanently added ... (RSA) to the list of known hosts." will be occured.

How can i avoid this information without use the parameter '-q'?
tks!!!
# 2  
Old 08-21-2009
The ssh protocol has a high paranoia level, for good reason. I don't know what you are trying to do - that would help a lot. Why can you not use -q if it does what you want?

I suppose you could redirect stderr to /dev/null but you would lose fatal error messages as well. No a great idea.
Code:
ssh [address] 2>/dev/null

# 3  
Old 08-21-2009
When you connect to a server via ssh, it sends the host key information. This is security feature. If you dont want to receive at all, that the server key should be saved in you $HOME/.ssh/authorized_keys file before attempting to connect.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #801
Difficulty: Medium
The CSS z-index property specifies the stack order of an element.
True or False?

10 More Discussions You Might Find Interesting

1. Red Hat

Openssh 6.8

Hi im using redhat enterprise linux 7 im trying to update to the latest openssh version 6.8 i ran the command yum update openssh and this upgraded only to version 6.6 how can i update to the latest version 6.8? thanks! (5 Replies)
Discussion started by: guy3145
5 Replies

2. Shell Programming and Scripting

Problem with perl openssh

hello, can anyone help me with this problem? im just a beginner and currently starting to program in perl, also i just installed openssh because what i really need is to ssh to a ubuntu server. so I tried my code: #!/usr/bin/perl use strict; use warnings; use Net::OpenSHH; my $ssh =... (4 Replies)
Discussion started by: samohung390
4 Replies

3. UNIX for Advanced & Expert Users

Problem with OpenSSH Remote Port Forwarding with Bind_address

As in the ssh(1) man page: -R bind_address:]port:host:hostport .......By default, the listening socket on the server will be bound to the loopback interface only. This may be overridden by specifying a bind_address. An empty bind_address, or the address `*', indicates... (2 Replies)
Discussion started by: ahmad.zuhd
2 Replies

4. Fedora

OpenSSH Problem

Hello, I cannot seem to loggon to a machine using ssh/scp. Whenevr I do it closes the connection (error message : lost connection)but it appears to be the host machine closing rather than the destination which puzzles me even more. What is even weirder is that as a root user it works but as a... (1 Reply)
Discussion started by: mojoman
1 Replies

5. AIX

AIX 6.1 - openssh - problem

Hello, I am new in aix unix. First i install openssl - success, next step i try install openssh when i put command geninstall -Y -d /myssh openssh.base i have this message: What is the problem? Thanks for help. Sorry for my bad english i still learning. ---------- Post updated at... (2 Replies)
Discussion started by: bieszczaders
2 Replies

6. UNIX Desktop Questions & Answers

OpenSSH

Hello, I downloaded Cygwin to practice on my coursework from home. I was told to download the OpenSSH from Cygwin website so that I can access my files from home. However, the file saves itself with a cgi extension and I have no idea as to what I am supposed to do next. I found info on some... (1 Reply)
Discussion started by: feliks0
1 Replies

7. UNIX for Dummies Questions & Answers

OpenSSH Patch

Hi there, I am trying to install a patch for OpenSSH that will allow for a HeartBeat function to keep me from going idle. I am using a Powerbook G4 with Tiger OS 10.4. I have downloaded the patch but when I try and run it using the command: I get the following information: I have tried... (1 Reply)
Discussion started by: perryl7
1 Replies

8. AIX

openSSH for AIX

Has anyone installed openSSH, or any alternate ssh on AIX 5.1 if so is there a web site with quick guide of do's and don'ts for installation / setup that can be recommended. Is it a straightforward install ? (2 Replies)
Discussion started by: gefa
2 Replies

9. UNIX for Dummies Questions & Answers

OpenSSH

Help! SSH is returning the following error message: OpenSSL version mismatch. Built against 90581f, you have 90602f How can I correct this? (21 Replies)
Discussion started by: chenly
21 Replies

10. UNIX for Dummies Questions & Answers

Problem installing openssh v2.9-p2

I am trying to install openssh v2.9-p2 on Solaris 8. I already installed zlib and openssl, as required in INSTALL file. But when I issue ./configure to configure openssh v2.9-p2 for my platform ( I got the sources), it stops in the folowing message: checking for OpenSSL directory... configure:... (1 Reply)
Discussion started by: htsubamoto
1 Replies

Featured Tech Videos