Visit Our UNIX and Linux User Community


Unmounting /home Permanently


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Unmounting /home Permanently
# 1  
Old 12-18-2001
Unmounting /home Permanently

Hi! I got tired of running out of disk space on the different partitions on my Solaris 8 Ultra 5 computer so I tried to make just a big / partition and install everything on that. But somehow I managed to get a 0 byte /home partition :-) I tried to delete this (By just clicking it in X-Windows and pressing delete) and make a new folder in / called home and use this instead. This worked fine until I restarted the computer. Then somehow the old 0 byte /home had returned and my own /home was gone.

Does anybody know how to delete this 0 byte /home permanently so that I can create my own /home again.

I heard I need to edit some partition file some ware but I'm not sure how.

Can anybody help me?

Best regards,
Anders Windelhed
# 2  
Old 12-18-2001
Just remove the info for /home from /etc/vfstab
# 3  
Old 12-19-2001
Hum... Maybe that's not the problem. I opened the /etc/vfstab file and it said nothing about /home. df -k doesn't either say anything about /home but I still cant create any directories in /home or remove it with rmdir.

What do you think?

$ pwd
/home
$ df -k
Filesystem kbytes used avail capacity Mounted on
/dev/dsk/c0t0d0s0 8565372 1038684 7441035 13% /
/proc 0 0 0 0% /proc
fd 0 0 0 0% /dev/fd
mnttab 0 0 0 0% /etc/mnttab
swap 258896 8 258888 1% /var/run
swap 284232 25344 258888 9% /tmp
$ mkdir test
mkdir: Failed to make directory "test"; Operation not applicable
$ ls
$ rmdir /home
rmdir: directory "/home": Directory is a mount point or in use
$


/etc/vfstab

#device device mount FS fsck mount mount
#to mount to fsck point type pass at boot options
#
#/dev/dsk/c1d0s2 /dev/rdsk/c1d0s2 /usr ufs 1 yes -
fd - /dev/fd fd - no -
/proc - /proc proc - no -
/dev/dsk/c0t0d0s1 - - swap - no -
/dev/dsk/c0t0d0s0 /dev/rdsk/c0t0d0s0 / ufs 1 no
-
swap - /tmp tmpfs - yes -
# 4  
Old 12-19-2001
can you

umount /home
then delete the 0 byte partition using

format

???Smilie

Last edited by thangorn; 12-19-2001 at 06:30 AM..
thangorn
# 5  
Old 12-19-2001
I tried to type “umount /home” and then my “self made” /home with my own user dir returnet! :-) but as soon as I restart the computer the empty read-only undeletable /home returns!

How do I use format to delete this unusable /home?
# 6  
Old 12-19-2001
You are running the automounter and you have a /home entry in /etc/auto_master. Turn off the automounter or at least remove the offending entry.
# 7  
Old 12-19-2001
Thanks!

I just put a # infront of /home in /etc/auto_master and now everything works fine!

Maximum respect!
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #344
Difficulty: Medium
In February 2005, Sun announced the Sun Grid, a grid computing deployment on which it offered utility computing services priced at US$2 per CPU/hour for processing and per GB/month for storage.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Unmounting NFS idle clients from server

Hello World, We have a software repository server in our environment which we use as an NFS server. Now this has been going on well before I was hired. Now, I observed many users not unmounting the NFS resources after their use. I ran showmount and it showed 513 current sessions. :wall: Is... (7 Replies)
Discussion started by: satish51392111
7 Replies

2. Shell Programming and Scripting

Validation of mounting and unmounting

Hi folks, I have below code for unmounting, but i need validation filesystem is unmounted or not, if not it give us error. Please confirm below code or need modification. Please suggest. umount /oradata if then echo "/oradata Unmounted Successfully" else echo... (3 Replies)
Discussion started by: learnbash
3 Replies

3. AIX

Error unmounting a remote mounted file system

Hi All, I'm facing an issue while trying to unmount a remotely mounted file system, strangely it's not even getting mounted, Kindly find the reply messages. Mounting error msg nfsmnthelp: 1831-019 <Server host>: Cannot mount a file system that is already remotely mounted. mount: 1831-008... (13 Replies)
Discussion started by: Abhishekag
13 Replies

4. UNIX for Advanced & Expert Users

gmail revert to old look permanently

I thought I would share gmail revert to old look permanently. I am sure I am not the only one annoyed by the new look. Install Stylish extension Choose the Stylish UserStyle that you want. I know The Return of Old Gmail and gmail-b2b both work but I prefer gmail-b2b since I think it looks... (0 Replies)
Discussion started by: cokedude
0 Replies

5. Solaris

delete routing permanently

How can I remove permanently a route from the routing table? I have the following: root@aiwutr1>netstat -rnv IRE Table: IPv4 Destination Mask Gateway Device Mxfrg Rtt Ref Flg Out In/Fwd -------------------- --------------- --------------------... (3 Replies)
Discussion started by: gianluca.p
3 Replies

6. AIX

Unmounting a failed NFS mount

I have an NFS file system mounted on one of my AIX servers with "mount -v cifs".. The server from which the file system was mounted has crashed and now my "df -g" output is hanging. Is there any was to unmount this NFS file system? I have tried "umount -f". Doesn't work. Or is there any way in... (6 Replies)
Discussion started by: wibhore
6 Replies

7. Shell Programming and Scripting

cp -p /home/* home/exp/*.date not working please help

:( ---------- Post updated at 01:51 AM ---------- Previous update was at 01:50 AM ---------- Not working ---------- Post updated at 02:04 AM ---------- Previous update was at 01:51 AM ---------- cp -p /home/* home/exp/*.`date` i am using this (4 Replies)
Discussion started by: rishiraaz
4 Replies

8. IP Networking

Changing the Ip adress permanently

well i'm trying to change the ip adress on an old alphaserver runing tru64 4.0F using the ifconfig hme0 IP_ADDRESS mask MASK broadcast BROADCAST and when i check it using ifconfig -a it shows the new ip and all is well but when the server is rebooted it reverts back to the old ip (3 Replies)
Discussion started by: randUSR()
3 Replies

9. AIX

unmounting problem

Hello, can someone help me with the problem am facing unmounting a filesystem I wanted to unmount /oradata cause i created it with a larger size and wanted to umount it , delete the fs and create again with less size. i have done below but nothing so far. 1) iam not in /oradata directory 2) i... (3 Replies)
Discussion started by: karthikosu
3 Replies

10. UNIX for Dummies Questions & Answers

Unmounting a cd in Solaris

I am having a rough time with unmounting a CD on a Solaris box. I am installing Oracle 8.1.7 for someone, and everything was going swell until the system tells me to put in CD 2. When I try to eject CD 1, nothing happens because the CD is still mounted. I looked on the man pages for rmmount to... (3 Replies)
Discussion started by: Jody
3 Replies

Featured Tech Videos