Visit Our UNIX and Linux User Community


Unmounting a cd in Solaris


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Unmounting a cd in Solaris
# 1  
Old 10-14-2002
Unmounting a cd in Solaris

I am having a rough time with unmounting a CD on a Solaris box. I am installing Oracle 8.1.7 for someone, and everything was going swell until the system tells me to put in CD 2. When I try to eject CD 1, nothing happens because the CD is still mounted. I looked on the man pages for rmmount to see if there was anything on there that would allow me to unmount the CD, but that was a waste of time. I even searched here on the forum, but the forum gave me nada. Can someone tell me how or point me in right direction of unmounting that CD so I can finish the Oracle installation?
# 2  
Old 10-14-2002
I hope this isn't the case, but...

Please don't take this the wrong way, but if you are in your mounted directory, you won't be able to umount it. Can't pull the rug out from under your own feet. Smilie

Post your error message so we can better help you.

I don't know what your level of expertise is with UNIX, but the command is "umount" not "rmmount". I believe that rmmount is a config file under /etc ... Although, I haven't used Solaris in a few years.

Here is a link that may help. I searched google for "solaris umount". Look at the commands fuser and lsof for files that may still be accessed from the disk.

http://www.netsys.com/sunmgr/1999-04/msg00149.html

Hope this helps you.

Smilie
# 3  
Old 10-14-2002
The command is:
eject

Is that what you meant when you said you tried to eject the cd? If the eject command is failing run:
eject -d
to see if knows about the device. Did you mount this manually? On a sun you should just insert a cd and it should mount itself. Did that happen? If vold running? (ps -ef | grep vold)

See the man page on eject for more ideas. But sometimes you need to kill and restart vold:
/etc/init.d/volmgt stop
/etc/init.d/volmgt start
But that should be a last resort.
# 4  
Old 10-14-2002
When I tried to umount /cdrom/oracle8i, the error I received was "/cdrom/oracle8i is busy". When I keyed in eject, the message came back and said "/usr/sbin/rmmount(this is where I got rmmount from): umount of /cdrom/oracle8i failed returning 1 /vol/dev/rdsk/c1t6d0/oracle8i Device busy.

The CD did mount automatically, and eject -d did give me a default device(the CD drive). ps -ef | grep vold did show that Volume Management was working. I went ahead and stopped it and restarted it, which let me get the CD out. However, now CD 2 will not mount. I do not have much experience with Solaris, but I do believe that I am going to have to start over on my install now, or perhaps I could get some practice doing some Olympic Solaris Box Roof Tossing to relieve my frustration Smilie.

Oh well, thanks anyway, guys!!
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #747
Difficulty: Medium
The Z80 uses 248 out of the available 256 codes as single byte opcodes.
True or False?

7 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Unmounting NFS idle clients from server

Hello World, We have a software repository server in our environment which we use as an NFS server. Now this has been going on well before I was hired. Now, I observed many users not unmounting the NFS resources after their use. I ran showmount and it showed 513 current sessions. :wall: Is... (7 Replies)
Discussion started by: satish51392111
7 Replies

2. Shell Programming and Scripting

Validation of mounting and unmounting

Hi folks, I have below code for unmounting, but i need validation filesystem is unmounted or not, if not it give us error. Please confirm below code or need modification. Please suggest. umount /oradata if then echo "/oradata Unmounted Successfully" else echo... (3 Replies)
Discussion started by: learnbash
3 Replies

3. AIX

Error unmounting a remote mounted file system

Hi All, I'm facing an issue while trying to unmount a remotely mounted file system, strangely it's not even getting mounted, Kindly find the reply messages. Mounting error msg nfsmnthelp: 1831-019 <Server host>: Cannot mount a file system that is already remotely mounted. mount: 1831-008... (13 Replies)
Discussion started by: Abhishekag
13 Replies

4. AIX

Unmounting a failed NFS mount

I have an NFS file system mounted on one of my AIX servers with "mount -v cifs".. The server from which the file system was mounted has crashed and now my "df -g" output is hanging. Is there any was to unmount this NFS file system? I have tried "umount -f". Doesn't work. Or is there any way in... (6 Replies)
Discussion started by: wibhore
6 Replies

5. Solaris

Unable to login using ssh,telnet onto my solaris machine with solaris 10 installed

Hi, I am unable to login into my terminal hosting Solaris 10 and get the below error message "Server refused to allocate pty ld.so.1: sh: fatal: libc.so.1: open failed: No such file or directory " Is there anyways i can get into my machine and what kind of changes are required to be... (7 Replies)
Discussion started by: sankasu
7 Replies

6. AIX

unmounting problem

Hello, can someone help me with the problem am facing unmounting a filesystem I wanted to unmount /oradata cause i created it with a larger size and wanted to umount it , delete the fs and create again with less size. i have done below but nothing so far. 1) iam not in /oradata directory 2) i... (3 Replies)
Discussion started by: karthikosu
3 Replies

7. UNIX for Dummies Questions & Answers

Unmounting /home Permanently

Hi! I got tired of running out of disk space on the different partitions on my Solaris 8 Ultra 5 computer so I tried to make just a big / partition and install everything on that. But somehow I managed to get a 0 byte /home partition :-) I tried to delete this (By just clicking it in X-Windows and... (8 Replies)
Discussion started by: alfabetman
8 Replies

Featured Tech Videos