Visit Our UNIX and Linux User Community


mysql installation error using redhat 7.2


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers mysql installation error using redhat 7.2
# 1  
Old 11-14-2001
mysql installation error using redhat 7.2

i am a newbie to unix admin stuff so bare with me. -- i get this message when executing mysql_install_db during the installation of mysql. what is the cause of this and how can it be fixed. btw - i have tried installing as root and other accounts also.


scripts/mysql_install_db: ./bin/my_print_defaults: cannot execute binary file
WARNING: The host 'localhost.localdomain' could not be looked up with resolveip.
This probably means that your libc libraries are not 100 % compatible
with this binary MySQL version. The MySQL deamon, mysqld, should work
normally with the exception that host name resolving will not work.
This means that you should use IP addresses instead of hostnames
when specifying MySQL privileges !
mkdir: cannot create directory `./data/mysql': Permission denied
chmod: getting attributes of `./data/mysql': Permission denied
mkdir: cannot create directory `./data/test': Permission denied
chmod: getting attributes of `./data/test': Permission denied
Preparing db table
Preparing host table
Preparing user table
Preparing func table
Preparing tables_priv table
Preparing columns_priv table
Installing all prepared tables
scripts/mysql_install_db: ./bin/mysqld: cannot execute binary file
Installation of grant tables failed!

Examine the logs in ./data for more information.
You can also try to start the mysqld daemon with:
./bin/mysqld --skip-grant &
You can use the command line tool
./bin/mysql to connect to the mysql
database and look at the grant tables:

shell> ./bin/mysql -u root mysql
mysql> show tables

Try 'mysqld --help' if you have problems with paths. Using --log
gives you a log in ./data that may be helpful.

The latest information about MySQL is available on the web at
http://www.mysql.com
Please consult the MySQL manual section: 'Problems running mysql_install_db',
and the manual section that describes problems on your OS.
Another information source is the MySQL email archive.
Please check all of the above before mailing us!
And if you do mail us, you MUST use the ./bin/mysqlbug script!
# 2  
Old 11-14-2001
First you need to fix your "localhost.localdomain" problem. Put your real hostname in /etc/hostname and a proper entry in /etc/hosts and then reboot.

Next, make sure you are trying the install as root -- that should fix any "permission denied" errors you are seeing.

Finally, RedHat provides a mysql rpm package which would make the install much easier. Recommend installing that rather than trying to do it manually.
# 3  
Old 11-14-2001
thanks, there are several mysql rpm's, which ones should I install?

I know this one
MySQL 3.23.44 Server

But what about these?
MySQL 3.23.44 Benchmark/test suites
MySQL 3.23.44 Client programs
MySQL 3.23.44 Libraries and Header files for development
MySQL 3.23.44 Client shared libraries
# 4  
Old 11-15-2001
You almost certainly need the "Client Programs" and "Client Shared Libraries". You only need the "Benchmark" if you want to benchmark MySQL, and you only need the "Libraries and Header Files" if you want to write C/C++ programs which interface directly with your database. (i.e. if you are using a pre-built interface such as Perl, PHP, etc) you wont need this one.
# 5  
Old 11-15-2001
thanks again --- another problem

installing the 'client programs' rpm using the following command line: rpm -ivv MySQL-client-3.23.44-1.i386.rpm, I get the following error, thus it does not install correctly.

error: unpacking of archive failed on file /usr/bin/mysql;3bf412e3: cpio: MD5 sum mismatch

I get the same type of error when installing the 'Client Shared Libraries' rpm. Can I get some more help? Thanks.

Last edited by theDirtiest; 11-15-2001 at 03:33 PM..
# 6  
Old 11-15-2001
i think i might know what the problem is. i downloaded those two rpm's on a windows machine, and then ftp'd them to a linux box, then secured copied them to the machine that i tried to install them on. unlike the server rpm, which i downloaded directly.

I got the following warning when I wanted to see what the rpm would install: rpm -qpl MySQL-client-3.23.44-1.i386.rpm

warning: Expected size: 1773110 = lead(96)+sigs(68)+pad(4)+data(1772942)
warning: Actual size: 1773090

All that transferring must have mess with the size of the rpm or something (like I said I'm new to this). So I will download directly to the machine when I get home and then try it again. Thanks.
# 7  
Old 11-15-2001
it worked - great


thanks again
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #564
Difficulty: Medium
The negation operator is a null task operator not a unary operator.
True or False?

10 More Discussions You Might Find Interesting

1. Red Hat

Dependency Error for OpenSSL i686 installation in Redhat 7.4 x64

Hi, I am unable to install openssl package due to some of the dependencies: # rpm -i openssl098e-0.9.8e-29.el7_2.3.i686.rpm warning: openssl098e-0.9.8e-29.el7_2.3.i686.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY error: Failed dependencies: libcom_err.so.2 is needed by... (0 Replies)
Discussion started by: rsimpossible86
0 Replies

2. UNIX for Beginners Questions & Answers

Redhat installation

Hi everyone, i am new to unix system. i got a project to install a web server (grafana)and database(influxdb) to install in redhat 7. The alloted space for my virtual machine is 1.3 TB . i don't have any idea how to allocate this space for redhat directories. DO i have to continue with the basic... (1 Reply)
Discussion started by: munnancs
1 Replies

3. Red Hat

configuring MYsql db on redhat cluster

Hello, can someone please suggest me in configuring the mysql db on redhat cluster, I have few questions. 1. where do I have to configure heart beat links, and is there any file in the redhat cluster that we update it to use these ipaddress and these interface on the node. 2. I am configuring... (0 Replies)
Discussion started by: bobby320
0 Replies

4. Red Hat

Redhat 9 installation problem

All, I am trying to install redhat9 to my system. I have 26 GB of unpartitioned space, and I do have xp-2 already installed on my system in c: . I am using external DVD-RW to install linux. I have booted the CD, chosen Graphical mode and now installation frizzed with below message: ... (5 Replies)
Discussion started by: joshilalit2004
5 Replies

5. Red Hat

Help with Redhat installation problem

Hello; I have 4 servers with RedHat Enterprise server 32-bit installed. i'm trying to install 64-bit system instead but the hardware has only CD drive (not DVD). When i tried to use external DVD drive and connect it to the USB to install the 64-bit system, it starts ok but then it ask for the... (2 Replies)
Discussion started by: Katkota
2 Replies

6. Red Hat

remote redhat installation

Hi guys! I have fedora6 on server and i want redhell5 to be on it. The problem is that the server is located from me several hundred kilometers away. So the only access i have is ssh. On my notebook i have iso-image with redhell5. How can install redhell5 on it and deinstall fedora6? Thanks in... (8 Replies)
Discussion started by: smallman
8 Replies

7. Red Hat

"No Drives Found" error during Redhat Linux AS 4 installation

I'm trying to install Redhat LInux AS 4 update 4 on an IBM x306 series server. I keep getting following error: "No Drives Found. An error has occurred - no valid devices were found on which to create new file systems. Please check your hardware for the cause of this problem." I called IBM and... (2 Replies)
Discussion started by: pieman8080
2 Replies

8. UNIX for Advanced & Expert Users

Redhat 7.3 Installation

Hi, I am trying to install Redhat 7.3 on a Compaq Proliant Server but after booting from CD1 it gives following "SYSLINUX 1.52 Unknown Keyword in Syslinux.cfg Could not find Kernel Image boot: I don't know what this means. I tried the same CD on a... (4 Replies)
Discussion started by: s_aamir
4 Replies

9. UNIX for Dummies Questions & Answers

mysql in redhat

Does anyone know how to get mysql up and running with the installed version that comes with redhat linux? I've spent hours with no progress. Thank you (13 Replies)
Discussion started by: gparsons70
13 Replies

10. UNIX for Dummies Questions & Answers

oracle installation on redhat 7.0/7.1

can anybody tell me that whether oracle 8i is installable on redhat 7.0/7.1. for me it is only working successfully on redhat 6.1 but not later versions cheers (3 Replies)
Discussion started by: balu
3 Replies

Featured Tech Videos