Visit Our UNIX and Linux User Community


mysql in redhat


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers mysql in redhat
# 1  
Old 10-29-2001
mysql in redhat

Does anyone know how to get mysql up and running with the installed version that comes with redhat linux?
I've spent hours with no progress.
Thank you
# 2  
Old 10-29-2001
Which part are you having problems with? If you have installed the redhat rpm, just do:

/etc/init.d/mysqld start


to start the server.


If you have already tried that, please provide more specific details of where you are having problems.
# 3  
Old 10-29-2001
mysql problem

When I varify the mysql-server package it says that theres a problem with /var/log/mysqld.log . I went there and found nothing. Also when I do "mysql &" it comes back with a error saying connot connect to local mysql server through socket '/var/lib/mysql/mysql.sock . I went there and nothing was there. It seems that the mysql server package out of the redhat box may have a problem. I've varified the mysql server package right off the disk and it comes back with a problem warning.

Last edited by gparsons70; 10-29-2001 at 11:59 PM..
# 4  
Old 10-29-2001
I have reinstalled my linux

I have reinstalled linux and the same problem exists. Is there something I'm not doing or is there a package that i'm not installing

Last edited by gparsons70; 10-30-2001 at 12:03 AM..
# 5  
Old 10-30-2001
rpm sayes many packages missing

ok I did a rpm on my system which is redhat professional server 7.1. I found out that many packages are missing. Some of these are not installing correctly. Such as mysql-server. Has anyone had this problem? Is there a way around this. Redhat that touts their support all over their $200 software box is next to imposible to contact and when you do it's to tell you that you need to contact some other department. Point-- Don't buy software that you can download for free thinking you will increace your learning curve. You'll just be throuing your money away!!! Nomatter how much they tout their docs(junk) or customer service.
# 6  
Old 10-30-2001
Make sure you have the rpm's correctly installed. Use your installation CD, or visit the RedHat ftp site. You will need to install:

mysql-3.23.36-1.i386.rpm
mysql-server-3.23.36-1.i386.rpm
mysqlclient9-3.23.22-4.i386.rpm

and possibly

mysql-devel-3.23.36-1.i386.rpm


Install those with 'rpm -Uvh <filenames>'

If you get messages about missing dependancies you will have to install additional packages. Once you have those installed, try running '/etc/init.d/mysqld start' and let us know what the output is.
# 7  
Old 10-30-2001
When you start mysqld are you starting as root or are you starting as another user?

The reason I ask is that if your mysqld process does not have the proper permissions to write to the directories you reference in your posts, then problems occur. If you are starting mysqld as a non-root user, you must set the permissions appropriately for the logfile and the other file.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #987
Difficulty: Medium
The FreeBSD TCP/IP stack is based on the 4.2BSD implementation of TCP/IP.
True or False?

6 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Sort command results are different in Redhat 4 vs Redhat 5

Hi, I am having a text file with the following contents ########### File1 ########### some page1.txt text page.txt When I sort this file on Red Hat 5, then I get the following output ########### File1 ########### page1.txt page.txt some (3 Replies)
Discussion started by: sarbjit
3 Replies

2. Red Hat

configuring MYsql db on redhat cluster

Hello, can someone please suggest me in configuring the mysql db on redhat cluster, I have few questions. 1. where do I have to configure heart beat links, and is there any file in the redhat cluster that we update it to use these ipaddress and these interface on the node. 2. I am configuring... (0 Replies)
Discussion started by: bobby320
0 Replies

3. UNIX and Linux Applications

MySQL Daemon failed to start - no mysql.sock file

After doing a yum install mysql mysql-server on Fedora 14 I wasn't able to fully install the packages correctly. It installed MySQL 5.1. I was getting the following error when running the: mysql ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)... (3 Replies)
Discussion started by: jastanle84
3 Replies

4. Web Development

Unkown table Engine 'InnoDB' on a RedHat server with MySQL v5!

hi all, After installing MySQL Source Code on my RedHat machine and compiling it, i no longer have access to some of my DBs having this error message. Unkown table Engine 'InnoDB' Before this step, i used to have another MySQL instance that used to work properly with all the DBs i do have,... (7 Replies)
Discussion started by: mehdi1973
7 Replies

5. UNIX for Advanced & Expert Users

MYSQL command to take a backup of the database in Redhat linux 7.2

I am new to mysql database , we have a mysql database running on linux , and we use mysql database for bugzilla, so we wanted to take a backup . what is the command for taking the entire database backup from the command prompt with all options. Thanks in advance Bache Gowda (4 Replies)
Discussion started by: bache_gowda
4 Replies

6. UNIX for Dummies Questions & Answers

mysql installation error using redhat 7.2

i am a newbie to unix admin stuff so bare with me. -- i get this message when executing mysql_install_db during the installation of mysql. what is the cause of this and how can it be fixed. btw - i have tried installing as root and other accounts also. scripts/mysql_install_db:... (6 Replies)
Discussion started by: theDirtiest
6 Replies

Featured Tech Videos