Loading JDK1.3 on Sparc2.6


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Loading JDK1.3 on Sparc2.6
# 8  
Yes, as you can see from the error message, the problem is that the binary cannot find the required dynamic lib when the binary is executed, which is a problem based on the dynamic loader (linker) and not something a patch fixes.


One quick way to fix this is to copy the libs to a standard ld path, like /usr/lib or /usr/local/lib (you might have to run a command like ldconfig or whatever for Solaris to insure the ld cache is updated). However, normally, there is an environmental variable for this (and this is my preferred approach). If you don't use env vars, then the ld config file is preferred. (this is all a matter of personal choice, however, and some folks just copy the files to /usr/local/lib or some place like that....)

# 9  
I would like to use an enviornment variable, however I do not know which one to use. we have a LD_LIBRARY_PATH which equals a ton of directories associated with another application on this machine. We also had a JAVA_PATH which I do not see any more. The symbolic link,?? can that be changed to point to the libraries. It now points to /usr/java/jre? What am I exactly suppose to point to. Is it /usr/j2se/jre/lib or one of the directories I wrote out in my long reply above? There is also a /usr/j2se/lib directory so I am very confused as to what variable to use and what lib directory cannot be found. Thanks again.
# 10  
LD_LIBRARY_PATH is a good environmental variable for adding directories to the LD (dynamic loader) search path. This path is not for Java classes, but for the libs (lib*.so and lib*.a files). There is a different environmental variable for the search path for Java classes.
# 11  
Data

Sorry this is still dragging on. I added to LD_LIBRARY_PATH /usr/j2se/jre/lib/sparc/client:/usr/j2se/jre/lib/sparc/server:/usr/j2se/lib/sparc:/usr/j2se/lib:/usr/j2se:

It didnt work (Do i need to reboot?) I then added this stuff to the PATH variable as well, same result. I keep getting;

Error: failed /usr/j2se/jre/lib/sparc/client/libjvm.so, because ld.so.1: /bin/../java/bin/../bin/sparc/native_threads/java: fatal: libCrun.so.1: open failed: No such file or directory

I cant find this libCrun.so.1 myself? Any further ideas? What is that file? Thank you so much for your valuable input so far.

Jim
# 12  
Question libCrun.so.1 not on my system?

I cannot find the file libCrun.so.1 but I did find it was included in Patch 105591-09. All attempts to add this patch seemed to fail. At first I was warned that patchadd was being used isntead of installpatch as the instructions stated. Then I seemed to get it to install by using pkgadd -d <dir>/<patch-id>/pkg SUNMlibC.

Hoever, the file is still not there. Isn't it possible i am missing this file in the /user/lib directory and how do I get it? This is becomming much more difficult then i could have imagined. Thank You
# 13  
You have to search your filesystem for the file, libCrun.so.1 using some version of the find command (as you like) find / | grep libCrun.so.

Sometimes there has been a new version, i.e. libCrun.so.14 installed and you have to fix the symbolic link etc. For example, if a binary is built to load libCrun.so.1 and there is a patch or upgrade to libCrun.so and the current version is libCrun.so.19, you must create a symbolic link as required.

[Edited by Neo on 01-26-2001 at 12:59 AM]
# 14  
Question

The jdk is the latest from sun and it seems to be looking for libCrun.so.1 so i believe that is the latest version of that file. I will try to find the file on the machine but I do not understand how I can load a patch that specifically states it has that file included in it and then I cant find the file. What is the best way to do a full machine search for a file as i am still very new to this system. thanks again.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #166
Difficulty: Easy
The Internet is a packet-switched network.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

When loading Linux "loading please wait.." then nothing?

Hi everyone, I have a problem but I have never installed a separate OS before so my lingo and understanding may not be as good as some of you. I will try and explain my problem best I can. I am trying to instead of loading Windows 7 when my computer starts up, for it to start linux specifically... (2 Replies)
Discussion started by: markhow30
2 Replies

2. Red Hat

Loading Expect

I need to get expect/tcl loaded on a Linux machine I have access to. Im not an admin so Im not sure what to ask for. Here is what we are running ... a Redhat clone from what I understand. CentOS release 6.4 (Final)... (1 Reply)
Discussion started by: sumguy
1 Replies

3. Solaris

Installing JDK1.6.0 on SOLARIS 10

Hello everyone, Can you help me please. I have to install JDK 1.6.0 under Solaris sparc 64 bits machine. Is this the steps to do it the right way ? 1- Install JDK 1.6.0 for 32 bits machine before installing the package for 64 bits machine? 2- gunzip jre1.6.0.tar.gz 3- tar -vxf... (1 Reply)
Discussion started by: adilyos
1 Replies

4. Solaris

Oracle VM for sparc2.0 (Ldoms)

Does any one has idea about when Ldoms2.0 is gonna be available for download? (1 Reply)
Discussion started by: fugitive
1 Replies

5. BSD

GUI not loading...

I tried FreeBSD VMimage on my VMWare based on XP, but I failed to load the GUI, orI don't know to load the GUI. Terminal is freely working over it. (5 Replies)
Discussion started by: budtuxy
5 Replies

6. Programming

facing problem with IBMTriggerMonitor in hp-ux with jdk1.6

Hi, We are facing problem with IBMWebsphereMQ6.0 TriggerMonitor while invoking java appliation in hp-ux with jdk1.6. With other versions of jdk triggermonitor is able to invoke the java application successfully in the same environment. We are facing problems with jdk1.6 only. Following is the... (3 Replies)
Discussion started by: urspradeep330
3 Replies

7. AIX

loading subsets

In aix 5.2, we are trying to update with the latest subsets for "bos.adt.debug package". the subset version we have is 33 and the latest available is 95. Would like to know whether i need to load all the versions from 34 to 95 or can i load the latest version directly? (1 Reply)
Discussion started by: mjdarm
1 Replies

8. Shell Programming and Scripting

Function loading in a shell scripting like class loading in java

Like class loader in java, can we make a function loader in shell script, for this can someone throw some light on how internally bash runs a shell script , what happenes in runtime ... thanks in advance.. (1 Reply)
Discussion started by: mpsc_sela
1 Replies

9. SuSE

Error when loading

Hi all, I'm trying to install Open SUSE and after the installation it will not boot. At first I thought it could be something wrong with the setup so I re-installed. Then it would still fail on the boot. When trying to boot in safe mode these are the last few lines just before it just sits... (7 Replies)
Discussion started by: woofie
7 Replies

10. UNIX for Dummies Questions & Answers

TCP/IP Not Entirely Loading

When our SCO UNIXWARE 7.4 System starts up we receive the following log indicating that its not loading successfully. I have pasted the txt file for review. Can someone please help? UX:S69inet: INFO: The following commands ran from /etc/init.d/inetinits This command will link the TCP/IP... (0 Replies)
Discussion started by: Yorgy
0 Replies

Featured Tech Videos