Loading JDK1.3 on Sparc2.6


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Loading JDK1.3 on Sparc2.6
# 1  
Question

I have followed instructions to get the jdk for sparc, 1.3 loaded on this sparc workstation machine. I used a tar file and everything seemed to go fine. The usr/j2se directory was created with all the subdirectories and java files. However, attempting to run Java commands fails with a file not found error. It is not a path issue as I created a symbolic link and it does start to open up java. I will try to post the exact message on a follow up. Do I need to load some of the many patches I read about to get this to work? I have not loaded any as I thought it should at least run without the bug fixes. Any help will be most appreciated.
# 2  
In our JDK distros, there is an environmental variable which has a Java class path to help the JVM find the classes. The installation instructions normally have a step to set these environmental variables. (I put them in /etc/profile)
# 3  
Computer

Thankyou, however we have those set correctly I believe. The java engine actually is starting to launch and then it fails. I have seen it with the path not known and the error is simple not found. Being on 2.6 I think the application of required patches may be the key as some of those patches seem to address library files and other things mentioned in our error. Does this make sense?
# 4  
Did you compile the Java binaries for static or dynamic libs? Sometimes problems with dynamic lib paths will cause the binary to fail after execution. Did you install the libs and update the dynamic linker configuration file (if using dynamic libs)? Or do you have statically linked binary?
# 5  
>Did you compile the Java binaries for static or dynamic >libs? Sometimes problems with dynamic lib paths will cause >the binary to fail after execution. Did you install the >libs and update the dynamic linker configuration file (if >using dynamic libs)? Or do you have statically linked >binary?

I did not compile the Java binaries unless the unpacking of the tar file did that for me. I followed directions I got from sun and for Java 2 SDK Installation for Solaris.
They said in part....
On Sparc:

zcat j2sdk-1_3_0-solsparc.tar.Z | tart -xf -

I got 4 packages, became root and installed the packages

pkgadd -d . SUNWjrt etc......

I then had a usr/j2se directory fully loaded and it looked fine. I did not do anything else other then set the symbolic link which had pointed to usr/java1.1 to my new directory, trying bin and then jre with the same results both times. So I dont know how to answer your question.

I did not to anything with the location of libjvm location. There was a note in the instructions about the path within the SDK to the HotSpot Client VM:

jre/lib/sparc/client/libjvm.so

The path to the HotSpot Server VM:

jre/lib/sparc/server/libjvm.so

I did not know what to do with these being a newbie here. So does any of this ring a bell for you? Thanks.
# 6  
Yes, you have dynamic loadable binaries with the pre-compiled distro. This means that your shell must know where to find the java dynamic libs. This can be done with an environmental variable (sometimes) like LDCONFIG (if your system has or uses this) or adding the path to a similar configuration file (if your system uses that Smilie )

Which environmental vars are used/installed for this application ? You can find them (on most OS)by typing the <B>env</B> command. Also, find out how your system handles dynamic loadable libs.

# 7  
Error

Thanks. so it is not the lack of patches!?
I have run env but will look further based on your comments.
Here is the exact error we get by the way:

Error: failed /usr/j2se/jre/lib/sparc/client/libjvm.so, because ld.so.1: /bin/../java/bin/../bin/sparc/native_threads/java: fatal: libCrun.so.1: open failed: No such file or directory
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #783
Difficulty: Medium
Microsoft launched its first retail version of Microsoft Windows in 1983.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

When loading Linux "loading please wait.." then nothing?

Hi everyone, I have a problem but I have never installed a separate OS before so my lingo and understanding may not be as good as some of you. I will try and explain my problem best I can. I am trying to instead of loading Windows 7 when my computer starts up, for it to start linux specifically... (2 Replies)
Discussion started by: markhow30
2 Replies

2. Red Hat

Loading Expect

I need to get expect/tcl loaded on a Linux machine I have access to. Im not an admin so Im not sure what to ask for. Here is what we are running ... a Redhat clone from what I understand. CentOS release 6.4 (Final)... (1 Reply)
Discussion started by: sumguy
1 Replies

3. Solaris

Installing JDK1.6.0 on SOLARIS 10

Hello everyone, Can you help me please. I have to install JDK 1.6.0 under Solaris sparc 64 bits machine. Is this the steps to do it the right way ? 1- Install JDK 1.6.0 for 32 bits machine before installing the package for 64 bits machine? 2- gunzip jre1.6.0.tar.gz 3- tar -vxf... (1 Reply)
Discussion started by: adilyos
1 Replies

4. Solaris

Oracle VM for sparc2.0 (Ldoms)

Does any one has idea about when Ldoms2.0 is gonna be available for download? (1 Reply)
Discussion started by: fugitive
1 Replies

5. BSD

GUI not loading...

I tried FreeBSD VMimage on my VMWare based on XP, but I failed to load the GUI, orI don't know to load the GUI. Terminal is freely working over it. (5 Replies)
Discussion started by: budtuxy
5 Replies

6. Programming

facing problem with IBMTriggerMonitor in hp-ux with jdk1.6

Hi, We are facing problem with IBMWebsphereMQ6.0 TriggerMonitor while invoking java appliation in hp-ux with jdk1.6. With other versions of jdk triggermonitor is able to invoke the java application successfully in the same environment. We are facing problems with jdk1.6 only. Following is the... (3 Replies)
Discussion started by: urspradeep330
3 Replies

7. AIX

loading subsets

In aix 5.2, we are trying to update with the latest subsets for "bos.adt.debug package". the subset version we have is 33 and the latest available is 95. Would like to know whether i need to load all the versions from 34 to 95 or can i load the latest version directly? (1 Reply)
Discussion started by: mjdarm
1 Replies

8. Shell Programming and Scripting

Function loading in a shell scripting like class loading in java

Like class loader in java, can we make a function loader in shell script, for this can someone throw some light on how internally bash runs a shell script , what happenes in runtime ... thanks in advance.. (1 Reply)
Discussion started by: mpsc_sela
1 Replies

9. SuSE

Error when loading

Hi all, I'm trying to install Open SUSE and after the installation it will not boot. At first I thought it could be something wrong with the setup so I re-installed. Then it would still fail on the boot. When trying to boot in safe mode these are the last few lines just before it just sits... (7 Replies)
Discussion started by: woofie
7 Replies

10. UNIX for Dummies Questions & Answers

TCP/IP Not Entirely Loading

When our SCO UNIXWARE 7.4 System starts up we receive the following log indicating that its not loading successfully. I have pasted the txt file for review. Can someone please help? UX:S69inet: INFO: The following commands ran from /etc/init.d/inetinits This command will link the TCP/IP... (0 Replies)
Discussion started by: Yorgy
0 Replies

Featured Tech Videos