Loading JDK1.3 on Sparc2.6


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Loading JDK1.3 on Sparc2.6
# 15  
I would execute this command:
Code:
find / | grep -i libCrun

and search the entire file system for every occurance of the libCrun token. If you run the command above and you don't find it, then it has not been installed. You might find libCrun.so.14 or libCrun.so.2 (just making up names of files) etc.
You can also do something like:
Code:
find / | grep -i libCrun > /tmp/foo

and post the results (the contents of /tmp/foo) here.

# 16  
I ran the command. It only finds the file in the directory where I placed the patch before loading it. I do not know why the patch did not place that fiel properly, do you know why that might happen? Also, should I just move the files from the /lib directory in the patch itself to my systems /lib directory?

Here is the output from the command:
you will note that patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
is where I put the patch.

# find / | grep -i libCrun
/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/net/localhost/opt/home/peri/patches/105591-09/SUNWlibC/reloc/usr/lib/libCrun.so.1
# 17  
You found it!!

OK, now you found it (many times, what's up with that circular link problem?, BTW)

Copy libCrun.so.1 to /usr/local/lib or /usr/lib. Make sure you cache your ldconfig and this small step of your epic journey is done Smilie

Also, suggest you track down and fix that misconfigured (symbolic) link that is causing the circular listing pattern above.

[Edited by Neo on 01-26-2001 at 12:37 PM]
# 18  
Tools

Ok, I did move those but I also found other errors asking for other files which led to other patches. I installed all these patches and Java came up fine!!!! SO, as a newbie, I am pretty proud of the fact that I first said it was patches missing from my machine. You seemed to say no, so I wasn't all wet! Anyway, my forte4j IDE is trying to come up but stops short referencing another file, I wiull work that out or post a new question. Can you recommend a solid book for a beginner so I won't have long episodes like this anymore?

AND

How do you get rid of the circular links you noted?

THANK YOU VERY MUCH NEO, YOU ARE A GREAT HELP.
# 19  
To me, patches are something that are applied to source code and recompiled to correct errors. Adding dynamic libs etc. may be called 'patches' by the vendors, but they are not really patches, per se. In all technologies, the use of terms and changing uses of terms are always a core source of confusion.

So, because a vendor provides dynamic libs in 'patch format' does not make them 'patches'. In many systems, they are simply 'the libraries', etc. Installing libs are not patching source code and recompiling; so as a newbie, you need to be aware of that. All you did was install dynamic libs (reuseable binary modules)and these libs may or maynot be used for other distributions besides your Java JDK install.

BTW, if installing reuseable code modules (libs) were patches, then the entire concept of object oriented programming would then be called 'patchwork'!! Smilie


On your circular links, you need to look at the filesystem and study the links that have been created to trace down the problem. I suggest you look at the books recommended in threads in this forum (do a search) and get a good book on shell programming. It is time to close this particular thread, IMHO. Great job getting your JDK up and running.

BTW: If you can't get your circular links problem solved, please feel free to start a new thread on that particular problem/issue.

Perhaps others (in the future) with similar lib problems will find this thread helpful also.

[Edited by Neo on 01-26-2001 at 06:49 PM]
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #153
Difficulty: Easy
Novell sold their Unix business operations to Microsoft in 1995.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

When loading Linux "loading please wait.." then nothing?

Hi everyone, I have a problem but I have never installed a separate OS before so my lingo and understanding may not be as good as some of you. I will try and explain my problem best I can. I am trying to instead of loading Windows 7 when my computer starts up, for it to start linux specifically... (2 Replies)
Discussion started by: markhow30
2 Replies

2. Red Hat

Loading Expect

I need to get expect/tcl loaded on a Linux machine I have access to. Im not an admin so Im not sure what to ask for. Here is what we are running ... a Redhat clone from what I understand. CentOS release 6.4 (Final)... (1 Reply)
Discussion started by: sumguy
1 Replies

3. Solaris

Installing JDK1.6.0 on SOLARIS 10

Hello everyone, Can you help me please. I have to install JDK 1.6.0 under Solaris sparc 64 bits machine. Is this the steps to do it the right way ? 1- Install JDK 1.6.0 for 32 bits machine before installing the package for 64 bits machine? 2- gunzip jre1.6.0.tar.gz 3- tar -vxf... (1 Reply)
Discussion started by: adilyos
1 Replies

4. Solaris

Oracle VM for sparc2.0 (Ldoms)

Does any one has idea about when Ldoms2.0 is gonna be available for download? (1 Reply)
Discussion started by: fugitive
1 Replies

5. BSD

GUI not loading...

I tried FreeBSD VMimage on my VMWare based on XP, but I failed to load the GUI, orI don't know to load the GUI. Terminal is freely working over it. (5 Replies)
Discussion started by: budtuxy
5 Replies

6. Programming

facing problem with IBMTriggerMonitor in hp-ux with jdk1.6

Hi, We are facing problem with IBMWebsphereMQ6.0 TriggerMonitor while invoking java appliation in hp-ux with jdk1.6. With other versions of jdk triggermonitor is able to invoke the java application successfully in the same environment. We are facing problems with jdk1.6 only. Following is the... (3 Replies)
Discussion started by: urspradeep330
3 Replies

7. AIX

loading subsets

In aix 5.2, we are trying to update with the latest subsets for "bos.adt.debug package". the subset version we have is 33 and the latest available is 95. Would like to know whether i need to load all the versions from 34 to 95 or can i load the latest version directly? (1 Reply)
Discussion started by: mjdarm
1 Replies

8. Shell Programming and Scripting

Function loading in a shell scripting like class loading in java

Like class loader in java, can we make a function loader in shell script, for this can someone throw some light on how internally bash runs a shell script , what happenes in runtime ... thanks in advance.. (1 Reply)
Discussion started by: mpsc_sela
1 Replies

9. SuSE

Error when loading

Hi all, I'm trying to install Open SUSE and after the installation it will not boot. At first I thought it could be something wrong with the setup so I re-installed. Then it would still fail on the boot. When trying to boot in safe mode these are the last few lines just before it just sits... (7 Replies)
Discussion started by: woofie
7 Replies

10. UNIX for Dummies Questions & Answers

TCP/IP Not Entirely Loading

When our SCO UNIXWARE 7.4 System starts up we receive the following log indicating that its not loading successfully. I have pasted the txt file for review. Can someone please help? UX:S69inet: INFO: The following commands ran from /etc/init.d/inetinits This command will link the TCP/IP... (0 Replies)
Discussion started by: Yorgy
0 Replies

Featured Tech Videos