apache issues

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers apache issues
# 1  
Old 09-16-2001
apache issues

hi guys!

well, as some of you might have noticed, i was having issues getting my linux box going correctly -- well, after some long hours and the help of you guys and my trusty o'reilly linux in a nutshell book, everything's runing great and i'm getting much more comfortable using the file system, understanding the interoperability, etc ... totally seeing why you guys love it so much.

here's the question -- went throught the archives and couldn't really find an answer so, here goes. i d/l apache, compiled, installed, etc -- went in and set the defaults in my httpd.conf file. when i typed localhost into my browser, nothing -- it did the netscape search bit. so, i backed up my httpd.conf and dumped the default back in and still nothing. when i run apachectl start, it says the server's going, so -- any solutions?

also, i'm assuming if i set the default host to the machine's IP, i'll be able to hit it from any machine on my network by entering that ip into a browser, correct?

thanks for the help, guys -- keep spreadin the linux love.

// trent
# 2  
Old 09-16-2001
Apache web server has logfiles. What do the logfiles say?

On our servers, the logfiles are in /usr/local/apache/logs .... however, this is configuration dependent.

You should be able to look at the logfiles and get a clue as to what is going on.
# 3  
Old 09-16-2001
ok, here's what my log says, and i have practically no clue what it means ... this is written after starting

1) [alert] (22) Invalid argument : setgid: unable to set group id to Group 4294967295

// it has this like 5 times

2) [alert] Child 17435 returned Fatal Error ... Apache is exiting!

and then another instance of the first one. so -- obviously it's shutting down because of something wrong in the httpd.conf file?
# 4  
Old 09-16-2001
There is a problem with the ownership (user, group) of the files in the apache distribution. You need to make sure that the user:group ownership of all files are valid system users and that the httpd.conf file is correctly configured as well.

This is outlined pretty well in the Apache book by O'Reilly. Might help to run to your local bookstore and get a copy!
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Linux

Apache httpd configuration - Issues with APR

Hi I have tried setting up of Apache http server - httpd-2.4.25. During configuration, I understand it needs APR to be setup. Hence I have downloaded APR & APR-Util. Performed, tar xvfC apr-1.5.2.tar /root/httpd-2.4.25/srclib/apr What is happening is there is another directory... (1 Reply)
Discussion started by: videsh77
1 Replies

2. Red Hat

Process not running: /opt/java15/jdk/bin/java -classpath /opt/apache/apache-ant-1.7.0-mod/lib/ant-la

Have no idea on what the below error message is: Process not running: /opt/java15/jdk/bin/java -classpath /opt/apache/apache-ant-1.7.0-mod/lib/ant-launcher.jar org.apache.tools.ant.launch.Launcher -buildfile build.xml dist. Any help? (3 Replies)
Discussion started by: gull05
3 Replies

3. Web Development

Apache module development on apache 2.2

Hi, I'm new to developing modules for Apache. I understand the basics now and can develop something simple which allows a 'GET' request to happen, but what I want to do is actually 'POST' information to my site. I know the basic POST Request works and I can see that it is post by looking at... (2 Replies)
Discussion started by: fishman2001
2 Replies

4. Web Development

Apache write permission issues to another user owned directory

Hi I am trying to make a web program which is command line equivalent. i have done the coding in cgi program in perl and html for basic forms to take inputs. when i ran the program from web application i see permission denied messages. after analyzing i found apache is running as wwwrun which... (2 Replies)
Discussion started by: rakeshkumar
2 Replies

5. UNIX for Advanced & Expert Users

Vsftpd serious issues

hello mighty all there's a problem in vsftpd it allows to delete files which have 000 mode and root:root owner also 400 even with option deny_file={those_files} - still allowed i'm doing it through mc through ftp-shell it's not allowed it's not working if mother-dir have -w and not working... (3 Replies)
Discussion started by: tip78
3 Replies

6. Emergency UNIX and Linux Support

rm -rf issues

We are using the solaris server and if i am using rm -rf to delete the directories its asking the confirmation for each and every file inside the directory.Is there any way to disable ( should not ask the confirmation) only for a particular session? (12 Replies)
Discussion started by: sureshbabuc
12 Replies

7. Red Hat

Apache / Tomcat / APR Issues [RHEL]

Evening, I'm posting for help here, because I'll be honest I've reached the end of my tether, hopefully someone can give me some assistance and help me maintain a level of sanity... I maintain a number of webservers on RHEL 5 64Bit (Red Hat Enterprise Linux Server release 5.3 (Tikanga)), the... (2 Replies)
Discussion started by: cpickering
2 Replies

8. Web Development

Using IP.Board on FreeBSD, having SQL/Apache Issues

Server: FreeBSD 7.2-RELEASE MYSQL Version: MYSQL 5.1.36 PHP Version: 5.2.10 (apache2handler) IP.Board Version: v3.0.2 Safe Mode: OFF For the most part previously IP.Board, forum software, has run fine without any issues. Regular web pages and .php pages seem to load fine without any issues.... (2 Replies)
Discussion started by: Dark Severance
2 Replies

9. Shell Programming and Scripting

SU issues

Hi, I have automated a build process that does the following activities. 1. check out code from cvs to a specific directory 2. build the revision checked out with 'ANT' 3. integrate the compiled code with the QA/UAT or new environment (/apps/QA or /apps/UAT or /apps/new directory) I... (1 Reply)
Discussion started by: yoi2hot4ya
1 Replies

10. UNIX for Dummies Questions & Answers

issues involving sshd, display and apache.

I have a rather peculiar problem in the past 2 weeks. I have a network setup with a linux box acting as a gateway (It is exposed to the internet). Also, there are 2 additional machines that are connected to the gateway (and are not exposed to the outside world). (The gateway has a NAT setup to... (5 Replies)
Discussion started by: ceeeyem
5 Replies
Login or Register to Ask a Question