Visit Our UNIX and Linux User Community


Using IP.Board on FreeBSD, having SQL/Apache Issues


 
Thread Tools Search this Thread
Top Forums Web Development Using IP.Board on FreeBSD, having SQL/Apache Issues
# 1  
Old 08-17-2009
Using IP.Board on FreeBSD, having SQL/Apache Issues

Server: FreeBSD 7.2-RELEASE
MYSQL Version: MYSQL 5.1.36
PHP Version: 5.2.10 (apache2handler)
IP.Board Version: v3.0.2
Safe Mode: OFF

For the most part previously IP.Board, forum software, has run fine without any issues. Regular web pages and .php pages seem to load fine without any issues. However they reset the server and everything was installed with default settings, as far as I know.

I'm not really an admin who deals with the back-end of things. I usually only admin the software side of things. However I do have root access and am able to modify and set things up. Currently it looks like it is a server configuration issue with something. Possibly optimization or setups for the SQL side of things. It looks like when requesting pages it queries and things are getting stuck or hanging. I either have to repair some of the tables or restart the server.

Anyone have suggestions or ideas on optizing mySQL, apache, php that I can look in trying to make things more stable?
# 2  
Old 08-17-2009
# 3  
Old 08-17-2009
Thank you. That helped quite a bit. But now I'm getting the following error:
"ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)"

There isn't a mysql.sock in /tmp. However /tmp does have the following permissions:
drwxrwxrwt 6 root wheel 512 Aug 17 20:07 .

Originally it was just a default setup. There was no my.cnf file. I found a .cnf file in /usr/local/share/mysql/my-medium.cnf and used that to configure options in mysql. I moved it to /var/db/mysql and renamed it my.cnf. Restarted, everything seemed fine. I was able to log into mysql but now I can't seem to login and I'm not sure why. I did try commenting out the socket part in my.cnf but that didn't seem to help.

EDIT:


I found a couple other default .cnf files. There was my-medium.cnf (which I originally used), my-small.cnf and my-large.cnf. I ran a diff to compare to the originals. It looks like the issue is related to these two lines:

query_cache_size = 8M
thread_cache_size = 4

That was causing the problem. When I removed them. Everything seemed to work fine... well at least I could use: mysql -u root -p

What did those commands do that caused it to not work?

Last edited by Dark Severance; 08-17-2009 at 06:36 PM..

Previous Thread | Next Thread
Test Your Knowledge in Computers #89
Difficulty: Easy
Software management applications like the Ubuntu Software Center are front-ends to the core terminal commands use to install and manage software applications.
True or False?

10 More Discussions You Might Find Interesting

1. BSD

FreeBSD DHCP wpa_supplicant Wi-Fi Issues

I just got FreeBSD up and running with an XFCE desktop on an old Gateway laptop. It works great, except the wireless setup is scaring me. I can connect to my home WiFi fine most of the time, but I'm concerned about other WiFi that I will need to connect to away from home. I understand that I can... (1 Reply)
Discussion started by: BrentBANKS
1 Replies

2. AIX

Networking Issues - Opera, FreeBSD, AIX

(1) Hi, Am working on FreeBSD 7.4/i386 and installed Opera 11.01 through ports collection manually... But when I run first time am getting "opera: cannot connect X server. Error: Unknown error: 0" What is this error all about???? Please help me to sort out this issue!!! (2) Hi, currently am... (12 Replies)
Discussion started by: Priya Amaresh
12 Replies

3. BSD

FreeBSD AMD NFS over TCP issues

Hi! I have a major issue with FreeBSD 7.1 i386. We did a change in our Unix env where we exchanged home storage from a NetAPP running udp to a NetAPP running tcp. Now I cant mount homedirs since NFS/AMD seem to fallback to udp :( Trying to force it with amd options nfs_proto=tcp and so on. ... (0 Replies)
Discussion started by: Esaia
0 Replies

4. Solaris

E4500 Disk board issues

Hi there, I'm building a couple of E4500's both with the same spec and seem to be having an issue with the disk boards on each. I’m running the following config E4500 6 x 400MHz, 6GB, 2 x X2612A with cards, 1 x disk board with 2 x 9.1GB 10K Disk I have configured the machine as... (0 Replies)
Discussion started by: wallrunn3r
0 Replies

5. UNIX for Dummies Questions & Answers

Resolved: htpasswd issues (-b) on FreeBSD

I wrote a script to batch-create directories with .htaccess and .htpasswd files. I am using the following line to create the .htpasswd file: htpasswd -cb .htpasswd $USER $PASS However, I keep getting this message in return: Usage: htpasswd passwordfile username The -c flag creates a new... (1 Reply)
Discussion started by: Spetnik
1 Replies

6. BSD

FreeBSD - Kernel Queries/Issues

All, I am a bit of a BSD newbie and haven't really played with it for years, but I have had a recent situation whereby someone attempted to load a custom kernel module and ended up breaking my BSD server. I managed to fix it by doing the following: Booting into loader mode: unload set... (3 Replies)
Discussion started by: drbabbers
3 Replies

7. UNIX for Dummies Questions & Answers

Some FreeBSD issues

I have been using Linux for 3 years now, and I think I am getting enough knowledge (and confidence) to try some more 'traditional' unix variants. I installed FreeBSD 5.0-CURRENT. I have a couple of questions for the time being: 1) Frequently when I need to compile software packages they can't... (16 Replies)
Discussion started by: cbkihong
16 Replies

8. UNIX for Advanced & Expert Users

snort installation on freebsd issues

i'm following the, "How to setup and secure Snort, MySQL and Acid on FreeBSD 4.6 Release" off of the snort.org website. in the documentation it says snort should be installed through the following: ----- make -DWITH_MYSQL -DWITH_FLEXRESP ; make install ----- later it says to do the... (13 Replies)
Discussion started by: xyyz
13 Replies

9. UNIX Desktop Questions & Answers

FreeBSD 4.7 X issues - assistance req'd please

question: i just installed FreeBSD 4.7 on my laptop, when i log in as root, i can startx no problem at all but when i try to start it as a user, i can't. otiginally it told me i needed to be a member of the group 'wheel' to do startx, no problem, added myself in /etc/group, but for some reason i... (1 Reply)
Discussion started by: Calum
1 Replies

10. UNIX for Dummies Questions & Answers

apache issues

hi guys! well, as some of you might have noticed, i was having issues getting my linux box going correctly -- well, after some long hours and the help of you guys and my trusty o'reilly linux in a nutshell book, everything's runing great and i'm getting much more comfortable using the file... (3 Replies)
Discussion started by: aenemated
3 Replies

Featured Tech Videos