Visit Our UNIX and Linux User Community


SU issues


 
Thread Tools Search this Thread
Top Forums Shell Programming and Scripting SU issues
# 1  
Old 10-09-2007
SU issues

Hi,
I have automated a build process that does the following activities.
1. check out code from cvs to a specific directory
2. build the revision checked out with 'ANT'
3. integrate the compiled code with the QA/UAT or new environment
(/apps/QA or /apps/UAT or /apps/new directory)

I have separated this into two scripts. The first one does steps 1 and 2 and then calls number 3. The reason that they are separated is that based on permissions steps 1 and 2 can be done only by and individual id while step 3 has to be done by the build user account that owns the integrated environments.

Here is the problem. I made the process interactive using 'select' contructs to allow the user to select different options. After steps 1 and 2 are completed I am executing and 'su' to switch to the build id to integrate the compiled code. However there are options in the second script also. For some reason when I 'su' the shell goes into an infinite loop when I prompt the user for feedback in the second script. It doesn't wait for response. I this the behavior of 'SU'? Is there any way around this? Thank you.

Here's how I su over in the script:
Code:
su - $vBuildUser <<-EOF
eval "$unixBuild -s $vSystem -r $vRevision -e $vIntegratedEnvironment"
wait
EOF
exit
exit

This User Gave Thanks to yoi2hot4ya For This Post:
# 2  
Old 10-09-2007
anyone have any hints, ideas, suggestions?

Previous Thread | Next Thread
Test Your Knowledge in Computers #237
Difficulty: Easy
Paul Baran was the first to build a theoretical model for communication using packet switching.
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Function Issues

I am converting English letters/words/punctuation in leet speak. My current script works just fine, but when I call the functions it seem to be bypassing my second function altogether. I am new to shell scripting so excuse me if its an easy fix. Also, when using SED for whole word phrases like... (4 Replies)
Discussion started by: bri09
4 Replies

2. Shell Programming and Scripting

Issues when dividing

Hi, I do have a very simple task to divide 2 variables and display the result. I CANNOT use bc when i try var1=2 var2=4 var3=$(($var1 / $var2)) echo $var3 the output is always 0 What can I change to get a dotted decimal result such as 0.5 ? Thanks! (5 Replies)
Discussion started by: svetoslav_sj
5 Replies

3. Emergency UNIX and Linux Support

rm -rf issues

We are using the solaris server and if i am using rm -rf to delete the directories its asking the confirmation for each and every file inside the directory.Is there any way to disable ( should not ask the confirmation) only for a particular session? (12 Replies)
Discussion started by: sureshbabuc
12 Replies

4. Shell Programming and Scripting

Issues with Expect

Here is a snippet of code that work for me: expect "abc" {send_log "abc found" } \ "def" {send_log "def found" } \ "123" {send_log "123 found} however the following does not and according to the book "Exploring Expect" it should be equivalent: expect { "abc"... (1 Reply)
Discussion started by: twk
1 Replies

5. AIX

lpstat issues

Hi, I tried to migrate a server, I installed AIX on a new server and I want to configure the printer queues. I copied all of files from the old server where the printer queues are working fine. I followed these steps: 1. copy the /etc/qconfig (make a copy of the original before) 2. Copy the... (10 Replies)
Discussion started by: imad77
10 Replies

6. Solaris

Issues with ldd

I tried to compile php and integrate it into apache on solaris. It compiled ok and I created a package. If I install it on a system that has the libpng from sunfreeware, it wants to use that library instead of the system SUNWpng. It doesn't run using SMCpng, but it runs using the system SUNWpng.... (4 Replies)
Discussion started by: Mike_the_Man
4 Replies

7. HP-UX

swinstall issues

what the heck am I doing wrong? Im trying to install bastille and i keep getting errors. # cd - /var/spool/sw # ls B6849AA_B.02.01.03.depot catalog swagent.log var # swinstall -s /var/spool/sw B6849AA ======= 10/04/07 09:47:43 EDT BEGIN swinstall... (4 Replies)
Discussion started by: csaunders
4 Replies

8. Shell Programming and Scripting

while loop issues

Hi guys, Been sifting through these forums for awhile, but never had an account or needed to post. Shoutouts to a great forum with heaps of useful info. Now i consider myself a noob when it comes to linux and to bash scripting. I recently started to learn to use Vmware ESX server which uses... (4 Replies)
Discussion started by: ryath
4 Replies

9. UNIX for Dummies Questions & Answers

scripting issues...

Hi guys, I am thanks in advance for any posts and for reading. I am trying to run this script, under solaris: echo "****************************************" echo "The host is: " echo "****************************************" <<EOF find /etc/default -name login -exec ls -l {} \; find... (5 Replies)
Discussion started by: B14speedfreak
5 Replies

Featured Tech Videos