Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers StartX
# 1  
Old 09-03-2001

Hi guys Smilie

I'm having a slight problem. Every time I run the StartX command from my csh, it just says cannot access terminal. Can anyone tell me why this is and what it means?

Thank you Smilie

# 2  
Old 09-04-2001
Can you give more details?
What OS? How are you accessing that machine...
from the console? from a terminal? from Windows
# 3  
Old 09-04-2001
hi mate,

Thanks for the reply. I'm sorry I've been so vague with every question I've asked but I've kind of been set a 'Linux Challenge', and although I'm allowed to ask for help, I can't be incredibly specific (which is frustrating the hell outta me.).

Apparently, StartX has been disabled, so my situation is this. A Linux environment (using a C-shell.) has been completely tailored for me to solve a challenge. I'm not allowed to use any scripts, I have no permissions on practically everything as I'm supposed to use my observation skills to determine my goal.

Now here's my problem. Whenever I type "echo" with anything after it, it will ALWAYS output:


So even if I try "echo 'Hi, how are you?'", it would always output: $input. I'm pretty certain that my goal lies within this variable, but it won't let me print the damn thing. I've tried cat $input, print $input, print($input), but nothing happens (most commands have been disabled too to be incredibly restrictive.)

Is there a way to display the contents of a variable, without the use of any scripting, and without the cat/print commands?

Thanks guys, sorry to harp on about this.

# 4  
Old 09-04-2001
sounds to me like you're not even running the
"real" echo command. What do you get when
you run: which echo

I'm wondering if you're "environment" has it
(and other commands) aliased to somthing else.
In any case, it sounds like you're being tested
so I'm not sure how much info. I should give Smilie
# 5  
Old 09-04-2001
Maybe double substitution could be an idea? Try using eval and see what happens, that is if eval works...
# 6  
Old 09-04-2001
hi mate Smilie

I've run "which echo" but it comes up with nothing. It's just a simulation, there are no marks for this or anything like that. It's more of a "test project" to see if linux newbies (not computer newbies.) are able to investigate and find holes in systems by doing their own research.

I mean with regards to Linux, I really don't know anything, and most of the things I've read up on have been disabled which is why I've resulted to asking questions in here in the hope I can find something. I totally apologise if this is the wrong place to post in but I just can't find anywhere else that will help.

Thanks again Smilie

# 7  
Old 09-04-2001
Smilie eval didn't work Smilie

Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Screen Goes Black When Run startx

Have - HP G4p DL360 SCSI version (*see below of pdf of server basics if needed) Scientific Linux live-cd.iso Issue - When it boots off the LiveCD, all starts swell, but if I install the OS normal it goes to a black monitor.... If I install text only, it works and when done I am at the... (4 Replies)
Discussion started by: sas
4 Replies

2. Ubuntu

startx not working for 8.04.4

Hi, I am running Ubuntu 8.04.4 on a Sun Blade 1000 SPARC. I installed both kubuntu and xubuntu in attempt to load a gui onto the machine. Both fail when trying to start them. When I use startx I get the following error: (EE) Failed to laod module... (0 Replies)
Discussion started by: swilso
0 Replies

3. Debian

kde, startx on debian

Hello :-)! I installed Debian (I downloaded it on may 2009 so it is new version) from CD. I run it and see only text console. I try to type "kde" or "startx" but it doens't recognize those commands. That's difficult for me to believe that Linux from CD doesn't contain graphical interface so I... (2 Replies)
Discussion started by: johnyjj2
2 Replies

4. Shell Programming and Scripting

Scripts after startx

I want to autorun a shell script which inculde start two java programs and some shell scripts I using fedora 9 and I had put in Personal > Sessions /bin/sh / but it got a problem when I start firefox from one of the java program, it said "Firefox is already running but not... (3 Replies)
Discussion started by: uativan
3 Replies

5. Shell Programming and Scripting

startx and then firefox

I have edited /etc/inittab to auto login as root in level 3 and edited .bash_profile to auto start x window I would like to auto start a firefox browser after go into x window. I tried to add "firefox" in /etc/rc.d/rc.local but no effects. Anyone have suggestion? Thanks in advance. (1 Reply)
Discussion started by: uativan
1 Replies

6. UNIX Desktop Questions & Answers

KDE and startx

Hello, Ive installed freeBSD 6.0 - and the prompt part of the system works well. Ive then tried to install KDE for graphic interface to the unix system. The problem is: Whenever I run "$ startx" it starts some graphical interface, but its totally swirled, you can sense that in the background... (1 Reply)
Discussion started by: congo
1 Replies

7. UNIX for Advanced & Expert Users

startx / xterm

When I try to run startx or xterm the window opens fine, however when using keyboard incorrect chars are displayed, e.g pressing return displays 2 (0 Replies)
Discussion started by: gefa
0 Replies

8. Debian

error startx with debian

hello i have installed xfree86 with debian 2.4, but i have the message when i launch startx: XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining. xauth: (argv):1: bad display name ""... (0 Replies)
Discussion started by: pascalbout
0 Replies

9. UNIX for Dummies Questions & Answers

Help with FreeBSD and startx.

Hello everyone. I just installed FreeBSD recently and when I type the command startx, I get the following errors: (EE) failed to load module "fbdev" (EE) <default pointer> cannot find which device to use (EE) xf860Open erial: No evice specified (EE) <default pointer> cannot open input... (3 Replies)
Discussion started by: cosmotron
3 Replies

10. UNIX for Dummies Questions & Answers

startx, xauth msg and Solaris 8

I just built my first Solaris 8 machine. I start x using this command (assume I'm in the correct directory): ./startx After I run this command, I receive this extremely frustrating message: /startx: XAUTHORITY=//.Xauthority: is not an identifier Can someone tell me what I am doing... (4 Replies)
Discussion started by: rpeteg
4 Replies
Login or Register to Ask a Question