Visit Our UNIX and Linux User Community


startx, xauth msg and Solaris 8


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers startx, xauth msg and Solaris 8
# 1  
Old 12-01-2001
Data startx, xauth msg and Solaris 8

I just built my first Solaris 8 machine. I start x using this command (assume I'm in the correct directory):

./startx

After I run this command, I receive this extremely frustrating message:

/startx: XAUTHORITY=//.Xauthority: is not an identifier

Can someone tell me what I am doing incorrectly?


Other vitals:

Running Solaris 8 (7/01 release) on an INTEL machine

Thanks!

Pete
# 2  
Old 12-03-2001
Hi Pete.

It seems like your startx script is using korn shell or bash shell to export variables (like "export VAR=value"). Since Solaris uses bourne shell as default, you can try using korn shell before starting the startx script. You can also include #!/bin/ksh or #!/bin/bash in the first line of the startx script. That may solve your problem. Any problems, let me know.

HTT
# 3  
Old 12-04-2001
Hi Pete!

About the new errors you got, you can search for xinit script in your system (I´m not sure but it may be in /usr/X11R6/bin or something like that). If you find it, you can do two things: you can put the full path in startx script (line 81, as ksh tells) or you can set-up your PATH environmental variable to include xinit´s path. If you set-up PATH variable you do not have ro change your startx script. Any problems let me know.

HTT
# 4  
Old 12-04-2001
Thank You . . .

The xinit script and the startx script are both in the same folder:

/usr/X11R6/bin

So, I'm a bit confused as to why startx cannot seem to find xinit?

I really appreciate your help!

Pete
# 5  
Old 12-04-2001
Hi Pete.

Try this:
# PATH=$PATH:/usr/X11R6/bin
# export PATH
# startx

It must help

HTT
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #353
Difficulty: Medium
mawk is a very fast AWK implementation by Mike Brennan based on a Python interpreter.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

What is the use of .msg fils in Solaris?

I am new to SOlaris OS, compilation using make files etc. I have a code base that I am trying to compile under Solaris 2.5 OS. IT has a folder structure, where the root folder contains the master make file which calls each of the make files present in the subfolders to compile the code in... (1 Reply)
Discussion started by: rajujayanthy
1 Replies

2. BSD

problems with authorization via `xauth'

Dear all, I've got problems with X server authentication using `xauth'. The problem is, that I have my local computer running NetBSD 5.1 and a remote computer in LAN which is running Debian GNU Linux. During the login to my NetBSD computer `xdm' generates a magic cookie for my DISPLAY. Then I... (2 Replies)
Discussion started by: sidorenko
2 Replies

3. Ubuntu

startx not working for 8.04.4

Hi, I am running Ubuntu 8.04.4 on a Sun Blade 1000 SPARC. I installed both kubuntu and xubuntu in attempt to load a gui onto the machine. Both fail when trying to start them. When I use startx I get the following error: (EE) Failed to laod module... (0 Replies)
Discussion started by: swilso
0 Replies

4. Debian

kde, startx on debian

Hello :-)! I installed Debian (I downloaded it on may 2009 so it is new version) from CD. I run it and see only text console. I try to type "kde" or "startx" but it doens't recognize those commands. That's difficult for me to believe that Linux from CD doesn't contain graphical interface so I... (2 Replies)
Discussion started by: johnyjj2
2 Replies

5. Shell Programming and Scripting

Scripts after startx

I want to autorun a shell script which inculde start two java programs and some shell scripts I using fedora 9 and I had put in Personal > Sessions /bin/sh /myscript.sh but it got a problem when I start firefox from one of the java program, it said "Firefox is already running but not... (3 Replies)
Discussion started by: uativan
3 Replies

6. Shell Programming and Scripting

startx and then firefox

I have edited /etc/inittab to auto login as root in level 3 and edited .bash_profile to auto start x window I would like to auto start a firefox browser after go into x window. I tried to add "firefox" in /etc/rc.d/rc.local but no effects. Anyone have suggestion? Thanks in advance. (1 Reply)
Discussion started by: uativan
1 Replies

7. UNIX Desktop Questions & Answers

KDE and startx

Hello, Ive installed freeBSD 6.0 - and the prompt part of the system works well. Ive then tried to install KDE for graphic interface to the unix system. The problem is: Whenever I run "$ startx" it starts some graphical interface, but its totally swirled, you can sense that in the background... (1 Reply)
Discussion started by: congo
1 Replies

8. UNIX for Advanced & Expert Users

startx / xterm

When I try to run startx or xterm the window opens fine, however when using keyboard incorrect chars are displayed, e.g pressing return displays 2 (0 Replies)
Discussion started by: gefa
0 Replies

9. UNIX for Dummies Questions & Answers

Help with FreeBSD and startx.

Hello everyone. I just installed FreeBSD recently and when I type the command startx, I get the following errors: (EE) failed to load module "fbdev" (EE) <default pointer> cannot find which device to use (EE) xf860Open erial: No evice specified (EE) <default pointer> cannot open input... (3 Replies)
Discussion started by: cosmotron
3 Replies

10. UNIX for Dummies Questions & Answers

StartX

Hi guys :) I'm having a slight problem. Every time I run the StartX command from my csh, it just says cannot access terminal. Can anyone tell me why this is and what it means? Thank you :) hellz. (15 Replies)
Discussion started by: hellz
15 Replies

Featured Tech Videos