Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers StartX
# 8  
Old 09-04-2001

/usr/bin/whereis echo

If that output a valid path to 'echo' then:

$output_path/echo "test"

Normally echo resides in /bin:

/bin/echo "test"
# 9  
Old 09-04-2001
Thanks again, but still no joy Smilie

These are the commands I've found to be active so far:

cat filename (no switches.)
echo (printing $input but not its contents to the shell.)
finger username
cd (permission denied for most movement.)
ls directoryname (no switches.)
vi (displays Must be root.)
pine (displays cannot connect to host.)
pico (displays Must be root.)
StartX (displays cannot access terminal.)

I've found a shadowed password file, although the passwd file contains user who do not have passwords attached to their usernames. However I cannot change user.

Unsuccessful commands:

ypcat passwd

As you can see, it is pretty restrictive. I've even grabbed myself a free shell account at, and it's not helping me. I'm not sure if 'obscure' commands are being called for or not.

Any other suggestions? Smilie

# 10  
Old 09-04-2001
Mmm, are you sure you are running a Linux shell and not some weird DOS program? Smilie I give up!
# 11  
Old 09-04-2001
lol, nope it's definitely a csh Smilie I wish it was DOS, I wouldn't have a problem with that! The most irritating thing for me is that I can't use any scripting at all and I've got no idea how Unix/Linux systems work.

Thanks for trying though, I really appreciate it Smilie

# 12  
Old 09-04-2001
test project???

I'm not sure what useful information can be
gleened from trying to find holes in an
extremely restrictive environment but anyway,
I'd be curious to know if "env" or "set"
gives you any information about your environment.
Since most of your commands are "disabled" or
unusable, I'm not sure what help I (or anyone
else) will be. Sorry about that Smilie
# 13  
Old 09-04-2001
Thanks for the replies everyone, it looks like I'm at a dead end. I'll post back if I find the answer! Thank you all so very very much!

# 14  
Old 09-05-2001

You mentioned that whoami works... who does it say you are?

Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Screen Goes Black When Run startx

Have - HP G4p DL360 SCSI version (*see below of pdf of server basics if needed) Scientific Linux live-cd.iso Issue - When it boots off the LiveCD, all starts swell, but if I install the OS normal it goes to a black monitor.... If I install text only, it works and when done I am at the... (4 Replies)
Discussion started by: sas
4 Replies

2. Ubuntu

startx not working for 8.04.4

Hi, I am running Ubuntu 8.04.4 on a Sun Blade 1000 SPARC. I installed both kubuntu and xubuntu in attempt to load a gui onto the machine. Both fail when trying to start them. When I use startx I get the following error: (EE) Failed to laod module... (0 Replies)
Discussion started by: swilso
0 Replies

3. Debian

kde, startx on debian

Hello :-)! I installed Debian (I downloaded it on may 2009 so it is new version) from CD. I run it and see only text console. I try to type "kde" or "startx" but it doens't recognize those commands. That's difficult for me to believe that Linux from CD doesn't contain graphical interface so I... (2 Replies)
Discussion started by: johnyjj2
2 Replies

4. Shell Programming and Scripting

Scripts after startx

I want to autorun a shell script which inculde start two java programs and some shell scripts I using fedora 9 and I had put in Personal > Sessions /bin/sh / but it got a problem when I start firefox from one of the java program, it said "Firefox is already running but not... (3 Replies)
Discussion started by: uativan
3 Replies

5. Shell Programming and Scripting

startx and then firefox

I have edited /etc/inittab to auto login as root in level 3 and edited .bash_profile to auto start x window I would like to auto start a firefox browser after go into x window. I tried to add "firefox" in /etc/rc.d/rc.local but no effects. Anyone have suggestion? Thanks in advance. (1 Reply)
Discussion started by: uativan
1 Replies

6. UNIX Desktop Questions & Answers

KDE and startx

Hello, Ive installed freeBSD 6.0 - and the prompt part of the system works well. Ive then tried to install KDE for graphic interface to the unix system. The problem is: Whenever I run "$ startx" it starts some graphical interface, but its totally swirled, you can sense that in the background... (1 Reply)
Discussion started by: congo
1 Replies

7. UNIX for Advanced & Expert Users

startx / xterm

When I try to run startx or xterm the window opens fine, however when using keyboard incorrect chars are displayed, e.g pressing return displays 2 (0 Replies)
Discussion started by: gefa
0 Replies

8. Debian

error startx with debian

hello i have installed xfree86 with debian 2.4, but i have the message when i launch startx: XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining. xauth: (argv):1: bad display name ""... (0 Replies)
Discussion started by: pascalbout
0 Replies

9. UNIX for Dummies Questions & Answers

Help with FreeBSD and startx.

Hello everyone. I just installed FreeBSD recently and when I type the command startx, I get the following errors: (EE) failed to load module "fbdev" (EE) <default pointer> cannot find which device to use (EE) xf860Open erial: No evice specified (EE) <default pointer> cannot open input... (3 Replies)
Discussion started by: cosmotron
3 Replies

10. UNIX for Dummies Questions & Answers

startx, xauth msg and Solaris 8

I just built my first Solaris 8 machine. I start x using this command (assume I'm in the correct directory): ./startx After I run this command, I receive this extremely frustrating message: /startx: XAUTHORITY=//.Xauthority: is not an identifier Can someone tell me what I am doing... (4 Replies)
Discussion started by: rpeteg
4 Replies
Login or Register to Ask a Question