Screen Goes Black When Run startx

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Screen Goes Black When Run startx
# 1  
Old 12-04-2013
Display Screen Goes Black When Run startx

Have -
HP G4p DL360 SCSI version (*see below of pdf of server basics if needed)
Scientific Linux live-cd.iso

Issue -
When it boots off the LiveCD, all starts swell, but if I install the OS normal it goes to a black monitor....
If I install text only, it works and when done I am at the terminal view and login as root.....then if I execute startx, the screen goes black....if I make root create a user and then that user runs startx - same screen..

The same ISO (livecd.iso) boots to the GUI (gnome I think) when I run it on VMware the ISO is clean (I think...)

Googling this issue has returned too many confusing, what'ya think?

Thanks in advance for any suggestions.

ps - this server is for my home-unix/ I'm not some network engineer if yer wondering what my ignorance is due to...I'm more of a analytics person fwiw....

# 2  
Old 12-04-2013
More than likely it is a graphics card driver issue.

Which release of Scientific Linux?

Do you know the exact make and model of graphics card in your system?

What X-related error messages are showing up in /var/log/messages or /var/log/Xorg.0.log?
# 3  
Old 12-04-2013
Hi, sorry, here's my goods:

error after running Xorg :1 -configure:
card - AMD...:


---------- Post updated at 09:56 PM ---------- Previous update was at 09:27 PM ----------

The ISO is:


Last edited by sas; 12-04-2013 at 10:31 PM..
# 4  
Old 12-05-2013
Please provide contents of /root/

Please do not used a screenshot. It takes up bandwidth to display and add no value.
# 5  
Old 12-05-2013
Sorry, have not been able to ssh into the box so the pic was best I could do.

I was able to install Debian and things are working great. From what little I was able to find re this server (that is like 100 years old in an IT sense) it has some kind of driver conflict per this gentleman:

linux centOS enterprise 6.3 64bit*installed on a hp proliant dl360*
Published on Jan 30, 2013
suse linux 12.2 fail no video driver
ubuntu 12.10 fail no grub fatal error
slackware? no idea what the problem was
linux mint 14.1 no video driver
debian 6.0 works but logging into root is a pain in the ass.
centos 6.3 works great with extra features like firewall etc smooth fast.

I get the feeling that this dino of a server doesn't play well with Scientific Linux. I didn't try centos, but Debian is working great.

Thanks for trying, I've moved on since the box is now up and I am able to start using it to do some analytic research. Thanks!!!
Login or Register to Ask a Question

Previous Thread | Next Thread

8 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Showing a black screen

Hi all, Is there a way, on the command line, to show a black screen WITHOUT turning off the monitor? Also, is there a way to make the computer show the last screen before the black screen as soon as the user interacts with it? I know that there are various ways to turn off the computer, or... (8 Replies)
Discussion started by: Zel2008
8 Replies

2. HP-UX

HP-UX server boots to black graphical screen

hello all, please can you help me crack this.... i have an hp-ux server which when after booting it does not completely boot to graphical. it stops aa black screen with only an hour glass showing. at this stage only the mouse responds but the keyboard does not respond. any idea to find... (5 Replies)
Discussion started by: steveGH
5 Replies

3. Linux

Cannot boot as usuall , turn to black screen & ask for loging in ???? Help me????

Hey guys..... Im new user for linux fedora 20.... i really need help ....... i have no idea why suddently when i turn on my laptop fedora turn to be black screen and ask me loging in , when i loging then nothing happen , it stay at the same screen... then i try to go to "with linux secure...,"... (12 Replies)
Discussion started by: asianfootball
12 Replies

4. UNIX Desktop Questions & Answers

Boot problem after updates, Ubuntu, black screen and cursor

I hope this is the correct forum, please forgive a newbie. Hi all, New to linux, ubuntu, and this forum. I have enjoyed ubuntu for the past few months, but after my last update installation ubuntu would boot to a black screen and blinking cursor. If I let it sit for a while it would give the... (0 Replies)
Discussion started by: nutoubuntu
0 Replies

5. Hardware

qosmio f50-freeze when trying to update bios-black screen

Hi! I own a Qosmio f50 laptop and today i download the file from toshiba to update my bios. Everything went well until installer reaches block 16 when system freezes. I left it half an hour and then tried to power-off the pc with the button, but it dont. I unplug the ac-adaptor and the battery and... (0 Replies)
Discussion started by: giampoul
0 Replies

6. Red Hat

Black Screen

I am using Intel HD 400 Graphics on a laptop. When I logout, I get a black screen with no cursor or anything. I have to hard reboot the system to get into linux again. Working on RHEL 6 (gnome) (1 Reply)
Discussion started by: sunveer
1 Replies

7. Shell Programming and Scripting

Get Black Screen for 10secs

I was thinking if there is a way that i can go about making my screen go black automatically for about 10seconds, (with a message like "take a break" printed on the screen) and after 10seconds everything comes back to normal.... is there any way that i can do this...??? to further clarify the... (2 Replies)
Discussion started by: c_d
2 Replies

8. SCO

Black Screen SCO Real. 5 (intel platform)

Hi everyone, I am new in here. I have to work on a system where nothing is showing up on the screen. I am suspecting an hardware issue, can anyone help me with this? Thanks for your input BB (4 Replies)
Discussion started by: labcc
4 Replies
Login or Register to Ask a Question