TFTP setup


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers TFTP setup
# 15  


i'm installing tftp because I work for the networking dept here and we have a very secure unix box downstairs that has a tftp server and has the final back up's of all our ios' on our cisco's switches. I wanted a more lienant server that I ran so that we could put temp files and ios' that we were still playing with first before we put it on the more secure on downstairs.

it's pretty much just for back up purposes of our switches
# 16  
This is what I guessed, backup of Cisco IOS and/or Cisco config files. That is precisely where my expertise in TFTP originates Smilie

To backup the IOS, you will have to touch a file (and give open permissions) to the same name of the file you are saving. When you do a 'write net' on the Cisco boxes, it will ask for the name/ip of the TFTP server AND the name of the file (the Cisco IOS gives a default). That file MUST exist in the TFTP directory of the server.

So before you do a 'write net' you much touch a file with the same name as the file you are writing. For example, on the server:

Code:
cd /etc/tftp
touch cisco-ios-dec-05-v11.03a
chmod 666 cisco-ios-dec-05-v11.03a

On the router you would then 'write net' file name, cisco-ios-dec-05-v11.03a. (use your own file names). The confusion most people have is that the file must exist in the TFTP directory in order to write it from a device, like the Cisco IOS. To read the file (get), you must know the exact name of the file you are 'getting'. Same is true for Cisco configurations:

Code:
cd /etc/tftp
touch router-bigmomma-new-access-lists-dec-06
chmod 666 router-bigmomma-new-access-lists-dec-06

I forget the exact Cisco syntax, so if you need help in that area, please login to the router from an X or other GUI telnet session and use the mouse to capture the screen (Cisco console) and upload to this thread. I can help you through the 'write net' and other commands between the Cisco IOS and your UNIX TFTP platform.

[Edited by Neo on 12-07-2000 at 06:35 PM]
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #189
Difficulty: Easy
The boolean data type in Python is immutable.
True or False?

10 More Discussions You Might Find Interesting

1. Linux

tftp will not start.

I have setup nimol on a Fedora 9 machine. Nimol is installed and correctly configured and I have a client rs6000 (43p) declared in the dhcpd.conf file. all is running correctly and tftp is installed. I am monitoring /var/log/messages when I start the 43p and see the dhcp request come in and a reply... (0 Replies)
Discussion started by: johnf
0 Replies

2. AIX

NIM server setup on etherchannel setup environment

I know that IBM's official stance is that NIM does not work on etherchannel environment, but has anyone able to get around it? I'm working on a p5-590 LPAR system, and the NIM master and clients are all on the same frame. Any help is appreciated. (1 Reply)
Discussion started by: pdtak
1 Replies

3. UNIX for Dummies Questions & Answers

TFTP not found

Hi, I'm trying to run the tftp client on tsch shell and I get command not found, but on bash tftp ran fine, can anyone help me on how to run it on tsch? Thanks (1 Reply)
Discussion started by: wsn
1 Replies

4. UNIX for Dummies Questions & Answers

tftp troubleshooting

Hi I am trying to do a network install of Solaris 10 08_07 onto a Sunfire T2000. I have configured all my network-boot-arguments on the client server (named sundb1). I have installed my image of Solaris on my install server (sun1). But when I try to install using # boot net -s I get the... (0 Replies)
Discussion started by: Bobby76
0 Replies

5. UNIX for Dummies Questions & Answers

enabling TFTP

ive been trying to enable a tftp service on a unix box using the command atftpd --daemon but when i scan the open ports using nmap it doesnt show that port 21 as up does anyone know the reason... ive tried /etc/init.d/atftpd start , it didnt work if i type atftpd by it self it gives me a set... (2 Replies)
Discussion started by: ratamahatta
2 Replies

6. UNIX for Dummies Questions & Answers

Tftp

Is it possible to copy files between two computers with TFTP.And how? (1 Reply)
Discussion started by: bericica
1 Replies

7. Linux

tftp question

RH 7.2 I am attempting to get tftp working but I'm having a problem. On the server, xinetd has libwrap options compiled in. I have a deny all policy in my hosts.deny file and the following entries in my hosts.allow file: in.tftpd:.10.151.2.6 But...when I attempt to tftp from... (1 Reply)
Discussion started by: jalburger
1 Replies

8. Solaris

tftp daemon error

Hi everyone, I am currently receiving an error on my console that reads something like: <host> tftpd: socket (delay): Protocol not supported I have done so much research into tftpd, i've looked everywhere to find out what this might be caused by...unfortunately i have Solaris 8, so there... (5 Replies)
Discussion started by: myscsa2004
5 Replies

9. IP Networking

TFTP question

I have been hearing that this protocol offers faster throughput rate than FTP, is it true? If so, are there any compromise in reliability on data being sent? How do I set up a TFTP transfer instead of a FTP to download? Thanks (3 Replies)
Discussion started by: ho_k
3 Replies

10. UNIX for Dummies Questions & Answers

bootp/tftp

Hi, Setting up print queue, using SMIT on AIX And I have an option saying do I wish to make this a BOOTP/TFTP server. What exactly does this do? Thanks (3 Replies)
Discussion started by: maverick
3 Replies

Featured Tech Videos