TFTP setup


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers TFTP setup
# 8  
Thanks. Please upload the results of:

Code:
ls -ld /etc/tftp

# 9  
# ls -ld /etc/tftp
drwxr-xr-x 2 root other 512 Dec 5 11:02 /etc/tftp
#


i am doing all of this from
/
would it matter what kind of shell i am in?
# 10  
Shell is just fine. Can you sucessfully move a file or fine error messages (locally) using these commands?

Code:
tftp localhost

You should get a prompt for tftp:

Code:
tftp>

Try putting a file like this:

Code:
tftp localhost
tftp>
tftp> ?

Commands may be abbreviated.  Commands are:

connect         connect to remote tftp
mode            set file transfer mode
put             send file
get             receive file
quit            exit tftp
verbose         toggle verbose mode
trace           toggle packet tracing
status          show current status
binary          set mode to octet
ascii           set mode to netascii
rexmt           set per-packet retransmission timeout
timeout         set total retransmission timeout
?               print help information
tftp> put /etc/services

What happens? Do you get a 'transfer time out' error?

[Edited by Neo on 12-06-2000 at 03:11 PM]
# 11  
all if fine up untill I get to the put statement
tftp> put /etc/services
tftp: services: No such file or directory

this is where I am stuck, not really sure how I have it all setup.

# 12  
From the man page:

Quote:
The use of tftp(1) does not require an account or password on the remote system. Due to the lack of authentication information, tftpd will allow only publicly readable files to be accessed. Files may be written only if they already exist and are publicly writable.
cd in the /etc/tftp directory and touch a file called services. i.e.:

Code:
cd /etc/tftp
touch services
chmod 666 services

Now you have a file in the tftp directory with full public read/write permissions per the man-page quote above.

Again, try to tftp to localhost and get this file and put this file.

What happens?

Note:

Make sure you are in the /tmp directory when "getting" test files so you do not overwrite good files. For example, testing /etc/services (as an example), don't get the test file and overwrite the /etc/services file by doing the tftp from the /etc directory! Make sure you cd to /tmp before issueing the tftp command.


[Edited by Neo on 12-06-2000 at 04:16 PM]
# 13  

ok all of the above worked, so I am logged into tftp localhost, and what do I do now, do i put a file? or do I get a file? how do I get a list of what files are avaible for me to get?
# 14  
The man pages are pretty clear here. You can only get and put files that exist in the tftp directory (and have proper permissions). Did you do everything in the examples above? If you did, you are all set to tftp all you want.

As to what you are going to tftp, that is really up to you. Why did you install it?
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #711
Difficulty: Easy
The earliest computing machines had fixed programs.
True or False?

10 More Discussions You Might Find Interesting

1. Linux

tftp will not start.

I have setup nimol on a Fedora 9 machine. Nimol is installed and correctly configured and I have a client rs6000 (43p) declared in the dhcpd.conf file. all is running correctly and tftp is installed. I am monitoring /var/log/messages when I start the 43p and see the dhcp request come in and a reply... (0 Replies)
Discussion started by: johnf
0 Replies

2. AIX

NIM server setup on etherchannel setup environment

I know that IBM's official stance is that NIM does not work on etherchannel environment, but has anyone able to get around it? I'm working on a p5-590 LPAR system, and the NIM master and clients are all on the same frame. Any help is appreciated. (1 Reply)
Discussion started by: pdtak
1 Replies

3. UNIX for Dummies Questions & Answers

TFTP not found

Hi, I'm trying to run the tftp client on tsch shell and I get command not found, but on bash tftp ran fine, can anyone help me on how to run it on tsch? Thanks (1 Reply)
Discussion started by: wsn
1 Replies

4. UNIX for Dummies Questions & Answers

tftp troubleshooting

Hi I am trying to do a network install of Solaris 10 08_07 onto a Sunfire T2000. I have configured all my network-boot-arguments on the client server (named sundb1). I have installed my image of Solaris on my install server (sun1). But when I try to install using # boot net -s I get the... (0 Replies)
Discussion started by: Bobby76
0 Replies

5. UNIX for Dummies Questions & Answers

enabling TFTP

ive been trying to enable a tftp service on a unix box using the command atftpd --daemon but when i scan the open ports using nmap it doesnt show that port 21 as up does anyone know the reason... ive tried /etc/init.d/atftpd start , it didnt work if i type atftpd by it self it gives me a set... (2 Replies)
Discussion started by: ratamahatta
2 Replies

6. UNIX for Dummies Questions & Answers

Tftp

Is it possible to copy files between two computers with TFTP.And how? (1 Reply)
Discussion started by: bericica
1 Replies

7. Linux

tftp question

RH 7.2 I am attempting to get tftp working but I'm having a problem. On the server, xinetd has libwrap options compiled in. I have a deny all policy in my hosts.deny file and the following entries in my hosts.allow file: in.tftpd:.10.151.2.6 But...when I attempt to tftp from... (1 Reply)
Discussion started by: jalburger
1 Replies

8. Solaris

tftp daemon error

Hi everyone, I am currently receiving an error on my console that reads something like: <host> tftpd: socket (delay): Protocol not supported I have done so much research into tftpd, i've looked everywhere to find out what this might be caused by...unfortunately i have Solaris 8, so there... (5 Replies)
Discussion started by: myscsa2004
5 Replies

9. IP Networking

TFTP question

I have been hearing that this protocol offers faster throughput rate than FTP, is it true? If so, are there any compromise in reliability on data being sent? How do I set up a TFTP transfer instead of a FTP to download? Thanks (3 Replies)
Discussion started by: ho_k
3 Replies

10. UNIX for Dummies Questions & Answers

bootp/tftp

Hi, Setting up print queue, using SMIT on AIX And I have an option saying do I wish to make this a BOOTP/TFTP server. What exactly does this do? Thanks (3 Replies)
Discussion started by: maverick
3 Replies

Featured Tech Videos