tftp troubleshooting

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers tftp troubleshooting
# 1  
Old 02-29-2008
tftp troubleshooting


I am trying to do a network install of Solaris 10 08_07 onto a Sunfire T2000. I have configured all my network-boot-arguments on the client server (named sundb1). I have installed my image of Solaris on my install server (sun1).

But when I try to install using
# boot net -s
I get the error message of:
tftp transfer Timed out

I have tried to troubleshoot tftp on my install server and below is some of the info
# more /etc/release
Solaris 9 s9_58shwpl3 SPARC
Copyright 2002 Sun Microsystems, Inc. All Rights Reserved.
Use is subject to license terms.
Assembled 15 April 2002

inetd appears to be configured ok
# more /etc/inetd.conf
# TFTPD - tftp server (primarily used for booting)
tftp dgram udp6 wait root /usr/sbin/in.tftpd in.tftpd -s /tftpboot

inetd appears to be running ok
# ps -ef
root 263 1 0 Feb 27 ? 0:00 /usr/sbin/inetd -s

permissions on tftp appear to be okay
# ls -ld /tftpboot
drwxrwxrwx 2 root other 512 Feb 28 16:55 /tftpboot

# ls -l /usr/sbin/in.tftpd
-r-xr-xr-x 1 root bin 27600 Apr 7 2002 /usr/sbin/in.tftpd

tftp appears to function ok within the install server
# cd /tmp
# tftp
tftp> get sun1:/tftpboot/services
# ls -l
total 720
-rw------- 1 akil support 360372 Feb 28 11:02 dtdbcache_:0
-rw-rw---- 1 akil support 0 Feb 28 11:03 sdtvolcheck19253
-rw-r--r-- 1 root other 0 Feb 29 10:06 services
-rw-r--r-- 1 akil support 6 Feb 28 11:02 speckeysd.lock

I have tried to tftp using another server to the sun1 server and I get tftp timed out so the problem is not specific to my client server.

There are no error messages in /var/adm/messages

Any help is greatly appreciated
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Linux

tftp will not start.

I have setup nimol on a Fedora 9 machine. Nimol is installed and correctly configured and I have a client rs6000 (43p) declared in the dhcpd.conf file. all is running correctly and tftp is installed. I am monitoring /var/log/messages when I start the 43p and see the dhcp request come in and a reply... (0 Replies)
Discussion started by: johnf
0 Replies

2. UNIX for Dummies Questions & Answers

TFTP not found

Hi, I'm trying to run the tftp client on tsch shell and I get command not found, but on bash tftp ran fine, can anyone help me on how to run it on tsch? Thanks (1 Reply)
Discussion started by: wsn
1 Replies

3. UNIX for Dummies Questions & Answers

enabling TFTP

ive been trying to enable a tftp service on a unix box using the command atftpd --daemon but when i scan the open ports using nmap it doesnt show that port 21 as up does anyone know the reason... ive tried /etc/init.d/atftpd start , it didnt work if i type atftpd by it self it gives me a set... (2 Replies)
Discussion started by: ratamahatta
2 Replies

4. Solaris

tftp configuring on Solaris 5.7

Hi, I need to setup a tftp facility on a Sun server. Can someone help me urgently, i need this to be up at the earliest. Regards, Vivek :( (1 Reply)
Discussion started by: vivek_scv
1 Replies

5. UNIX for Dummies Questions & Answers


Is it possible to copy files between two computers with TFTP.And how? (1 Reply)
Discussion started by: bericica
1 Replies

6. Linux

tftp question

RH 7.2 I am attempting to get tftp working but I'm having a problem. On the server, xinetd has libwrap options compiled in. I have a deny all policy in my hosts.deny file and the following entries in my hosts.allow file: in.tftpd:. But...when I attempt to tftp from... (1 Reply)
Discussion started by: jalburger
1 Replies

7. Solaris

tftp daemon error

Hi everyone, I am currently receiving an error on my console that reads something like: <host> tftpd: socket (delay): Protocol not supported I have done so much research into tftpd, i've looked everywhere to find out what this might be caused by...unfortunately i have Solaris 8, so there... (5 Replies)
Discussion started by: myscsa2004
5 Replies

8. IP Networking

TFTP question

I have been hearing that this protocol offers faster throughput rate than FTP, is it true? If so, are there any compromise in reliability on data being sent? How do I set up a TFTP transfer instead of a FTP to download? Thanks (3 Replies)
Discussion started by: ho_k
3 Replies

9. UNIX for Dummies Questions & Answers


Hi, Setting up print queue, using SMIT on AIX And I have an option saying do I wish to make this a BOOTP/TFTP server. What exactly does this do? Thanks (3 Replies)
Discussion started by: maverick
3 Replies

10. UNIX for Dummies Questions & Answers

TFTP setup

ok, I configured inetd.conf so that the tftp string is not commented out, but I cannot get the process to start. I'm running Solaris 5.8 and need some help. Cabletron said that it's process is 3485, i tried to kill it, it's the wrong process. I started inetd again and still can't kill it. i... (15 Replies)
Discussion started by: veitcha
15 Replies
Login or Register to Ask a Question