Visit Our UNIX and Linux User Community


Permissions Issues FTP server


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Permissions Issues FTP server
# 1  
Old 09-28-2009
Permissions Issues FTP server

Hi all,

Quick question, im going to find this a bit hard to explain but ill give it a go.

Basically i have an admin account on an FTP server that i want to be able to control ALL files without having to use sudo (as i need to run cron scripts to move files that are owned by a number of different users).

I have tried setting the admin account to be inside the ftpusers group but the default chmod is 744 (i think) so the group will not allow this? I hope your following me here.

Anyway i would like to know if i can setup an account that will be able to access any files or could someone let me know the best setup for a ftp server (with 10+) remote users and 10+ scripts this side to send, move and receive files. ie who should own the incoming folder, outgoing folder and what permissions should be set on it. I want remote users to be able to drop files off into there directory (then my scripts run and move them), i also want myself to be able to drop files into there accounts outgoing folder so there sent over to there ftp server (via a script) (using cron).

Thanks alot. Smilie


---------- Post updated at 05:44 AM ---------- Previous update was at 05:29 AM ----------

Basically i need a user to override the owner on a certain group (ftpusers) with an admin account.
# 2  
Old 09-28-2009
Why don't you just change the rights on the folders ?

Something like :
Code:
chmod -R 0770 /my_base_dir

# 3  
Old 09-28-2009
set the ftpd umask to 002, then every file generated comes with 775


for aix ftp, change inetd.conf line with ftpd, and append the flag -u 2 eg

Code:
ftp     stream  tcp6    nowait  root    /usr/sbin/ftpd         ftpd -u 2

Edit: ok I'm not in the aix subforums, which ftp-server are you using? ^^

for vsftp set file_open_mode in /etc/vsftpd.conf to 775

for proftp change the umask line in /etc/proftp.conf to 002

Last edited by funksen; 09-28-2009 at 09:24 AM..
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #1006
Difficulty: Medium
In calculus and most other branches of mathematics beyond practical geometry, angles are universally measured in degrees.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX Desktop Questions & Answers

Web Server/Permissions issues.

I do not know if this is the correct place to post this, and I have tried to trawl through relevant articles to fix the issue, but I am stumped. I have a server, log as root. var/www is root:root var/www/website-one is root:root var/www/website-one/neosmart-stream is root:root This... (10 Replies)
Discussion started by: LightCastle
10 Replies

2. Red Hat

Implement FTP server on RHEL server without using FTP client

We have RHEL 5.8 in our environment, I had a query whether we can implement an FTP server using vsftpd package and Linux configurations like setsebool without using any external FTP clients like FileZilla etc. I am very confused on this. The FTP functionalities that should be present are download &... (3 Replies)
Discussion started by: RHCE
3 Replies

3. OS X (Apple)

Wordpress & Git, urgent permissions issues, need help...

Heya, So I recently upgraded my MacBook to a solid state drive, during the re-install of Snow Leopard I chose to abandon MAMP and use the built in Apache & PHP and in doing so moved my ~/Sites to /Library/WebServer/Documents from a Time Machine backup. During this transition the permissions... (0 Replies)
Discussion started by: s3w47m88
0 Replies

4. UNIX for Dummies Questions & Answers

permissions on ftp...

hi, how can I see permissions through ftp connection ? I can't see them using "ls -l" as in the local system.. thanks (1 Reply)
Discussion started by: aneuryzma
1 Replies

5. Red Hat

Issues with LDAP user/group permissions on NFS share

I can't seem to make sense of this. $ cat /etc/redhat-release Red Hat Enterprise Linux Server release 5.2 Beta (Tikanga) $ $ mount /dev/sda2 on / type ext3 (rw) proc on /proc type proc (rw) sysfs on /sys type sysfs (rw) devpts on /dev/pts type devpts (rw,gid=5,mode=620) /dev/sda1 on... (6 Replies)
Discussion started by: dfinn
6 Replies

6. AIX

FTP file permissions

Hi all, I am using ftp command to transfer a file from one AIX5.3 box to different box with the same OS level. Is there a way I could change the permissions on the file once its transferred, as I am automating the process but the file permissions on the target does not allow other users to access... (2 Replies)
Discussion started by: sam_78_nyc
2 Replies

7. UNIX for Dummies Questions & Answers

FTP Permissions

Hi Guys, I am trying to grant FTP acccess to my server for a WebDesigner to be able to upload live and see how it looks online. I created a new user (WebDes:tomcatUsers) and created his home dir as /var/lib/tomcat5/webapps/uPhoto/ and then made sure he CHROOT's to his home dir so he only... (1 Reply)
Discussion started by: boarderstu
1 Replies

8. UNIX for Advanced & Expert Users

How to run my own FTP server without root permissions

Hi all, I need your help with this problem. I have my own ftp server implemented in java. If I start it as root it is successfully binded to port 21 and everything works. Now I want to run it as non-root user, but for binding to port 21 it needs root rights. How to solve it? I alrady try... (3 Replies)
Discussion started by: giorgione
3 Replies

9. UNIX for Dummies Questions & Answers

Permissions issues

I'm hoping this is a pretty simple question. I have a problem were memebers of a group can't delete or overwrite a file. The box is setup several users all part of the same group. Now default umask is 002. The problem I run into is there are processes that add to, del, and over write files. ... (3 Replies)
Discussion started by: lightspd
3 Replies

10. UNIX for Dummies Questions & Answers

ftp permissions error

HI, I am not really even a newbie I'm just posing as one until our sys admin gets back from vacation. I am getting errors downloading certain files from an NT Server onto our inhouse Unix fileserver. Certain files always return errors when downloading to their proper directory.... (2 Replies)
Discussion started by: newbie10
2 Replies

Featured Tech Videos