Web Server/Permissions issues.

Thread Tools Search this Thread
Special Forums UNIX Desktop Questions & Answers Web Server/Permissions issues.
# 1  
Old 02-25-2014
Web Server/Permissions issues.

I do not know if this is the correct place to post this, and I have tried to trawl through relevant articles to fix the issue, but I am stumped.

I have a server, log as root.

var/www is root:root

var/www/website-one is root:root

var/www/website-one/neosmart-stream is root:root

This error pops up

It is not possible to create new directories via PHP mkdir(). /var/www/website-one/neosmart-stream/ (CHMOD 0775) is not writeable.
Try to set your webserver as owner of /var/www/website-one/neosmart-stream/

Has this web server been setup incorrectly ?

On another web server not managed by me the permissions/group are right and everything works fine ?

Can anyone direct me on the right path please ?
# 2  
Old 02-25-2014
The issues is, more than likely, is that your web server (after it starts up) does not run as the root user. That is why you are having a permission problem (more-than-likely).
This User Gave Thanks to Neo For This Post:
# 3  
Old 02-25-2014
As part of your error message says:

Try to set your webserver as owner of /var/www/website-one/neosmart-stream/
As Neo has already post, your web server (process) does not have the required access rights to the files in question. This is typically fixed by changing the owner of the whole tree to the webserver user (eg, on Solaris x86 this is "webservd"). Or your web server may be running under userid "apache" for example.

To help you more we need to know the environment (O/S, webserver, etc) but you'll be pleased to know that your issue is not unusual at all when installing a web server. It happens all the time upon initial install.
This User Gave Thanks to hicksd8 For This Post:
# 4  
Old 02-25-2014
ubuntu-9.04-server-i386 ? Should this not be the latest version ?

I got somewhere earlier, with chown & chgrp, but there is a issue with -R seems to prevent me from using this as well.

var/www/website-one/neosmart-stream/ works but neosmart-stream/nss-admin ect do not work even when giving it a UID of 33 ?

Trying to learn what I can off the net now, but this server does seem to be setup incorrectly as you stated ?

Last edited by LightCastle; 02-25-2014 at 06:59 PM..
# 5  
Old 02-25-2014
Your post above is not very helpful.

First of all, do you know exactly what user and group your web server is running?

Do you know how to determine that basic information?
# 6  
Old 02-25-2014
root:root is running the webserver ?

How do I determine that ?

I was given the root as username and the password.
# 7  
Old 02-25-2014
It's extremely unlikely that the user "root" is running the webserver.

Login to the system as root and look at all the running processes:

ps -eaf|more

Look for a process that looks like the web server process (eg. apache or similar known web server).

If you can find the process then the user running it (see column 1) is the user that doesn't have access to the files in the www default directory tree.

If you can't find the web server process, post the whole output of:

ps -eaf

so that we can have a go.

---------- Post updated at 08:52 PM ---------- Previous update was at 08:51 PM ----------

And also, if you're logged in as "root" (ie, god) you shouldn't have any trouble running 'chown -R'
This User Gave Thanks to hicksd8 For This Post:
Login or Register to Ask a Question

Previous Thread | Next Thread

5 More Discussions You Might Find Interesting

1. Solaris

Permissions configuration for web server

Greetings! I have a Solaris workstation that I use for web hosting. It runs SAMP and everything was working good for me until I got a need to add a couple of co-workers to help me with development. I'm trying to find some guidance for how to set up filesystem permissions so everybody would be... (3 Replies)
Discussion started by: pn8830
3 Replies

2. OS X (Apple)

TextMate web server permissions

this could be a dumb question. i am still becoming used to usr / group permissions. permissions to place a file into XAMPP/htdocs. the problem is that when i go to place a TextMate file into XAMPP/htdocs a window comes up and states: Type your password to allow TextMate to make changes. ... (2 Replies)
Discussion started by: cowLips
2 Replies

3. OS X (Apple)

Wordpress & Git, urgent permissions issues, need help...

Heya, So I recently upgraded my MacBook to a solid state drive, during the re-install of Snow Leopard I chose to abandon MAMP and use the built in Apache & PHP and in doing so moved my ~/Sites to /Library/WebServer/Documents from a Time Machine backup. During this transition the permissions... (0 Replies)
Discussion started by: s3w47m88
0 Replies

4. UNIX for Dummies Questions & Answers

Permissions Issues FTP server

Hi all, Quick question, im going to find this a bit hard to explain but ill give it a go. Basically i have an admin account on an FTP server that i want to be able to control ALL files without having to use sudo (as i need to run cron scripts to move files that are owned by a number of... (2 Replies)
Discussion started by: mokachoka
2 Replies

5. UNIX for Dummies Questions & Answers

Permissions issues

I'm hoping this is a pretty simple question. I have a problem were memebers of a group can't delete or overwrite a file. The box is setup several users all part of the same group. Now default umask is 002. The problem I run into is there are processes that add to, del, and over write files. ... (3 Replies)
Discussion started by: lightspd
3 Replies
Login or Register to Ask a Question