Visit Our UNIX and Linux User Community


File names that contain "01" act hidden


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers File names that contain "01" act hidden
# 1  
Old 06-07-2001
File names that contain "01" act hidden

Haveing an issue. Anytime a file is created with "01" (zero one) in the name - it cannot be viewed by LS or any other file listing command. Although the file is there, it cannot be seen. I can edit it, run it, anything, except see it.....

What happened? Any ideas?
# 2  
Old 06-07-2001
$ ls
01 01new
$ touch .01
$ ls
01 01new
$ ls -l
total 0
-rw-r--r-- 1 UID GID 0 Jun 7 15:50 01
-rw-r--r-- 1 UID GID 0 Jun 7 15:50 01new
$ ls -la
total 4
drwxr-xr-x 2 UID GID 512 Jun 7 15:52 .
drwxrwxrwx 7 UID GID 512 Jun 7 15:50 ..
-rw-r--r-- 1 UID GID 0 Jun 7 15:52 .01
-rw-r--r-- 1 UID GID 0 Jun 7 15:50 01
-rw-r--r-- 1 UID GID 0 Jun 7 15:50 01new
$ echo $SHELL
/bin/ksh



are you sure it is not beganing with "." ??

Last edited by Optimus_P; 06-07-2001 at 05:53 PM..
# 3  
Old 06-07-2001
Those files that were created did not show up, but they were created.

The do not show up in the LS command
but they are there, like hidden system files on a PC in dos mode

Nothing with a dot, anything, and I mean anything, with "01" in the file name is not showing, its there, just not listing
# 4  
Old 06-07-2001
did you try ls -la?
# 5  
Old 06-07-2001
oh yeah - I covered every single basic

shared the files, shared the director to another unix server....

Every possible way to show those damn files. Even using samba via an NT server still does not show.

Driven me nuts here.
# 6  
Old 06-07-2001
sorry man then i am at a loss.
# 7  
Old 06-07-2001
Well poop!!!

This kinda sucks, I have no idea if it could be a hardware or software thing at this point. Sun references nothing like this on/in their documentations....

Any ideas on where to send me?

Thanks for tryin anyway
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #794
Difficulty: Medium
1/10 has a finite binary representation.
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Bash script - Print an ascii file using specific font "Latin Modern Mono 12" "regular" "9"

Hello. System : opensuse leap 42.3 I have a bash script that build a text file. I would like the last command doing : print_cmd -o page-left=43 -o page-right=22 -o page-top=28 -o page-bottom=43 -o font=LatinModernMono12:regular:9 some_file.txt where : print_cmd ::= some printing... (1 Reply)
Discussion started by: jcdole
1 Replies

2. Shell Programming and Scripting

Compare Only "File Names" in 2 Files with file lists having different directory structure

I have a tar arcive arch_all.tar.gz and 4 batched tar archive . These batches are supposed to have all the files form arch1.all.tar.gz arch1_batch1.tar.gz arch1_batch2.tar.gz arch1_batch3.tar.gz arch1_batch4.tar.gz my issue is that the directory structure in "arch_all.tar.gz" is... (6 Replies)
Discussion started by: sumang24
6 Replies

3. UNIX for Dummies Questions & Answers

Using "mailx" command to read "to" and "cc" email addreses from input file

How to use "mailx" command to do e-mail reading the input file containing email address, where column 1 has name and column 2 containing “To” e-mail address and column 3 contains “cc” e-mail address to include with same email. Sample input file, email.txt Below is an sample code where... (2 Replies)
Discussion started by: asjaiswal
2 Replies

4. Shell Programming and Scripting

The "read" command misinterprets file names containing spaces

The "read" command, which is built into bash, takes words from the standard input. However, "read" is not good at taking file names if the file names contain spaces. I would like my bash script to ask the user to enter file names, which may contain spaces. Can you think about any technique for... (14 Replies)
Discussion started by: LessNux
14 Replies

5. Shell Programming and Scripting

Removing "Hidden Characters" on a file

Hi - I'm having a problem with hidden characters on Linux. When I produced an output from Oracle database, there is a an extra "Hidden Character" included on the output. How can I remove that character? See below: The extra dollar sign is creating a new line on my .csv output file. I... (16 Replies)
Discussion started by: Jin_
16 Replies

6. Shell Programming and Scripting

awk command to replace ";" with "|" and ""|" at diferent places in line of file

Hi, I have line in input file as below: 3G_CENTRAL;INDONESIA_(M)_TELKOMSEL;SPECIAL_WORLD_GRP_7_FA_2_TELKOMSEL My expected output for line in the file must be : "1-Radon1-cMOC_deg"|"LDIndex"|"3G_CENTRAL|INDONESIA_(M)_TELKOMSEL"|LAST|"SPECIAL_WORLD_GRP_7_FA_2_TELKOMSEL" Can someone... (7 Replies)
Discussion started by: shis100
7 Replies

7. Shell Programming and Scripting

Compare file names and select correct elements to include in "for each loop"

Hi everyone, I`ll try to be most clear I can explaining my help request. I have 2 folders Folder A-->This folder receives files through FTP constantly Folder B-->The files from Folder A are unzipped and then processed in Folder B Sometimes Folder A doesn`t contain all... (2 Replies)
Discussion started by: cgkmal
2 Replies

8. UNIX for Advanced & Expert Users

how to remove a file names as "-a"

Hi, How to remove a file accidently named (created) as "-a". I have tried rm \-a but its not working. (6 Replies)
Discussion started by: apsprabhu
6 Replies

9. UNIX for Dummies Questions & Answers

total number of files which have "aaa" in files whose names are File*_bbb*

I am getting the list of all the files which have "aaa" from files whose name is File*_bbb*. grep -l "aaa" File*_bbb* But I want to count the number of files. That is I want the total number of files which have "aaa" in files File*_bbb* If I run the following for getting number of... (1 Reply)
Discussion started by: sudheshnaiyer
1 Replies

Featured Tech Videos