Visit Our UNIX and Linux User Community


Apache/Unix


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Apache/Unix
# 1  
Old 06-05-2001
Apache/Unix

OK, i followed the online directions to installing MySQL/Apache/PHP4 and it all seemed to be workign until i went into (OSX) System prefrences and tried to start Web shareing (turn on apache) ....it just kidna sits there saying 'statring web sharing'. should i just redo the steps online to install apache? could it be one of the other things i installed? should i try initializing it from terminal? any help would be apreciated
# 2  
Old 06-05-2001
heh, also, i just went to terminal and typed mysql and it gave me error 2002, cant connect to local server.....is that just because apache isnt on?
# 3  
Old 06-05-2001
ok, aparently when i try to start apache from terminal, it says the php module is garbled, and the instructions i was following warned against that, hwo do i reinstall php, can i just do it again and have it over write the garbled files?
# 4  
Old 06-06-2001
you will have to recompile apache to get ride of that php module if you did not load it as a "plug-in".

if you did add it as a plugin then just redownload it from ?php.org ? or something and use the AddModule in the httpd.conf file.

check out oreilys Apache boook its not that bad. but the online help for apache is pretty good as is.
# 5  
Old 06-06-2001
CPU & Memory

I recommend compiling PHP into the Apache binary and not as a loadable module. It is 'one less thing that can break' PLUS if you are going to use PHP with Apache (and MySQL) full time, this is a good thing to do. We only use a static (compiled into the kernel) method, not as a module.
# 6  
Old 06-06-2001
ok, thanks, i think ive almost solved the problem, the instructions say do not install teh package, instead use the tar ball, what is a tar ball and how do i use it?
# 7  
Old 06-06-2001
tarball is just a tar file.

slang i suppose.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #274
Difficulty: Easy
OpenSolaris is a descendant of the UNIX System V Release 4 (SVR4) code base developed by Sun and AT&T in the late 1980s.
True or False?

7 More Discussions You Might Find Interesting

1. Red Hat

Process not running: /opt/java15/jdk/bin/java -classpath /opt/apache/apache-ant-1.7.0-mod/lib/ant-la

Have no idea on what the below error message is: Process not running: /opt/java15/jdk/bin/java -classpath /opt/apache/apache-ant-1.7.0-mod/lib/ant-launcher.jar org.apache.tools.ant.launch.Launcher -buildfile build.xml dist. Any help? (3 Replies)
Discussion started by: gull05
3 Replies

2. Web Development

Apache module development on apache 2.2

Hi, I'm new to developing modules for Apache. I understand the basics now and can develop something simple which allows a 'GET' request to happen, but what I want to do is actually 'POST' information to my site. I know the basic POST Request works and I can see that it is post by looking at... (2 Replies)
Discussion started by: fishman2001
2 Replies

3. Programming

Problem with Perl script after moving from a Windows/Apache Server to a UNIX server.

I have a Perl script that worked fine before moving it to justhost.com. It was on a Windows/Apache server. Just host is using UNIX. Other Perl scripts on other sites that were also moved work fine so I know Perl is functioning. The script is called cwrmail.pl and is located in my cgi-bin. When I... (9 Replies)
Discussion started by: BigBobbyB
9 Replies

4. Shell Programming and Scripting

Apache Help..

I have properly installed Apache server 2.0 on Linux redhat9 and its working fine and showing its test page from LAN Computers. Now i want to change the directory of apache so it can show my webpages. Can anyone tell me where i can do that ????? Please help in detail because i am facing... (1 Reply)
Discussion started by: wakhan
1 Replies

5. UNIX for Dummies Questions & Answers

running apache on unix

Hi, I am running an application on apache/tomcat under unix. It was working fine until I stopped both tomcat and apache and restarted both. Now I am getting 404 not found error. Is there something here that I am missing. Any help will be appreciatd. Thx Karthik (1 Reply)
Discussion started by: kkarthik
1 Replies

6. IP Networking

Apache

I want to have multiple domains to be configured in apache web server on redhat linux can i have that without DNS server configured. What all i have to do for that.What all to configure ? And importantly i want the site be accessed by name rather IP address. Please help me ... (1 Reply)
Discussion started by: Vijayanand
1 Replies

7. UNIX for Dummies Questions & Answers

Apache!

How do you tell which apache version is currently running. the situation is that I got multiply httpd.conf files on a solaris 2.6 server and I need to tell which version is what? I have checked the httpd.conf but no joy Thanks in Advance (3 Replies)
Discussion started by: hassan2
3 Replies

Featured Tech Videos