DEBUG_PROG and opts: parameter not set

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers DEBUG_PROG and opts: parameter not set
# 1  
Old 11-07-2002
DEBUG_PROG and opts: parameter not set

I am using a Sun Ultra 30 with 250MG of RAM and 9GIG of hard drive. I connect to the machine via Exceed 6 and have the Oracle8i for Solaris in the cdrom drive. I have read and complied with Oracle's instruction in preparation to installing Oracle. Since I don't have enough space to cp the content of both CD's in the Ultra30, I run the ./runInstaller from the cdrom. However, I get two errors when I try to install it and no one I know has ever seen this and I don't know how to fix it so that Oracle is installed and I can learn and practice for my DBA exam.

Here is these errors I get:

Alex:/cdrom/oracle8i_se > ./runInstaller
Alex:/cdrom/oracle8i_se > Initializing Java Virtual Machine from /tmp/OraInstall/jre/bin/jre. Please wait...
/tmp/OraInstall/jre/bin/jre[91]: DEBUG_PROG: parameter not set

Alex:/cdrom/oracle8i_se > ./runInstaller
Alex:/cdrom/oracle8i_se > Initializing Java Virtual Machine from /tmp/OraInstall/jre/bin/jre. Please wait...
/tmp/OraInstall/jre/bin/jre[91]: opts: parameter not set

Alex:/cdrom/oracle8i_se >

I have looked on Oracle for assistance and got nothing. Can anyone help??

# 2  
Old 11-08-2002
Have you set your display back to your p.c. (or workstation ) you are connecting from? Normally this would give a different error (can't open display) but it's possible.

Once you sign into the server via Exceed, set display to your IP address (from workstation)

Either setenv DISPLAY

Also, you either need to be root or oracle user to do the install - follow the instructions that come with the product. You would proabably have to set up the oracle user and create the proper environment for it. Then do a su - to that user. Check your documentation.

The only other possible issue I can think of is that you don't have the correct path for java. Again, this should be documented in the installation guide.

Here is an example only of some of the steps in other types of Oracle installations: Note - I did put 'example only' - follow your documentation!!!

From SunSolve:

Create oracle users and add a group called dba to the /etc/group file
Make sure the oracle userid is the same on both nodes.

Here's the group file:


1. cp /etc/skel/local.cshrc and local.login to oracle's home directory

2. Edit .cshrc and add the oracle environment:

# @(#)cshrc 1.11 89/11/29 SMI
umask 022
set path=(/bin /usr/bin /usr/ucb /etc /export/oracle/7.1.6/bin .)

setenv ORACLE_SID oracle
setenv ORACLE_HOME /export/oracle/7.1.6

if ( $?prompt ) then
set history=32

NOTE: Oracle recommends making the ORACLE_SID parameter different on each node.
They recommend that you use the name of the database and a 1 and 2 after
it. For example, oracle1 and oracle2.

3. Make a directory called 7.1.6 (the oracle rev) in oracle's home directory.
This is where all the oracle executables will go.

4. Make sure .rhosts and hosts.equiv are set up so that you can rcp files back
and forth. When you install oracle, you install on one machine and the
installation program copies files to the second node.

5. Edit /etc/system and add the following section for shared memory to the
bottom of the file:

* set up shared memory for oracle
set semsys:seminfo_semmni=70
set semsys:seminfo_semmns=200
set shmsys:shminfo_shmmin=1
set shmsys:shm_info_shmmni=100
set shmsys:shm_info_shmseg=10
set shmsys:shminfo_shmmax=8388608
set semsys:seminfo_semmsl=50

NOTE: Before you begin installing oracle, make sure that the pdb is running
and all the volumes are owned by oracle.

6. Mount the oracle cdrom:

# mount -r -F hsfs /dev/dsk/c0t6d0s0 /cdrom

7. Run the orainst program as oracle:

% cd /cdrom/oracle/orainst

8. Set ORACLE_TERM to xsun if in xterm. Set ORACLE_TERM to sun if in cmdtool
% setenv ORACLE_TERM xsun
% orainst

disabled smilies --oombera

Last edited by oombera; 02-16-2004 at 01:31 PM..
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Solaris "ksh" Parameter Not Set

Getting the following when I try to set -u or set -o nounset in ksh on Solaris. Anyone ever seen this? Using an account I just built so everything is default and default shell is set to ksh. Oracle Corporation SunOS 5.11 11.3 September 2015 bar@solaris11:~$ echo $0 -ksh bar@solaris11:~$ set... (3 Replies)
Discussion started by: epost
3 Replies

2. Shell Programming and Scripting

Can't set parameter to lynx properly

My intention is to go through list of addresses and call google geocode api for each of them. I am using lynx for this, but somehow I can't supply the parameters to it in a proper way. To show that my parameters are OK I just hardcoded one address in my script and put it in my input file, and... (2 Replies)
Discussion started by: migurus
2 Replies

3. Shell Programming and Scripting

"ksh: XYZ: parameter not set" in .profile

Hi, A very basic query. I am working on two different UNIX servers and I see different behaviours for my user id. This has to be a setting in the .profile, but I can't seem to find where :confused: So, in one server if I type echo $XYZDD (a random variable), I get a blank line with no... (2 Replies)
Discussion started by: ALDonP
2 Replies

4. Shell Programming and Scripting

Passing parameter to script, and split the parameter

i am passing input parameter 'one_two' to the script , the script output should display the result as below one_1two one_2two one_3two if then echo " Usage : <$0> <DATABASE> " exit 0 else for DB in 1 2 3 do DBname=`$DATABASE | awk -F "_" '{print $1_${DB}_$2}` done fi (5 Replies)
Discussion started by: only4satish
5 Replies

5. Programming

Problem with STL's std::set container parameter to the operator << ()

Hi, I have this following code which gives me error when compiling. The problem is happening at the point where I create a const_iterator inside the overloaded insertion operator (i.e) operator << () function. The template argument version of set is not correct I guess. Could anyone please pitch... (3 Replies)
Discussion started by: royalibrahim
3 Replies

6. Shell Programming and Scripting

Command that takes one parameter and then searches for the passed in parameter

Hi I am looking for a unix command or a small shell script which can takes one parameter and then searches for the passed in the parameter in any or all files under say /home/dev/ Can anyone please help me on this? (3 Replies)
Discussion started by: pankaj80
3 Replies

7. Shell Programming and Scripting

Dot operator and space, Parameter not set

Hi, i have this script if then echo "is empty" fi echo "done" The following is the result when i run the script from command without and with a dot and space operator $ is empty done $ . sh: VAR_1: Parameter not set. $ It's our standard to run... (5 Replies)
Discussion started by: ysrini
5 Replies

8. UNIX and Linux Applications

set mysql password with host parameter

hi, linux gurus... i'm trying to write a script in ksh called ResetPass that allows a user to change mysql passwords. the script accepts user, password and host like this: ResetPass <user> <password> <host>. here's the code: ***************************************************** mysql... (1 Reply)
Discussion started by: ankimo
1 Replies

9. Shell Programming and Scripting

how do I make dynamic parameter names? Or get the value of a parameter evaluated twi

Say I write something like the following: var1=1 var2=2 for int in 1 2 do echo "\$var$int" done I want the output to be: 1 2 Instead I get something like: $var1 $var2 (2 Replies)
Discussion started by: Awanka
2 Replies

10. Shell Programming and Scripting

ksh: dbfFILe: parameter not set

Having the following message returned: FIND REDLOG FILES..... ksh: dbfFILe: parameter not set When I attempt to perform the script below....#!/bin/ksh . $HOME/.profile # Initial Script Prerequisites ORACLE_SID=MDirect ; export ORACLE_SID REDOLOGDIR=$ARCLOGDEST ; export REDOLOGDIR... (2 Replies)
Discussion started by: Cameron
2 Replies
Login or Register to Ask a Question