Visit Our UNIX and Linux User Community


Remote mount of a cdrom


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Remote mount of a cdrom
# 1  
Old 08-28-2002
Remote mount of a cdrom

I am trying to remote mount a cdrom (Sun Ultra 10 running release 7) on another system.

I followed the following procedure offered by a friend:

To allow a drive to be mounted, edit /etc/dfs/dfstab file to include the following line:

share -F nfs -o ro /usr/man


On computer with drive to be shared, type:

share -F nfs /cdrom/cdrom0


On Computer with drive to be mounted, type

mount "remote hostname":/cdrom/cdrom0 /mnt

I get this error message after the mount command - RPC:: Program Not Registered.

What am I missing?
# 2  
Old 08-29-2002
issue the command:

shareall -F nfs
on the computer with shared cdrom and
make sure nfs daemon is running on the
on this computer

issued ps -ef | grep nfs
this should list the nfs daemon

if nfs deamon is not running you could
start it up by cd /etc/init.d
and issued ./nfs.server start

on the computer with drive to be mounted issue

mount -v "remote hostname":/cdrom/cdrom0 /mnt
# 3  
Old 08-30-2002
QUOTE:
I get this error message after the mount command - RPC:: Program Not Registered.


There are a few things you can look at.

First, it looks like you don't have the rpcd daemon running. That needs to be running.

Also, I would do this.

Telnet to the box exporting the CD from your other box. Then run who -R to show all remote connections. Make sure that you actual hostname is the name used in this output. I had a problem where my hostname is "myhost" but my exported name is "myhosta"!!


Hope this helps


My brain is your brain...

Smilie
# 4  
Old 03-12-2003
mount -v

I tried your solution:

mount -v "remote hostname":/cdrom/cdrom0 /mnt

on Solaris 8 and get the error "can't use -v option with arguments.

I try:
mount "remote hostname":/cdrom/cdrom0 /mnt

and it works OK.

you can't start the /etc/init.d/nfs.server daemon unless you have:

share -F nfs /cdrom/cdrom0 in /etc/init.d/dfstab
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #353
Difficulty: Medium
mawk is a very fast AWK implementation by Mike Brennan based on a Python interpreter.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Unable to mount CDROM

Hi I have created a RHEL6 machine that is hosted on VMWare player that in turn runs off my Windows 7 PC. When I try and mount the CDROM on the RHEL6 box I get the following output: $ mount /dev/cdrom/media mount: can't find /dev/cdrom/media in /etc/fstab or /etc/mtab $ Here is the... (3 Replies)
Discussion started by: accipiter1
3 Replies

2. UNIX for Dummies Questions & Answers

CDROM does not mount

Hi people, I am a new user of Unix, I want to ask a basic question. I have a solaris 10 system. I want to use the cd-rom but I can't see what's inside in the cd. I put the cd and then ; root@hubatusvr # mount /dev/dsk/c0t3d0s2 /cdrom mount: /dev/dsk/c0t3d0s2 is already mounted or /cdrom is busy... (2 Replies)
Discussion started by: hubatuwang
2 Replies

3. UNIX for Dummies Questions & Answers

can't mount cdrom

Hi there I am trying to mount a cdrom using: mount /cdrom and I get the error: mount: mount point cannot be determined If I try the command mount cdrom /cdrom nfs mount: nfs file system; use path I tried running mountall and mountall -F NFS but to no avail (3 Replies)
Discussion started by: niamh
3 Replies

4. HP-UX

cannot mount cdrom with SAM

Hi there, I am building an HP UX 11 server (first time) and I'm trying to mount the CDROM with SAM. What am I supposed to enter in the "mount directory" box? Also, I can't ftp to the server due to a logon failure. I used root id and password. I deleted the file in the /etc/ftpd directory but... (8 Replies)
Discussion started by: rbglo
8 Replies

5. SCO

cdrom will not mount

I am trying to mount my a cd in my SCO 5.0.7 box and keep getting this: Alessandra! -->#mount -r /dev/cd0 /mnt mount: cannot stat '/dev/cd0' Alessandra! -->hwconfig name=kernel vec=- dma=- rel=3.2v5.0.7 kid=2003-02-18 name=cpu vec=- dma=- unit=1... (0 Replies)
Discussion started by: herot
0 Replies

6. AIX

mount directory as cdrom

Hi guy's, my first post here on the forum :p I did a quick search here, but did not find a direct hit, so decided to post my question. I'm taking my first steps into AIX, and right now I'm trying to install some software that I've downloaded as a zip file, and have this extracted into a mounted... (1 Reply)
Discussion started by: psyduck
1 Replies

7. UNIX for Advanced & Expert Users

CDROM Doesn't Auto Mount - Solaris 9

On Sun Fire V240, cdrom doesn't automount. I can manually mount the cdrom, however it pretty annoying. I have checked the vold demon and its seems to be running. Here is the output from /etc/inetd.conf pg inetd.conf daytime stream tcp6 nowait root internal daytime dgram udp6 ... (2 Replies)
Discussion started by: mshafi
2 Replies

8. UNIX for Advanced & Expert Users

mount cdrom

Info: Alpha Server ES40, True64 Unix 4.0F Symptom: root#file /dev/rrz*c root#. . /dev/rrz24c: character special (8/49154) EIDE #3 CDR-8435 disk #192 (scsi ID #0) (SCSI LUN #0) offline root#mount -r /dev/rz24c /mnt root#/dev/rz24c on /mnt: I/O error pls help me, i don't know if... (2 Replies)
Discussion started by: q30
2 Replies

9. UNIX for Dummies Questions & Answers

mount cdrom

I have an external cdrom drive, which am tring to mount. I issued the following mkdir cdrom to create a mount point then mount -F cdfs /dev/dsk/c0t4d0s7 /cdrom but this is unsuccessful instead received an error message mount point not found can you help (5 Replies)
Discussion started by: hassan2
5 Replies

10. UNIX for Dummies Questions & Answers

mount cdrom

hi when i want to mount my cdrom i got this error cd9660: /dev/acd0c: Invalid argument this is how my /etc/fstab looks like: #device mntpoint FStype Options Dump pass /dev/ad0s1b none swap sw 0 0... (2 Replies)
Discussion started by: Stormpie
2 Replies

Featured Tech Videos