Unable to mount CDROM

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Unable to mount CDROM
# 1  
Unable to mount CDROM


I have created a RHEL6 machine that is hosted on VMWare player that in turn runs off my Windows 7 PC.

When I try and mount the CDROM on the RHEL6 box I get the following output:

[twood@localhost ~]$ mount /dev/cdrom/media
mount: can't find /dev/cdrom/media in /etc/fstab or /etc/mtab
[twood@localhost ~]$

Here is the output from the /etc/fstab file:

I have also listed the files under /dev/sr0:
# Created by anaconda on Tue Sep 25 08:44:35 2012
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
UUID=750e57a7-374a-42b7-80a8-ebc2ba6edf4a /                       ext4    defaults        1 1
UUID=e6619f17-bd0d-4f80-9c38-8b37bc0c862c /boot                   ext4    defaults        1 2
UUID=efade61b-c9b2-432d-a77a-dd32ad6f8e90 swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sr1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0

When I run the "mount" command I see that there is no CD device mounted:

[root@localhost ~]# mount
/dev/sda2 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
/dev/sda1 on /boot type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
vmware-vmblock on /var/run/vmblock-fuse type fuse.vmware-vmblock (rw,nosuid,nodev,default_permissions,allow_other)

I have also checked the settings under /dev/sr0:

[root@localhost ~]# ls -al /dev/cd*
lrwxrwxrwx. 1 root root 3 Oct  3 05:51 /dev/cdrom1 -> sr0
lrwxrwxrwx. 1 root root 3 Oct  3 05:51 /dev/cdrw1 -> sr0
[root@localhost ~]# ls -l /dev | grep cd
lrwxrwxrwx. 1 root root           3 Oct  3 05:51 cdrom1 -> sr0
lrwxrwxrwx. 1 root root           3 Oct  3 05:51 cdrw1 -> sr0
lrwxrwxrwx. 1 root root           3 Oct  3 05:51 scd0 -> sr0
crw-rw----. 1 root cdrom    21,   0 Oct  3 05:51 sg0
brw-rw----+ 1 root cdrom    11,   0 Oct  3 05:51 sr0

After searching through various Linux forums and websites I tried the following command:

[root@localhost media]# mount -t ext3 /dev/sr0 /media/cdrom
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
[root@localhost media]# dmesg | tail
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
SELinux: initialized (dev sr0, type iso9660), uses genfs_contexts
VFS: busy inodes on changed media or resized disk sr0
VFS: busy inodes on changed media or resized disk sr0
VFS: busy inodes on changed media or resized disk sr0
VFS: busy inodes on changed media or resized disk sr0
VFS: busy inodes on changed media or resized disk sr0
VFS: busy inodes on changed media or resized disk sr0
EXT3-fs (sr0): error: can't find ext3 filesystem on dev sr0.
[root@localhost media]#

Incidently, under my /dev file system there is no "cdrom" file. There are the following files, though: cdrom1 cdrw1, dvd1 and dvdrw1.
So my final question is: If I can't mount the CDROM under "/dev/cdrom/media" where can I mount it?
I hope this makes sense. My apologies as this is the first time I have used this forum for a while and am not familiar with the correct etiquette etc.
# 2  
cdroms are not ext3, they are iso9660.

I have no idea where you got /dev/cdrom/media.

Just mount /media/cdrom0 ought to do the job according to your fstab.
This User Gave Thanks to Corona688 For This Post:
# 3  
Unable to mount CDROM

Thanks for your feedback.

I inserted a RHEL4 CD into the drive tried running the #mount /media/cdrom# command but the drive didn't seem to recognise the media.

#[root@localhost ~]# mount /media/cdrom0
mount: no medium found on /dev/sr0#

I tried another CDROM but got the same message. I then run the following commands:

#[root@localhost ~]# dmesg | grep sr0
sr0: scsi3-mmc drive: 1x/1x writer dvd-ram cd/rw xa/form2 cdda tray
sr 2:0:0:0: Attached scsi CD-ROM sr0
[root@localhost ~]# 
#[root@localhost ~]# ls -al /dev/sr0
brw-rw----+ 1 root cdrom 11, 0 Oct 23 08:13 /dev/sr0
[root@localhost ~]# ls -al /dev/cdrom0
ls: cannot access /dev/cdrom0: No such file or directory
[root@localhost ~]# ls -al /dev/cdrom1
lrwxrwxrwx. 1 root root 3 Oct 23 08:13 /dev/cdrom1 -> sr0
[root@localhost ~]#

Can you suggest anything else?.

Last edited by Corona688; 10-23-2012 at 01:39 PM..
# 4  
My RHEL virtual Machine Does not have Virtual Machine Manager Desktop Tool


I don't seem to have the Virtual Machine Manager Desktop tool set up on my RHEL6 Machine. The Linux machine runs off VMWare player and I'm not sure whether it is a VMWare software issue or a problem with the RHEL6 installation.

When I launch a GNOME GUI there is no option for VMM under "Applicatons">"System Tools". (See Attachment)

I also run the following command:

HTML Code:
[root@localhost ~]# lsmod | grep kvm
kvm                   300283  0
As mentioned above, the Linux machine runs off a VMWare Player platform. When I built the machine I used the quick install option on VMWare Player and in doing so there seems to be some features missing - including the VMM desktop tool.

Once again, I'm not sure if this is a VMWare or RHEL6 issue. Please could someone shed some light on this issue.
Unable to mount CDROM-image001png

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #850
Difficulty: Medium
Every Bluetooth device has a unique 48-bit address.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

CDROM does not mount

Hi people, I am a new user of Unix, I want to ask a basic question. I have a solaris 10 system. I want to use the cd-rom but I can't see what's inside in the cd. I put the cd and then ; root@hubatusvr # mount /dev/dsk/c0t3d0s2 /cdrom mount: /dev/dsk/c0t3d0s2 is already mounted or /cdrom is busy... (2 Replies)
Discussion started by: hubatuwang
2 Replies

2. UNIX for Dummies Questions & Answers

can't mount cdrom

Hi there I am trying to mount a cdrom using: mount /cdrom and I get the error: mount: mount point cannot be determined If I try the command mount cdrom /cdrom nfs mount: nfs file system; use path I tried running mountall and mountall -F NFS but to no avail (3 Replies)
Discussion started by: niamh
3 Replies

3. HP-UX

cannot mount cdrom with SAM

Hi there, I am building an HP UX 11 server (first time) and I'm trying to mount the CDROM with SAM. What am I supposed to enter in the "mount directory" box? Also, I can't ftp to the server due to a logon failure. I used root id and password. I deleted the file in the /etc/ftpd directory but... (8 Replies)
Discussion started by: rbglo
8 Replies

4. SCO

cdrom will not mount

I am trying to mount my a cd in my SCO 5.0.7 box and keep getting this: Alessandra! -->#mount -r /dev/cd0 /mnt mount: cannot stat '/dev/cd0' Alessandra! -->hwconfig name=kernel vec=- dma=- rel=3.2v5.0.7 kid=2003-02-18 name=cpu vec=- dma=- unit=1... (0 Replies)
Discussion started by: herot
0 Replies

5. AIX

mount directory as cdrom

Hi guy's, my first post here on the forum :p I did a quick search here, but did not find a direct hit, so decided to post my question. I'm taking my first steps into AIX, and right now I'm trying to install some software that I've downloaded as a zip file, and have this extracted into a mounted... (1 Reply)
Discussion started by: psyduck
1 Replies

6. UNIX for Advanced & Expert Users

CDROM Doesn't Auto Mount - Solaris 9

On Sun Fire V240, cdrom doesn't automount. I can manually mount the cdrom, however it pretty annoying. I have checked the vold demon and its seems to be running. Here is the output from /etc/inetd.conf pg inetd.conf daytime stream tcp6 nowait root internal daytime dgram udp6 ... (2 Replies)
Discussion started by: mshafi
2 Replies

7. UNIX for Dummies Questions & Answers

Remote mount of a cdrom

I am trying to remote mount a cdrom (Sun Ultra 10 running release 7) on another system. I followed the following procedure offered by a friend: To allow a drive to be mounted, edit /etc/dfs/dfstab file to include the following line: share -F nfs -o ro /usr/man On computer with drive... (3 Replies)
Discussion started by: leond
3 Replies

8. UNIX for Advanced & Expert Users

mount cdrom

Info: Alpha Server ES40, True64 Unix 4.0F Symptom: root#file /dev/rrz*c root#. . /dev/rrz24c: character special (8/49154) EIDE #3 CDR-8435 disk #192 (scsi ID #0) (SCSI LUN #0) offline root#mount -r /dev/rz24c /mnt root#/dev/rz24c on /mnt: I/O error pls help me, i don't know if... (2 Replies)
Discussion started by: q30
2 Replies

9. UNIX for Dummies Questions & Answers

mount cdrom

I have an external cdrom drive, which am tring to mount. I issued the following mkdir cdrom to create a mount point then mount -F cdfs /dev/dsk/c0t4d0s7 /cdrom but this is unsuccessful instead received an error message mount point not found can you help (5 Replies)
Discussion started by: hassan2
5 Replies

10. UNIX for Dummies Questions & Answers

mount cdrom

hi when i want to mount my cdrom i got this error cd9660: /dev/acd0c: Invalid argument this is how my /etc/fstab looks like: #device mntpoint FStype Options Dump pass /dev/ad0s1b none swap sw 0 0... (2 Replies)
Discussion started by: Stormpie
2 Replies

Featured Tech Videos