ypbind wont bind?

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers ypbind wont bind?
# 1  
Old 02-07-2008
ypbind wont bind?

Well one problem down and another just pops up. I run ypbind and I see

Starting NIS service: [OK ]
Binding NIS service: [FAILED]
Shutting down NIS service: [OK ]

To my knowledge everything is configured properly.
I ran tcpdump on the machine running ypserv to see what was happening and here was the output (well the cleaned up version):

17:52:51.262128 IP node2.746 > head.node.sunrpc: UDP, length 56
17:52:51.262408 IP head.node.sunrpc > node2.746: UDP, length 28
17:52:51.262875 IP node2.filenet-nch > head.node.nlogin: UDP, length 108
17:52:56.262364 arp who-has node2 tell head.node
17:52:56.262505 arp reply node2 is-at 00:0b:db:5a:57:36 (oui Unknown)
17:52:56.262749 IP node2.fujitsu-dev > head.node.sunrpc: UDP, length 56
17:52:56.262935 IP head.node.sunrpc > node2.fujitsu-dev: UDP, length 28
17:52:56.263503 IP node2.filenet-nch > head.node.nlogin: UDP, length 108
17:53:01.262628 IP node2.ris-cm > head.node.sunrpc: UDP, length 56
17:53:01.262832 IP head.node.sunrpc > node2.ris-cm: UDP, length 28
17:53:01.263122 IP node2.filenet-nch > head.node.nlogin: UDP, length 108
17:53:06.262502 IP node2.749 > head.node.sunrpc: UDP, length 56
17:53:06.262708 IP head.node.sunrpc > node2.749: UDP, length 28
17:53:06.263244 IP node2.filenet-nch > head.node.nlogin: UDP, length 108
17:53:11.262374 IP node2.kerberos-iv > head.node.sunrpc:
17:53:11.262691 IP head.node.sunrpc > node2.kerberos-iv:
17:53:11.263117 IP node2.filenet-nch > head.node.nlogin: UDP, length 108
17:53:16.262246 IP node2.kerberos_master > head.node.sunrpc: UDP, length 56
17:53:16.262456 IP head.node.sunrpc > node2.kerberos_master: UDP, length 28
17:53:16.262740 IP node2.filenet-nch > head.node.nlogin: UDP, length 108
17:53:21.262120 IP node2.passwd_server > head.node.sunrpc: UDP, length 56
17:53:21.262317 IP head.node.sunrpc > node2.passwd_server: UDP, length 28
17:53:21.262863 IP node2.filenet-nch > head.node.nlogin: UDP, length 108
17:53:26.261993 IP node2.754 > head.node.sunrpc: UDP, length 56
17:53:26.262204 IP head.node.sunrpc > node2.754: UDP, length 28
17:53:26.262486 IP node2.filenet-nch > head.node.nlogin: UDP, length 108e
17:53:31.261615 IP node2.755 > head.node.sunrpc: UDP, length 56
17:53:31.261821 IP head.node.sunrpc > node2.755: UDP, length 28
17:53:31.262369 IP node2.filenet-nch > head.node.nlogin: UDP, length 108
17:53:36.261489 IP node2.756 > head.node.sunrpc: UDP, length 56
17:53:36.261704 IP head.node.sunrpc > node2.756: UDP, length 28
17:53:36.261982 IP node2.filenet-nch > head.node.nlogin: UDP, length 108
# 2  
Old 02-08-2008
have you checked to see whether or not the client can actually ping/resolve the NIS IP/name? Maybe its not a NIS problem but a DNS problem
# 3  
Old 02-08-2008
Well it is definitely node a DNS issue:

[root@head ~]# ping node2
PING node2 ( 56(84) bytes of data.
64 bytes from node2 ( icmp_seq=1 ttl=64 time=0.246 ms
64 bytes from node2 ( icmp_seq=2 ttl=64 time=0.457 ms
64 bytes from node2 ( icmp_seq=3 ttl=64 time=0.425 ms

--- node2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 0.246/0.376/0.457/0.092 ms
[root@head ~]# rpcinfo -p node2
program vers proto port service
100000 4 tcp 111 portmapper
100000 3 tcp 111 portmapper
100000 2 tcp 111 portmapper
100000 4 udp 111 portmapper
100000 3 udp 111 portmapper
100000 2 udp 111 portmapper
100000 4 0 111 portmapper
100000 3 0 111 portmapper
100000 2 0 111 portmapper
100024 1 udp 32768 status
100024 1 tcp 45407 status
100021 1 tcp 47257 nlockmgr
100021 3 tcp 47257 nlockmgr
100021 4 tcp 47257 nlockmgr
[root@head ~]#

Everything for NIS was configured in the kickstart file for the nodes, but I've gone through and double checked and everything appears to be alright. At first I thought it was ypbind's problem but since I can see it trying to reach the head node in tcpdump ON the head node I'm assuming it has to do with ypserv or something else is blocking it. It isn't portmapper because on the nodes rpcinfo -p head.node resolves fine. My firewall and selinux were both disabled as well. I'm really stumped.
# 4  
Old 02-08-2008
What OS are you trying to run this on?
Do you have other clients bound to the NIS host?
What is in /etc/defaultdomain?
What is in /etc/yp.conf?
Is the NIS master in your /etc/hosts file?
What do the following commands return...

# 5  
Old 02-08-2008
All the machines are FC8, the host and all the nodes. I'm just setting this up for the first time and no, none of the machines are working with ypbind - well with the exception of the head node.

There is no /etc/defaultdomain because the startup script assigns the domains to each machine. I can try creating this file anyway but I don't believe it would affect anything.

yp.conf =

domain node1 server

The domain name changes respectively for each node.

Yup the head node is there, heres /etc/hosts

# Do not remove the following line, or various programs
# that require network functionality will fail. node1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6 head.node
# node1 node2 node3

On the nodes ypwhich returns:

[root@node1 ~]# ypwhich
ypwhich: Can't communicate with ypbind
[root@node1 ~]#

which is to be expected because ypbind wont start

On the master ypbind is running fine so it returns:

[root@head home]# ypwhich
[root@head home]#

The nodes respectively show something similar to this:

[root@node1 ~]# domainname
[root@node1 ~]#

And the master shows:

[root@head home]# domainname
[root@head home]#
# 6  
Old 02-08-2008
I noticed that the line for node1 is commented out in you /etc/hosts file.

Also, have you tried running ypinit -c from the client?
It should prompt for the server to bind to. You can use the ip address of the master just to be sure.
# 7  
Old 02-08-2008
That file where you noticed the comment is /etc/hosts from node1, so node1 is defined up with localhost and commented out there. eh, ypinit -c I saw this else where but this is what I see when I try to run it :

[root@node1 yp]# ./ypinit -c
ypinit -m
ypinit -s master

where -m is used to build the data bases on a master NIS server,
and -s is used for a slave data base. master must be an existing
reachable NIS server.
[root@node1 yp]#
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

script wont run

$ ls -l total 44 drwx------ 2 ivanachu users 512 Dec 6 19:15 VILEARN -rw------- 1 ivanachu users 74 Dec 5 18:42 cond -rwx------ 1 ivanachu users 97 Dec 5 21:30 cond2 -rwxrwxrwx 1 ivanachu users 4979 Feb 10 22:42 createHAqmgr.ksh -rw------- 1 ivanachu users 28 Dec 4... (10 Replies)
Discussion started by: ivanachukapawn
10 Replies

2. AIX

check the status of ypbind

hello , How do i to check the status of ypbind on AIX(5.3) platform ? Thanks AVK Linux (1 Reply)
Discussion started by: avklinux
1 Replies

3. HP-UX

ypbind start/stop

Hi, How to start or stop ypbind on HP-UX machine. Searched a little but could not find. thanks, (2 Replies)
Discussion started by: jredx
2 Replies

4. HP-UX

Wont boot

I am new to HP-UX. I have a external SCSI drive with HP-UX on it. I was trying to clone it to another external scsi drive. I added the new drive to existing LVM. Then I used dd command. But it failed with I/O error. Now I cannot boot it from original drive. It's saying panic: LVM: Configuration... (11 Replies)
Discussion started by: forhad
11 Replies

5. Solaris

ypbind - multiple instances starting

I have built this Solaris 10 server, uses NIS. When the server starts up, two instances of ypbind start. This prevents the server from binding to any domain. The SMF in turn prevents any other network services (sshd and the like) from starting up. Has anyone seen this problem before? (0 Replies)
Discussion started by: blowtorch
0 Replies

6. Solaris

SMC wont start

Today I attempted to use SMC for the first time on SUNSVR01 since 4 November. The SMC toolbox loads just fine but when I attempt to run any of the tools in SMC, I get red stop signs with labels like "com.sun.admin.hostmgr.client.vhostmgr" in the GUI. At the bottom of the screen, I get the... (0 Replies)
Discussion started by: wjseaman
0 Replies

7. Solaris

file wont remove

check this out ls -l nmo* -rwsr-s--- 1 root dba 19312 Mar 31 14:44 nmo -rw-r----- 1 oracle dba 0 May 19 2004 nmo0 -rwxr-x--- 1 oracle dba 16512 Mar 31 14:44 nmocat # rm nmo0 nmo0: No such file or directory # id uid=0(root) gid=1(other) what... (8 Replies)
Discussion started by: csaunders
8 Replies

8. UNIX for Dummies Questions & Answers

Monitor wont come on...

I know this may not be the right forum, but here goes. Last night I was playing my favorite game Everquest and my monitor goes blank... I was able to save out of my game and shut it down... My question is this: I thought my monitor had died but this morning I was able to get it to come back... (6 Replies)
Discussion started by: Kelam_Magnus
6 Replies

9. UNIX for Dummies Questions & Answers

Apache wont start

Hi, like a lot of people that post here, I am new at UNIX. The only UNIX I have ever messed with is my iBook running MacOSX (10.1). I have a grasp of the basic commands and understanding of the system but only to a point. I searched the archive and FreeBSD.org and apache.org but I couldn't find... (4 Replies)
Discussion started by: Alpha_Harblo
4 Replies
Login or Register to Ask a Question