Apache wont start

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Apache wont start
# 1  
Old 01-02-2002
Question Apache wont start

Hi, like a lot of people that post here, I am new at UNIX. The only UNIX I have ever messed with is my iBook running MacOSX (10.1). I have a grasp of the basic commands and understanding of the system but only to a point.

I searched the archive and FreeBSD.org and apache.org but I couldn't find anything that helped me any.

Anyway, I just set up a FreeBSD Box (4.4) with an AMD K6 333, 2.5G, 32MBs of ram, ect... and I have been haveing fun trying to get it to work properly for me.

I got most of the stuff to work besides the sound card, but I'll mess with that later.

I'm wanting to use it as a webserver but I can't get apache to work. I just reinstalled everything last night. I installed everything in the www install packet. Every time I try to start apachectl it gives me this error

[alert] httpd: Could not determine the server's fully qualified domain name, using for ServerName
/usr/local/sbin/apachectl start: httpd could not be started

As of now, I don't plan to attach a domain to my system, I just want to mirror the IP address to my normal website. I was able to do this with the apache on my iBook with no problem, and, in fact, the apache on the BSD Box was working when I wasn't able to get my NIC card to work.

I don't know what to do with httpd.conf and i don't know if there is anything I should do with any of the hosts files. As you can see, I'm a bit lost.

I have this system behind a linksys router on a cable modem and the BSD box and my iBook are set as DHCP rather than static.

Thanks, and i hope I gave you enough information
# 2  
Old 01-02-2002

Apache will not start if there is a syntax or configuration error in the httpd.conf file.
# 3  
Old 01-02-2002
ok I messed around in the httpd.conf file and I'm not getting " [alert] httpd: Could not determine the server's fully qualified domain name, using for ServerName ", but I'm still getting /usr/local/sbin/apachectl start: httpd could not be started.

What I did was I enabled the NameServer and set it to Should I set this to something else?
# 4  
Old 01-02-2002
Sounds like you have a lot of basic leaning to do with TCP/IP like hostnames, nameservers, IP addresses,etc. The best approach is to get the O'Reilly book on Apache and read it, step-by-step; if you need more information on TCP/IP you might consider keeping the O'Reilly book TCP/IP Network Adminstration next to the Apache book.

Prior to setting up Apache, you need to insure your TCP/IP infrastructure is up and running. What is your IP address? The IP address of your nameserver(s)? Your host and domain names? What is the IP address of your web server?

These are all basic TCP/IP network administration 'things' that you need to know prior to trying to configure an Apache web server.
# 5  
Old 01-02-2002
I seen that book at hastings, I'll pick it up

Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

Apache start error

I have a new server, installed everything and tried to get it all up and running. Got the following issue: # /usr/local/apache/bin/apachectl start httpd: Syntax error on line 54 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/modules/libphp5.so into server:... (0 Replies)
Discussion started by: Tommyk
0 Replies

2. UNIX for Advanced & Expert Users

Apache does not start

After i added this line to my apache httpd.conf it does not start. AuthUserFile /apps/apache22/conf/httpd.passwd and i see the below error. Syntax error on line 876 of /apps/apache22/conf/httpd.conf: AuthUserFile not allowed here Kindly help. (4 Replies)
Discussion started by: mohtashims
4 Replies

3. Solaris

apache cannot start

hi all i'm having a problem with apache on solaris 10 SPARC I'm trying to start httpd as root but it fails with the following error /usr/local/apache2/bin/httpd -k start httpd: Could not determine the server's fully qualified domain name, using for ServerName (20014)Error... (16 Replies)
Discussion started by: h@foorsa.biz
16 Replies

4. Solaris

Apache start issue

Hi group, I need help to start apache in following scenario: 1) Say apache is installed on solaris OS by user 'root'. 2) An entry is there in httpd.conf that says to start apache process as user: #User <RUN_AS_USER> is edited as User user1 2) Now say user2 has logged and tries to start... (6 Replies)
Discussion started by: rs266
6 Replies

5. Solaris

help me........... my apache can't start

help me please.................bro i was install apache2 and i have been configure httpd.conf on my solaris 10 machine n i already running my httd service but why my webserver couldn't run on my browser? some buddy help me.............:confused::confused::confused::confused::confused: (5 Replies)
Discussion started by: yatmianto
5 Replies

6. UNIX for Advanced & Expert Users

Xwindows wont start

I have one machince where X crashes with some weird error on boot... Fatal server error: Cannot move old logfile "/var/log/XFree86.0.log.old" This is running redhat enterprise ES 3, I cant figure out how to get past this error. I have tried deleting the logfiles and recreating them, however... (1 Reply)
Discussion started by: frankkahle
1 Replies

7. UNIX for Dummies Questions & Answers

startup script wont start up

I've put this script in /etc/rc.d and made a symbolic link to it from S99pctb in /etc/rc.d/rc3.d but it wont start up. Anyone know why ? This is the script: --------------------------- #!/bin/sh c=1 case "$1" in start) echo -n "starting pctb ..." > /etc/logger while ; do... (7 Replies)
Discussion started by: msearson1
7 Replies

8. Solaris

Apache start problem

Hi, I have installed apache webserver on my solaris 10(x86). When I tried to start the server it gives following error, ld.so.1: /usr/local/apache2/bin/httpd: fatal: libssl.so.0.9.8: open failed: No such file or directory Killedld.so.1:: Too many arguments Can somebody please guide me how... (1 Reply)
Discussion started by: maheshsri
1 Replies

9. AIX

Start Stop Apache

I am in the process of reorging my Lawson db. I need to turn off the RMI server...not a problem. However my instructions also state that I must also shutdown my Servlet Container....I believe it is Apache. I have looked in /usr/apache/bin/apachectl What is the command for stopping and... (2 Replies)
Discussion started by: MILLERJ62
2 Replies

10. Solaris

SMC wont start

Today I attempted to use SMC for the first time on SUNSVR01 since 4 November. The SMC toolbox loads just fine but when I attempt to run any of the tools in SMC, I get red stop signs with labels like "com.sun.admin.hostmgr.client.vhostmgr" in the GUI. At the bottom of the screen, I get the... (0 Replies)
Discussion started by: wjseaman
0 Replies
Login or Register to Ask a Question