Visit Our UNIX and Linux User Community


Linux problems


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Linux problems
# 1  
Old 03-17-2002
Linux problems

Hi

I'm using linux slackware 8.0 with the 2.2.19 kernel

I have some problems..

First problem:

I cannot get kernel 2.4.* to work.. it hangs when I boot and displays someting like: configuring 100mbps tbase 100x full duplex

what can cause this? and what can I do about it?

Second problem:

My sound doesnt work very good.. when I play a mp3 file, it sounds great.. unless I do something else at the same time.. if I scroll a page in netscape, startnetscape, move an aterm around, copy a file or something like that, the sound "lags" and is very slow...

My computer:
amd athlon XP 1700+ ~1.47ghz, 512mb DDR, 80gb hdd and my soundcard is a creative SB live

it's not only that way in X..

please help me

//Maestin
# 2  
Old 03-18-2002
For your Second question, have you correctly configure your sound card ? #sndconfig for the Creative sound driver should have any problems running on your Linux Kernel ( 2.4.* ). The module file should be under /usr/lib/2.4.*/modules/sound/
Try to probe the correct soudn driver. Another important part, your system (not bad) running at high performance. When you installed your Linux how many gb or mb you reserve for your Swap space/partition ? As per what you say, when you scroll your netspace or running some background tasks the Sound or song becomes slow i suspect could be your swap space limitations. Check it out and let us know.

Anyway are you connecting to network? If yes did you configure your network selection during the Installation. It seems that :configuring 100mbps tbase 100x full duplex
the Kernel is searching/looking for an Available IP address. And the process hangs. Pls re-confirm. Do Post back.
# 3  
Old 03-18-2002
Hi, thanks for answering

The sound works great now.. I switched mp3-player into xmms.. (used gqmpeg before)

My swap partition is 450 mb.. should that be enough?

About the network card, it doesnt seem to be looking for an ip-address.. (I dont use dhcp, I use static ip)

The computer freezes comletely..

Anyway.. what's better with running the 2.4.* kernel instead of 2.2.19?

Is it just newer with fewer bugs and more hardware support?

Thanks for the help

// Maestin
# 4  
Old 03-19-2002
The newer kernel offers more hardware support, as always, but it also offers more security, like the new firewalling code. It should also offer better memory management (which should help even more in your first problem! Too much swapping is bad for media - too slow... Real memory works much better).

Kernel upgrades take time to get used to, and even longer to master. The first time I compiled my own kernel, it took me 3 or 4 tries to get one that booted completely. Go through the config (I like using "make menuconfig"), and only enable things you need, otherwise your kernel will not boot. Something have to be built in, like drivers for your disk and whatnot. Use the description (The hotkey is F1 or F2, I think) of each item in the config to see if you'll need it. If you want it, but don't need it, you could always build it as a Module.

The best thing, probably, is to just try rebuilding until it works. Just make sure to keep notes on what config you used, and try to know what hardware you use beforehand.

Good luck with the recompile!
# 5  
Old 03-19-2002
Thanks.

But now I have another problem..

When I booted linux today, and was about to enter my username, the chars didn't show.. my keyboard doesn't work..

I tried rebooting, and disabling/enabling caps-lock many times when the kernel booted..

The keyboard stopped responding after it loaded the key-map and stuff.. I tried booting with a lilo-bootdisk but I got the same problem..

So I tried re-installing, but I still cant use the keyboard.. it worked great yesterday.. it works great in windows..

What happened?

// Maestin
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #467
Difficulty: Easy
In computer networking, telecommunication and information theory, broadcasting is a method of transferring a message to all recipients using reverse polish notation.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Problems logging into linux workstation

Hello everyone: I got this msg. when I tried to logging. "the files that contain your preference setings are currently in use" (I'm the only one). "You can continue to use the current session, but this might cause temporary problems with the preference settings in the other session". ... (2 Replies)
Discussion started by: marcvill
2 Replies

2. UNIX for Dummies Questions & Answers

CD mounting problems with linux

Hi guys I'm a newbie with linux i recently installed mandrake linux 10.0 double boot(win 98se) on a pIII 300mhz 128mb ram PC I have a standard cd rom and for some reason, linux refuses to mount the CD drive it worked perfectly for the first cople of monthes and than suddenly it didn't it... (0 Replies)
Discussion started by: bentzi
0 Replies

3. SuSE

Linux Network problems-Please help

Hullo everyone, I have recently installed SUSE 9.1 and attached it to my Network router (Actiontec 54Mbps Wireless DSL Gateway) but can't connect to the internet. It comes up with the following error message: An error occurred while loading "http://www.yahoo.com":Timeout on server - connection... (2 Replies)
Discussion started by: sybella1
2 Replies

4. Linux

Feather Linux Problems

I am currently trying to create a Feather Linux boot disk using a Flash Drive. I have the Feather Kernel installed on the Flashrive, and am trying to make ot bootable with Syslinux. However i think that my Syslinux is faulty because whenever i try to run it in DOS to make the Flashdrive in Drive... (1 Reply)
Discussion started by: slats142
1 Replies

5. UNIX for Dummies Questions & Answers

linux xmms sound problems

Dear all, I have been using suse linux for as long as I can remember. However, for every installation I get the same problem. Once the installation is completed, and all of my devices (brand new hardware, from reknown brands) are detected, I decide to start doing some work, and play some... (2 Replies)
Discussion started by: bionicfysh
2 Replies

6. IP Networking

radvd + ipv6 problems in Linux

Hi everyone, I have a weird problem in Linux. Well, for the past month i've been very interested in IPv6, and, a couple of days ago i decided to try to get it to work. I run Slackware 8.0 on my gateway/router-box, and, the freenet6.com-program and scripts started and worked just fine. There's one... (1 Reply)
Discussion started by: kuba
1 Replies

7. UNIX for Advanced & Expert Users

Suse Linux mount problems ?

We are experiencing several startup problems at boot time. In our /etc/rc.d/boot script we have "swapon -a -v &> /dev/null/' (without the quotes). We have also added echo statements to make it visible on the HMC during IPL. The echo statements are seen but there no messages for the swapon... (1 Reply)
Discussion started by: darthur
1 Replies

8. UNIX for Dummies Questions & Answers

Networking Problems On Linux

HI I JUST INSTALLED LINUX 7.0 ON MY COMPUTER AND IT WIPED OUT THE WHOLE WIN2K SO MY QUESTION IS THAT I CAN'T .....MY NETSCAPE NAVIGATOR DOESN'T WORK (NO INTERNET AT ALL) WHAT SHOULD I DO!... I HAVE A CABLE MODEM IP I USE TO SEARCH THE INTERNET WITH BOTH BROWSER IE AND NETS..NAV.. NOW I... (1 Reply)
Discussion started by: IMOTEB
1 Replies

9. UNIX for Dummies Questions & Answers

Linux and in.telnetd problems

Hi, This is not the usual "unable to telnet to my machine" post. I: * have ensured that in.telnetd is started from inet.conf * that hosts.allow/deny are correctly configured * in.telnetd is listening, and on the correct port When I check my syslog i notice that tcpd (as I have... (3 Replies)
Discussion started by: sam_pointer
3 Replies

10. UNIX for Dummies Questions & Answers

a world of suse linux problems

1) how do i disable the graphic login in suse linux? 2) how do i disable the graphic boot-up in suse linux? 3) how do i disable the graphic console in suse linux? i think disabling graphic console will disable graphic booting, but what do i know, eh? 4) where is the dhcpcd directory and... (2 Replies)
Discussion started by: nydel
2 Replies

Featured Tech Videos