How HDD under Solaris on Intel platform


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers How HDD under Solaris on Intel platform
# 1  
Question

On my Intel PC I have 4GB HDD on which I installed Solaris. I also installed 30GB HDD but the bios does not recognize anything beyond 8GB and that is what Solaris picks up. Under WinNT is an utility that allows me to access and format the full capacity of this 30GB HDD no matter what the bios says, is there a way to do it on Solaris as well? What I need the help with is:
** How do I mount a HDD disk, do I have to rerun installation like the first time to mount it?
** How do I format it to the full capacity, 30GB and not only upto 8GB?
Thanks very much.
# 2  
I suggest you upgrade your motherboard or BIOS to a more modern version. All the modern releases recognize large disks. The same is true for both BIOs and UNIX kernels. Motherboards with modern BIOS are very cheap these days. UNIX kernels (many good flavors) are also free or almost free. What motherboard and kind/version of BIOs are you running, BTW? What is the year of the release?
# 3  
Network

Well I downloaded the latest BIOS from Dell since that is where the machine came from but now the system does not recognize any HDD so I am trying to figure out how to fix lots of hardware problems. It seems like the BIOS I got from Dell has a big bug(!?). I get blue screens and nothing wants to work.
Would you know how to excess the kernel or is it in the BIOS and remove either the NT or Solaris?
Thanks.
# 4  
A couple of questions:

(1) When the system BIOS is running (before kernel boot strap/time) can you access the BIOS (using the DELETE key or whatever)?

(2) During the BIOs period above, does the system messages indicate that the hard disks are found? network cards? etc?

If (1) and (2) are OK, your new BIOs is fine. The problem is that your Master Boot Record or other boot blocks on the hard disk do not match the new BIOs (just an educated guess from the other end of the screen).

If the BIOS is operating properly, then you will have to reinstall the OS on top of the new BIOS. Before you do, you might consider reinstalling the old BIOS and making a backup of your important files. When you are satisfied, then reinstall the new BIOS (first) and reinstall the OS (second) on the new BIOS.

I can't speak about NT because all my back-office servers are Linux or other UNIXes. In my Linux systems, I've often changed BIOS or complete boards with old versions of the OS and never had any problem in the initial boot (using the old disk partitions). However, I normally rebuild a kernel immediately on the new board/BIOs, including rebuilding the disks with FDISK etc (and mount the old filesystem later).

Sounds like you are on the right track. You can also build an entire new OS on a new disk partition and mount the old disk(s) to recover files. Sorry, but my NT knowledge is weak because I can do all the 'server-side-stuff' on UNIX and don't have a reason for an NT server. Perhaps someone who is an NT guru can jump in and help in that area?

# 5  
You're very correct. It is the MBR problem. I'll do as you suggested and that is to reinstall the old BIOS.
Thank you very much.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #876
Difficulty: Medium
All operational code must be POSIX compliant in order to be cost effective.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

solaris 10 cd install(intel)

just need help with loading solaris 10 from cds that i bought from sun. i have a dell box that had solaris 8 on it, wiped it and stuck in the cd1 for solaris 10. selected "solaris" for install. went through a few minutes then comes up with"sunOS Release 5.10 version generic_137138-09 32-bit,... (3 Replies)
Discussion started by: flir11
3 Replies

2. Solaris

OBP on Solaris 10-intel

Hi All, How can I go to OBP on Solaris 10-intel? I tried doing ctrl+c or ctrl+break, it won't go to the "ok" prompt. Thanks in advance, itik (6 Replies)
Discussion started by: itik
6 Replies

3. SCO

Black Screen SCO Real. 5 (intel platform)

Hi everyone, I am new in here. I have to work on a system where nothing is showing up on the screen. I am suspecting an hardware issue, can anyone help me with this? Thanks for your input BB (4 Replies)
Discussion started by: labcc
4 Replies

4. UNIX for Advanced & Expert Users

Solaris on Intel

I was wondering what features are not available on Solaris installed on Intel architecture as compared to the SPARC archietecture?? :-) (3 Replies)
Discussion started by: encrypted
3 Replies

5. UNIX for Dummies Questions & Answers

Solaris 8 Intel

Do you now have to pay to download the Solaris 8 OE? If so when did they change it? (3 Replies)
Discussion started by: tycobb
3 Replies

6. Programming

C Compiler for Solaris 8 (Intel)

hi I'm looking for a C Compiler that will run on a Solaris 8 (Intel) platform and that doesn't need to be complied. I've tried gcc binaries but they don't seem to work. Thanx. (5 Replies)
Discussion started by: ianf
5 Replies

7. UNIX for Advanced & Expert Users

kde on solaris 8 intel

hi. Have anyone use kde for solaris, if so can you help me download and configure it. i don't know which files i should download for solaris because there lots of files. Could you point me to the right path.thanks in advance. (9 Replies)
Discussion started by: souldier
9 Replies

8. IP Networking

Solaris 8 on Intel TCP/IP

I have just installed solaris 8 for Intel on one of my machines at home and I have a cable modem connection with a static IP and I am using a linksys cable/dsl router to assign IP's to my machines. I was wondering if any of you guys know the specific files and examples of the files I have to... (2 Replies)
Discussion started by: reggie316
2 Replies

9. UNIX for Dummies Questions & Answers

Solaris Installation (Intel)

Pls help i've used the boot assistance disk to boot my computer (P3 300) after checking the drivers , i select the CD to install , however, the computer said it can't mount the CD CD is download from sun.com (solaris 8) my CD rom is Misabushi and Ricoh (7060) , both cannot do so, what is... (4 Replies)
Discussion started by: kazamih
4 Replies

10. UNIX for Dummies Questions & Answers

Creating Domains on Intel platform

I'm trying to ling three solaris 8 machines on to one domain. I have DNS up and running. Do not know how to get them all on the same domain. Any Suggestions are appreciated. (1 Reply)
Discussion started by: Deuce
1 Replies

Featured Tech Videos