Visit Our UNIX and Linux User Community


PPPoE + ADSL on FreeBSD 4.4


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers PPPoE + ADSL on FreeBSD 4.4
# 1  
Old 03-07-2002
PPPoE + ADSL on FreeBSD 4.4

Hi everyone,

This is basically my problem. I setup freebsd, and wanted to get my adsl connection up which uses pppoe to connect. I followed the steps in this (http://free.mine.nu/~squirrel/PPPoE/...oE%20Howto.htm) manual and configured everything successfully. The problem begins when i run the command "ppp -bacgkround pppoe"

I get the following error:

Warning: Bad label in /etc/ppp/ppp.conf (line 5) - missing colon
Warning: Bad label in /etc/ppp/ppp.conf (line 6) - missing colon
Warning: Bad label in /etc/ppp/ppp.conf (line 7) - missing colon
Warning: Bad label in /etc/ppp/ppp.conf (line 8) - missing colon

From looking at the Handbook, and the manu above, I did not notice anywhere that says i should put a colon. For the heck of it I did putit in and the same problem appear. I've tried to get my connect up for a month now with no luck. PLEAse someone help.

Smilie
# 2  
Old 03-07-2002
You may try to find your answer in here
http://logicsquad.net/freebsd/PPPoE-how-to.html

It described and teaches the adsl connection step by step. Perhaps this URL works.
# 3  
Old 03-07-2002
Thanks for the link, but i still keep getting the colon missing error.
# 4  
Old 03-07-2002
as a root have you tried adsl -start, The adsl need to be started frst before you run the pppd. if you did state what is your pppd version pppd --version

Another URL that might get handy on this situation
http://mirror.kr.freebsd.org/handbook/pppoe.html
# 5  
Old 03-07-2002
I decided to use the freebsd default file, just change few lines such as:

set device PPPoE:dc0Smilieapchap

And in /etc/rc.conf i set the mode to background.

So now when i run ppp -background papchap

I get this error now

tun3: Error: chat_write: Network unreachable
tun3: Warning: Caht script failed

Also what is this "add default HISADDR"

is HISADDR should be some kind of IP?
# 6  
Old 03-08-2002
modify four lines in the file /etc/ppp/ppp.conf.

You will find the following lines at the end of /etc/ppp/ppp.conf:

papchap:

#
# edit the next three lines and replace the items in caps with
# the values which have been assigned by your ISP:
#

set phone PHONE_NUM
set authname USERNAME
set authkey PASSWORD

Assuming your ISP name is MYISP, your phone # is 123-1212, your username is USER and your password is PASS, you would do the following:

MYISP:

set phone 555-1212
set authname USER
set authkey PASS

Save your changes and from the command line do this:

# ppp -auto MYISP

Now ping an IP or access your network. Your modem should dial your ISP and connect. That's all there is to it.

Note that this assumes your modem is on com1. If not, tweak the beginning of your ppp.conf file under the default: section.
# 7  
Old 03-08-2002
killerserv, please reread the thread. The user is connecting via ADSL, not dialup.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #749
Difficulty: Medium
The ZX81 had a base configuration of 1 KB of on-board memory that could officially be expanded externally to 64 KB.
True or False?

9 More Discussions You Might Find Interesting

1. IP Networking

authentication of VM's via PPPoE

I have two VM's running on Ubuntu box.Their name and IP addresses are give below. nas 192.168.129.153 home_user 192.168.129.152 I establish a ppp connection between the two machines #nas (server) sudo pppd noauth local lock defaultroute... (0 Replies)
Discussion started by: karthik.sharma
0 Replies

2. Shell Programming and Scripting

Using Net::Telnet in Perl to connect to an adsl modem

Hello, First of all, congratulations on this forum! Very mice material! This is my fist thread and it has to do with connecting to an adsl modem and executing some commands. Heres what I do: $username = 'admin'; $passwd = 'admin'; $telnet = new Net::Telnet ( Timeout=>10,... (2 Replies)
Discussion started by: Ravendark
2 Replies

3. IP Networking

Sharing Adsl Link

Hi guyz, got a little bit of a situation here. we are sharing an ADSL link with another organization. so there are 2 networks. network 1: has the adsl router and the whole n/w is on subnet 192.168.0.* the adsl router has its ip as 192.168.0.1 network 2(now us): we have set up a linux... (0 Replies)
Discussion started by: royashoya
0 Replies

4. Solaris

Installing USB adsl modem?

Hello all, granted that I am an absolute beginner with Solaris, I'd like to use my adsl modem, t's a Zyxel prestige 630. I managed to install and configure it under Ubuntu using the drivers from Conexant AccessRunner ADSL USB modems with Linux ; is there a chance to do the same under Solaris 10... (0 Replies)
Discussion started by: clalfa
0 Replies

5. Solaris

Solaris 10 ADSL USB modem problem

Hi, I have USB Siemens Santis 100 ADSL modem.I need driver for this modem on Solaris 10.Please help me with some info.Platform is x86.Thanks. (2 Replies)
Discussion started by: Upravnik
2 Replies

6. SCO

pppoe

Greetings... I'm looking for a pppoe client for SCO SYS_V can u guys gimme some help ? a website address or even the program name would be just fine. Thanx (1 Reply)
Discussion started by: nEuRoMaNcEr
1 Replies

7. UNIX for Dummies Questions & Answers

Four PCs Sharing ADSL

Hello, everyone. I have a little favor to ask. Me and my friends decided sharing an ADSL line with four PCs. PC no.1: Desktop, two netcard (2000 and 8139), Mandrake 9.0 PC no.2: Acer notebook, PC Card, RTL-8139C/8139C+, MS 98 + Win 2000 Pro PC no.3: Desktop, net card 8139, WindowME + Win 2000... (1 Reply)
Discussion started by: HOUSCOUS
1 Replies

8. UNIX for Dummies Questions & Answers

ADSL with Darwin 1.41

Hey everyone, just to let you all know "I'm an uber n00b" I'm connected to Telstra Bigpond's (Australian ISP) ADSL network, now I;m running Darwin 1.41 on an Apple Macintosh PPC computer. I don't know how to set up ADSL on this system, can someone please guide me. (3 Replies)
Discussion started by: Syphor
3 Replies

9. IP Networking

Unix and ADSL

Is ADSL support available for Unix/Linux? If I want to set up a internet server, will it have to be Windows with a seperate unix box? Or can it be a clean unix server? (2 Replies)
Discussion started by: vannie
2 Replies

Featured Tech Videos