apache, php on solaris


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers apache, php on solaris
# 1  
Question

Hi, our spark 5, os 2.8, solaris 8, came with Apache. But this Apache is some kind of bastardized wrapper that has no configuration files, nothing. So, I got the real version of Apache that is configurable. That is so I can configure it with PHP-4. I installed this new Apache version but now I am facing dilemma: where the hell is the right config file?
The instillation installed several same files all over and now I am not sure which one I should modify to have the PHP working correctly(!?). Are all of them used by the server? Anybody any suggestions? What is the base directory, but then to get to PHP I would have to redirect(?), any suggestions on that one as well?
Thank you, George
# 2  
CPU & Memory http://forums.unix.com/showthread.php?threadid=376

The thread below discusses many of the issues you raise in detail:

http://forums.unix.com/showthread.php?threadid=376
# 3  
Question

Neo, I already installed Apache and PHP. There are directions on the PHP site. The issue is that there are several configurations files and the one that configures the server tells me that the Order word is mis-spelled or defined by a module not included in the server configuration. So, I cannot start the server. It is the httpd.conf file in apache_1.x/bindist/bin dir.
Thanks, George
# 4  
I believe that Apache uses /usr/local/apache
as its base directory by default.
# 5  
Question

You right, all is right there. Just I need to manage all these scripts. Thank you guys. Now I need to connect to PHP, not very successful so far even I did the steps to load PHP during loading Apache at sturt-up.
Thanks, George
# 6  
If you build apache+php correctly, included setting up the MIME types, etc. then you are 'connected' to php anytime you access (the web site) with a file with a .php extension or a file with an embedded php directive. I used this book to set up this apache+php site:

<A HREF=http://www1.fatbrain.com/asp/BookInfo/BookInfo.asp?theisbn=1861002963&from=HAN515>Professional PHP Programming</A>

Most of the information can be gleaned from the apache and php readme files (so if you are on a tight budget, don't feel compelled to purchase); however, this book saved me a lot of time going through the readmes (especially the chapter devoted to apache installation). Also, there is all the good php reference information if you decide to cut some php code. After you get set up, go to this link and pull down some good php packages for your server:

http://www.hotscripts.com/PHP/

The PHP book recommended is not required (the information is in the php and apache readme files), but it made my life much easier when I switched over to a PHP-core. The MySQL part is also helpful, and you will naturally need to set up MySQL, since the 'triple threat' is apache+php+mysql Smilie

[Edited by Neo on 03-06-2001 at 12:28 AM]
# 7  
Data save instead run

Well, when I run the PHP on my machine at home ir works fine under Windows. When I run it on Solaris it prompts me where do I want to save the *.php file(!?). I want to run the file instead.
Thanks,George
Note: I do have the book
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #225
Difficulty: Easy
In September 2019, according to NetMarketShare, Google commanded over 90% market share for desktop search engines.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Solaris install php as an apache module

Hi, I need to install php 5.5.30 as an apache (2.4.17) module on Solaris 10. Please any help is wellcome. Some aditional info: /usr/sfw/bin/gcc -v Reading specs from /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/specs bash-3.2# g++ -v Reading specs from... (1 Reply)
Discussion started by: lbslbs
1 Replies

2. Solaris

Compile PHP as an Apache module on Solaris

Hi, I need to install php 5.5.30 as an apache (2.4.17) module on Solaris 10. Please any help is wellcome. Some aditional info: /usr/sfw/bin/gcc -v Reading specs from /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/specs bash-3.2# g++ -v Reading specs from... (0 Replies)
Discussion started by: lbslbs
0 Replies

3. Solaris

Install apache 2.2.22 on Solaris 10

Hi all, This is Solaris 10 OS I received this error on Server, -bash-3.00$ /usr/local/apache2/bin/httpd -v ld.so.1: httpd: fatal: libaprutil-1.so.0: open failed: No such file or directory Killed -bash-3.00$ How to resolve this dependencies which are not resolved? ... (0 Replies)
Discussion started by: manalisharmabe
0 Replies

4. Solaris

apache 2.2.22 Solaris errors

Hi, I have installed apache 2.2.22 on solaris machine and trying to do some basic testing, but it is failing for one of the scenario. Seeing below in the error logs But noy sure why there is a need for AuthUserFile when i mentioned AuthldapURL. Please advise Thanks (1 Reply)
Discussion started by: prash358
1 Replies

5. Solaris

Installtion of apache 2.2.22 on solaris 10

I am trying to install apache 2.2.22 on Solaris 10 but getting below error message when starting apache: /etc/init.d/apache2 start Server type is set to running /opt/apache/conf/startup.pl for groups shared mem Starting Apache HTTPD service with SSL disabled httpd: Syntax error on line... (2 Replies)
Discussion started by: prash358
2 Replies

6. Solaris

Apache 2.2.21 installation on solaris 10

Hi , I am new to the unix environment. I need to install apache 2.2.21 on my machine. I have tried configuring apache from /etc/apache2 directory. But now I want to install it under a separate user. Can anybody tell me the step by step procedure to install it under separate user,please ?... (1 Reply)
Discussion started by: bikas89
1 Replies

7. Solaris

Upgrade Apache to new version? Solaris 10, goal:PHP

Hello, I have been searching on unix.com and google in general. I can't find what I am looking for. Maybe too dumb of a question. I've downloaded and installed the sunfreeware package for PHP 5.3.6 and made sure all dependencies are satisfied. Apache 2.2.8 is currently installed and... (2 Replies)
Discussion started by: CSLibrary
2 Replies

8. Solaris

apache insttalation on solaris 10

ii am trying to install apache 2 on solaris 10.it is configured successfully but is giving error while make.i have pasted last lines of that error. make: Warning: Can't find `/build/ltlib.mk': No such file or directory Current working directory /apache/httpd-2.0.59/srclib/pcre make: Fatal... (1 Reply)
Discussion started by: raynu.sharma
1 Replies

9. UNIX for Dummies Questions & Answers

apache on solaris 9

HI I want to use the apache server on my solaris 9 How do I start it?? (/etc/init.d/apache start does not work) Where do I need to put my html archives??? thanks (2 Replies)
Discussion started by: eldiego
2 Replies

10. UNIX for Dummies Questions & Answers

starting Apache on Solaris 8

I am not by any means a UNIX guru if you can't already tell by the question I'm about to ask. How do I launch Apache web server on my SOlaris 8 server without rebooting it? Any help would be much appreciated!!! -Thanks (5 Replies)
Discussion started by: jskillet
5 Replies

Featured Tech Videos