Visit Our UNIX and Linux User Community


linux newbie question...


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers linux newbie question...
# 1  
Old 02-07-2002
linux newbie question...

I'm running Vector Linux on this computer, and everythign works fine, except for the NIC. I run netconfig, and then when I reboot it says:



DC21140 at 0x9400(PCI BUS 0, device 11) h/w address 00:00:C0:2E:13:dC, and reqquires IRQ 9(provided by PCI BIOS)

Setting up net subsytems.

Attempting to configure eth0 by contacting DHCP server.

eth0: media is unconnected, link down, or incompatible connection.


I know the media is connected, because I'm using it right now. I checked, and it is using IRQ 9 so my troubleshooting skills ended right thereSmilie Please help me get it to work, and thanks in advance.
# 2  
Old 02-08-2002

you wrote:
eth0: media is unconnected, link down, or incompatible connection.

I know the media is connected, because I'm using it right now


- So how did you come to fix it? Is this just a normal error message that doesn't matter (ie. in Solaris when the SUN Disk Manager starts, I always get three errors - they don't matter because I don't use that portion of the software). In your case, it may be that something is trying to use eth0 before it is configured, gives the error, and then another startup script configures it and everything works. Take a look at the startup scripts to see if something is out of order (what I don't know since I don't have a Vector Linux system to look at). HTH!
thehoghunter
# 3  
Old 02-08-2002
Oh, sorry, I mean I'm using it under Windows... I can't get it to work at all under Linux.
# 4  
Old 02-09-2002
What type of NIC is it? Vendor, model #, and esp. a chipset name would be very helpful. Luckily it's PCI, so it's probably supported! We need more information to really help out.
# 5  
Old 02-09-2002
It's uses the Intel DC21140, tulip chipset... I'm not sure who makes the card though. But just now, when I went into device manager in win2k, it says that it's on IRQ 11, but when I boot(and in the BIOS) it says it's on 9.
# 6  
Old 02-10-2002
Have you tried moving it to another slot? If your BIOS says it's on IRQ9, but windows says it's on IRQ11, then what it SOUNDS like is that Windows is reassigning the IRQ, via IRQ steering, probably because of a conflict with another device. Do you have anything else listed as being on 11, or 9? Also, I assume you are connecting to the same switch/hub/RJ45 jack during both the Win2K boot and the Linux boot?
When you compiled your kernel, did you get any error messages?
If your machine is recognizing 'eth0' as even being there, it sounds like the driver was installed, and the card is being 'picked up' by LInux. You might want to do a 'dmesg' or 'cat /var/log/messages' and see if you can see anything about your NIC in there.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #956
Difficulty: Medium
A polymorphic virus infects files with an encrypted copy of itself which is decoded by a decryption module which is modified on each infection.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

newbie question

Hi all, I am sure this is very simple but I cant quite get it. I am trying to search textfile1.txt for a string then take the results of the search and append the result to textfile3.txt So far I have used $ find file1.txt -exec grep "string i am looking for" '{}' \; -print this... (2 Replies)
Discussion started by: radgator
2 Replies

2. UNIX for Dummies Questions & Answers

Newbie question

Hey. i am doing a lab work for shcool I am new to using the commands. This question is give to me. I do not no the length of file nor do i know the how many charterers they are in the question. Question below "Assume that you are NOT currently in your home directory. Enter a command to copy... (1 Reply)
Discussion started by: maniac173
1 Replies

3. Shell Programming and Scripting

perl newbie . &&..programming newbie (question 2)

Hello everyone, I am having to do a lot of perl scripting these days and I am learning a lot. I have this problem I want to move files from a folder and all its sub folders to one parent folder, they are all .gz files.. there is folder1\folder2\*.gz and there are about 50 folders... (1 Reply)
Discussion started by: xytiz
1 Replies

4. UNIX for Dummies Questions & Answers

UNIX newbie NEWBIE question!

Hello everyone, Just started UNIX today! In our school we use solaris. I just want to know how do I setup Solaris 10 not the GUI one, the one where you have to type the commands like ECHO, ls, pwd, etc... I have windows xp and I also have vmware. I hope I am not missing anything! :p (4 Replies)
Discussion started by: Hanamachi
4 Replies

5. UNIX for Dummies Questions & Answers

Newbie question?

What is the best way to learn UNIX on the web, with out buying books? any link would be much help. Thank you in advance, L (1 Reply)
Discussion started by: lsoria1
1 Replies

6. UNIX for Dummies Questions & Answers

newbie question

I am taking a db classes toward oracle 10g. I am taking unix as well . I need to know what is the best option for os . should I use linux fedora. or get a sun box and start learning from there. Thanks (6 Replies)
Discussion started by: xzyan
6 Replies

7. Shell Programming and Scripting

Newbie question

Hello, I have text file while looks this test1 test2 test3 test4 test5 test6 and if I want to parse it and make new file which would like this test1 test2 test3 test4 test5 test6 How can I do this in korn shell script Thanks (9 Replies)
Discussion started by: peeyush_23
9 Replies

8. UNIX for Dummies Questions & Answers

Newbie Question

Hi, I have a file, that is delimited by :: and the purpose of this file is none of your business. ;) There are about 65000 lines in this file, and there are lines that I would like to remove. About 45000 of them. Is there some sort of commands that I can run, to remove word(s) from this... (4 Replies)
Discussion started by: th3gh05t
4 Replies

9. Programming

Unix/Linux Newbie(ish) Question - IPC/Signals

:) Hello, i have been given the following code to help me learn how to use signals, it won't compile. The problem maybe because this was written for use in Unix and i am trying to compile in Linux. The error i get says that SIGPIPE and SIG_IGN are undeclared. I think that these are defined... (2 Replies)
Discussion started by: theultimatechuf
2 Replies

10. UNIX for Dummies Questions & Answers

newbie question

hi im thinking of getting unix but i have no idea where to start I know that its an OS similar to linux but what hardware does in run on? i've heard of solaris but im not quit sure what it is thankxs (3 Replies)
Discussion started by: ninja
3 Replies

Featured Tech Videos