Visit Our UNIX and Linux User Community


mkdev tape problem


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers mkdev tape problem
# 1  
Old 09-25-2007
mkdev tape problem

SCO 5.0.5

Our system hiccuped last week during mkdev tape command.
Actually was at the point where it generated a kernel to reflect the new scsi tape I was trying to add and the system appeared to hang and we aborted the process.

starting fresh no tape devices defined.
run mkdev tape define 1 scsi tape device
regen the kernel and reboot
and 3 tape devices appear (0,1,2).
Can not delete device 1 or 2 but deleting device 0 deletes all 3.

Must be value stuck somewhere in the system anyone know where to look or how to fix this ? THANK YOU
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #726
Difficulty: Medium
Satoshi Yamashita is a pseudonym for the anonymous creator or creators of Bitcoin.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

AIX: mkdev is waiting in kernel at et_wait

Hi All, bash-3.2# ps -eaf | grep mkdev root 4378752 1548526 0 03:27:04 - 0:00 /usr/sbin/mkdev -c disk -s vscsi -t xyz -l virtualdev bash-3.2# Here we are trying to create a virtual device using mkdev and the device is already populated in the namespace and the corresponding ODMs... (1 Reply)
Discussion started by: Muppana Prasad
1 Replies

2. AIX

AIX 4.2.1 Tape Drive Problem

Hi, The problem I have is I want to restore my AIX machine. I have created a mksysb tape from my tape drive rmt0 and I changed the bootlist using this command "bootlist -m normal rmt0 hdisk0". However, when I display the bootlist "bootlist -om normal", it shows '-' hdisk0. I googled and... (2 Replies)
Discussion started by: AixNoob87
2 Replies

3. Shell Programming and Scripting

Restoring problem on tape!

hi all , a messages appeared to me when i was checking my /var/adm/messages and the below code was in it Oct 6 13:15:21 medprod scsi: /pci@3,700000/SUNW,emlxs@0/fp@0,0/st@w21000024ff305234,7 (st1): Oct 6 13:15:21 medprod Restoring tape position at fileno=320,... (5 Replies)
Discussion started by: semaan
5 Replies

4. AIX

Tape Drive problem

Hi, I'm at AIX 5.3. My EOD program is giving following error while writing to tape: Can't write output cpio: Media Surface error Failed on Shell-script cd /; cpio -ocB 2 >> /autoline/misc/logs/bk.CopyToTape < /autoline/work/BACKUP.01022 1>/dev/rm0 I have tried with several new tapes,... (2 Replies)
Discussion started by: tayyabq8
2 Replies

5. UNIX for Dummies Questions & Answers

Dynix/ptx equivalents of lsdev, mkdev etc.

I am familiar with the AIX commands lsdev, mkdev, rmdev and so on. Have been asked to look at a very old Sequent Quad box running Dynix/ptx - believed to be version 2.4.1 ! These commands don't appear to be present. Can anyone please identify the equivalent Dynix commands? I've been handed the... (0 Replies)
Discussion started by: itboss
0 Replies

6. AIX

Tape Drive Problem.

Dear all, I have ultriam3 tape. It is connected my LPAR. I have that the Sl.Nos. and slot number. but run the cfmgr i am not getting the tape drive. I have fired the command lsdev -Cc tape but no reply. how will i configure the tape in LPAR? Please suggest. It is very urgent. (3 Replies)
Discussion started by: pernasivam
3 Replies

7. SCO

Tape drive problem

I replaced a HP Superstore Dat 40 with another HP Superstore Dat 40, but my backupedge software keeps putting up error code 1 (device not found) I have tried reinstaling the drive as DAT Alad stp 0 6 0 0. I'm not a computer expert but willing to have a go. I went into Backupedge to try and format a... (2 Replies)
Discussion started by: James Zwecker
2 Replies

8. UNIX for Advanced & Expert Users

Problem With Tape Backup in Solaris

Hi, OS: Solaris9, SPARC. Commands (and their outputs) that I use to backup two files of size 4GB and 10GB (respectively) are shown below: # cd /backup/daily/ # mt -f /dev/rmt/0m rew # tar -cvf /dev/rmt/0m * a Mails.bkf 4680454 tape blocks a backup.bkf too large to archive # The... (3 Replies)
Discussion started by: mahatma
3 Replies

9. AIX

Tape problem !!!!!!!!

HI !! I have problem with my tape LTO 3 on Aix o/S Into tape i have tar files the first one is /casa/immobili , the second one is /casa/giardini by shell i put command : 1) tar -xvf /dev/rmt0 2) mt -f /dev/rmt0 rewind 3) mt -f /dev/rmt0 fsf 1 4) tar -xvf /dev/rmt0 the problem is that i... (1 Reply)
Discussion started by: tt155
1 Replies

10. UNIX for Dummies Questions & Answers

Tape Backup Problem?

Hi. Can someone please tell what the following tape error message means: Read end of medium on output If you want to go on, type device/file name when ready This message comes after the terminal displays a few files from the directory I'm trying to backup. The command I'm running is: ... (1 Reply)
Discussion started by: cstovall
1 Replies
TCOPY(1)						    BSD General Commands Manual 						  TCOPY(1)

NAME
tcopy -- copy and/or verify mag tapes SYNOPSIS
tcopy [-cvx] [-s maxblk] [src [dest]] DESCRIPTION
The tcopy utility is designed to copy magnetic tapes. The only assumption made about the tape layout is that there are two sequential EOF marks at the end. By default, the tcopy utility will print information about the sizes of records and files found on the /dev/sa0 tape, or on the tape specified by the src argument. If a destination tape is also specified by the dest argument, a copy of the source tape will be made. The blocking on the destination tape will be identical to that used on the source tape. Copying a tape will yield the same program output as if just printing the sizes. The following options are available: -c Copy src to dest and then verify that the two tapes are identical. -s maxblk Specify a maximum block size, maxblk. -v Given the two tapes src and dest, verify that they are identical. -x Output all informational messages to the standard error instead of the standard output. This option is useful when dest is given as /dev/stdout. SEE ALSO
mt(1), mtio(4) HISTORY
The tcopy command appeared in 4.3BSD. BUGS
Writing an image of a tape to a file does not preserve much more than the raw data. Block size(s) and tape EOF marks are lost which would otherwise be preserved in a tape-to-tape copy. End of data (EOD) is determined by two sequential EOF marks with no data between them. There used to be old systems which typically wrote three EOF's between tape files. The tcopy utility will erroneously stop copying early in this case. When using the copy/verify option -c, tcopy does not rewind the tapes prior to start. A rewind is performed after writing, prior to the ver- ification stage. If one does not start at the beginning-of-tape (BOT) then the comparison may not be of the intended data. BSD
December 20, 2006 BSD

Featured Tech Videos