Can't find/see directory!


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Can't find/see directory!
# 1  
Question

I am very new to Unix and am using SunOS 5.7. I have created a new Unix account named "oracle" using the useradd utility, and placed it in the /users directory.

I am able to log in as "oracle", but now I can't see anything in the users directory! I used the
ls | ws -l
command to count the number of files in the users directory and it outputted 0.

I don't understand how I can log in with this Unix account and not be able to find the folder.

I also tried this using the Root account and the same problem occurs. There are other accounts in the users directory and I can finger them, but I can't find the folders.

Actually, I am looking for the "oracle" .profile file and it's not shown when I
ls -la
so I figured it might have something to do with the problem above.

PLEASE HELP!! THANKS!

# 2  
If you type ls -la in a directory and nothing shows up then there is nothing in the directory. What do you see when you type pwd? Try copying the .profile from another users home directory into oracles home.
If the other username is chuckb, type this;
cp ~chuckb/.profile ~oracle

# 3  
Right. The <b>ls</B> command will not show dot files (i.e. your .profile file) so when you do an <B>ls | wc -l</B> you will not count the dot files. As 98 points out, you must do an <B>ls -a | wc -l</B> to count dot files too.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #368
Difficulty: Medium
The Open Group released the Single UNIX Specification Version 2 in 1987.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

What are the differences between 'bash' and 'sh'

Hopefully this doesn't come off as too much of a "newbie" question or a flamebait. But I have recently begun working with a Sun Solaris box after having spent the past five years working with RedHat. From what i can tell, thing look fairly similar and the 'man' command is some help. But I've... (7 Replies)
Discussion started by: deckard
7 Replies

2. UNIX for Advanced & Expert Users

How to remove a file with a leading dash '-' in it's name?

Somehow someone created a file named '-ov' in the root directory. Given the name, the how was probably the result of some cpio command they bozo'ed. I've tried a number of different ways to get rid of it using * and ? wildcards, '\' escape patterns etc.. They all fail with " illegal option --... (3 Replies)
Discussion started by: GSalisbury
3 Replies

3. UNIX for Advanced & Expert Users

memory free up using 'find'

Hi, I am facing an interesting aspect of find command... to be clear, we are running a small web server with oracle 8i database and Oralce9iAS on Sun E250 with Solaris 2.6 Over a period of time, the free memory ( displayed in 'top' utility ) drops down.. we could relate this to dedicated... (6 Replies)
Discussion started by: shibz
6 Replies

4. UNIX for Dummies Questions & Answers

quoting echo 'it's friday'

echo 'it's friday' why appear the > (3 Replies)
Discussion started by: yls177
3 Replies

5. UNIX for Dummies Questions & Answers

How do I find out what version of X I'm using?

How can I find out? Besides looking on the box of my distro and checking their. (2 Replies)
Discussion started by: DISTURBED
2 Replies

6. Shell Programming and Scripting

Clearify what it means under 'WHAT' when hit the 'w'-command

I wonder how I shall read the result below, especially 'what' shown below. The result was shown when I entered 'w'. E.g what is TOP? What is gosh ( what does selmgr mean?)? login@ idle JCPU PCPU what 6:15am 7:04 39 39 TOP 6:34am 6:45 45 45 TOP 6:41am ... (1 Reply)
Discussion started by: Aelgen
1 Replies

7. UNIX for Dummies Questions & Answers

'find' command question

my solaris text talks about the 'find' command... it further goes to talk about an "action" used with the find command. I am completely confused as to what the {} do with the find comand. the explanation is this: "A set of braces, {}, delimits where the file name is passed to the command from... (2 Replies)
Discussion started by: xyyz
2 Replies

8. UNIX for Dummies Questions & Answers

can't find gunzip

I installed Solaris 2.6 on a Sparc20... I was trying to uncompress the mozilla source... but it says "gunzip: not found" so... I thought i'd try tar -zxvf... which also won't work. I found gzip on www.sunfreeware.com... but I don't know how to install it... I'm assuming I have to use the... (3 Replies)
Discussion started by: xyyz
3 Replies

9. UNIX for Dummies Questions & Answers

How do I change ownership of a directory and all of it's files.

How do I change ownership of a directory and all of it's files without changing permissions? (1 Reply)
Discussion started by: mborin
1 Replies

10. UNIX for Dummies Questions & Answers

importance of '/dev' directory

Can any one tell me what is the importance of '/dev' directory in unix. Is there any possibility to get 'root' by using the files stored in this directory. Beleive me this is not for any hacking purpose. just for learning. Hopes a detail reply. thak you (1 Reply)
Discussion started by: madhu
1 Replies

Featured Tech Videos