Visit Our UNIX and Linux User Community


can't find gunzip


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers can't find gunzip
# 1  
Old 09-28-2001
can't find gunzip

I installed Solaris 2.6 on a Sparc20... I was trying to uncompress the mozilla source... but it says "gunzip: not found"

so... I thought i'd try tar -zxvf... which also won't work.

I found gzip on www.sunfreeware.com... but I don't know how to install it...

I'm assuming I have to use the pkg-add or something... but it says this command also doesn't exist... :/

Any help with this one?
# 2  
Old 09-28-2001
hi,

its normally under /usr/local/bin or /usr/bin
check if its there, else copy from some other solaris machine, it should work fine.

Thanks
# 3  
Old 09-28-2001
Did you downloaded a source bundle or a binary (SUN pkg)
version?

If source, this would of course require a C compiler,
you can usually do (as root)...

./configure
make all
make install
make clean

...this would normall install it in /usr/local/bin

If binary (SUN pkg), then you would probably use pkg-add.
If pkg-add is not found, try running...

find / -name pkg-add -print

Assuming you get somthing like...

/usr/adm/bin/pkg-add

...then you could add the path to your $PATH
or just execute it by type the complete path name.
# 4  
Old 09-29-2001
thankyou thankyou thankyou for all your replies... but I did sort the problem out.

I downloaded gzip fom sunfreeware... and then I used pkgadd -d to install the package... and it fired right up...

Smilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #73
Difficulty: Easy
BSD (Berkeley Software Distribution) is an open-source, Unix-like operating system.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

What are the differences between 'bash' and 'sh'

Hopefully this doesn't come off as too much of a "newbie" question or a flamebait. But I have recently begun working with a Sun Solaris box after having spent the past five years working with RedHat. From what i can tell, thing look fairly similar and the 'man' command is some help. But I've... (7 Replies)
Discussion started by: deckard
7 Replies

2. UNIX for Advanced & Expert Users

How to remove a file with a leading dash '-' in it's name?

Somehow someone created a file named '-ov' in the root directory. Given the name, the how was probably the result of some cpio command they bozo'ed. I've tried a number of different ways to get rid of it using * and ? wildcards, '\' escape patterns etc.. They all fail with " illegal option --... (3 Replies)
Discussion started by: GSalisbury
3 Replies

3. UNIX for Advanced & Expert Users

memory free up using 'find'

Hi, I am facing an interesting aspect of find command... to be clear, we are running a small web server with oracle 8i database and Oralce9iAS on Sun E250 with Solaris 2.6 Over a period of time, the free memory ( displayed in 'top' utility ) drops down.. we could relate this to dedicated... (6 Replies)
Discussion started by: shibz
6 Replies

4. UNIX for Dummies Questions & Answers

quoting echo 'it's friday'

echo 'it's friday' why appear the > (3 Replies)
Discussion started by: yls177
3 Replies

5. UNIX for Dummies Questions & Answers

How do I find out what version of X I'm using?

How can I find out? Besides looking on the box of my distro and checking their. (2 Replies)
Discussion started by: DISTURBED
2 Replies

6. Shell Programming and Scripting

Clearify what it means under 'WHAT' when hit the 'w'-command

I wonder how I shall read the result below, especially 'what' shown below. The result was shown when I entered 'w'. E.g what is TOP? What is gosh ( what does selmgr mean?)? login@ idle JCPU PCPU what 6:15am 7:04 39 39 TOP 6:34am 6:45 45 45 TOP 6:41am ... (1 Reply)
Discussion started by: Aelgen
1 Replies

7. UNIX for Dummies Questions & Answers

'find' command question

my solaris text talks about the 'find' command... it further goes to talk about an "action" used with the find command. I am completely confused as to what the {} do with the find comand. the explanation is this: "A set of braces, {}, delimits where the file name is passed to the command from... (2 Replies)
Discussion started by: xyyz
2 Replies

8. Programming

i can't use 'make' in my computer?

I need to compile a file,but 'make' does not work.please tell me how to use it or need which tools? (3 Replies)
Discussion started by: dsun5
3 Replies

9. Programming

Can't find curses library

I am writing a c program with the use of the curses but when i tried compiling i get the error that the curses library is not found the header file i included is curses.h and th command i typed is gcc -o chat chat.c -lcurses 1) Is this correct in linux? 2) found a file libncurses.so.5.2 ... (1 Reply)
Discussion started by: xenon830
1 Replies

10. UNIX for Dummies Questions & Answers

Can't find/see directory!

I am very new to Unix and am using SunOS 5.7. I have created a new Unix account named "oracle" using the useradd utility, and placed it in the /users directory. I am able to log in as "oracle", but now I can't see anything in the users directory! I used the ls | ws -l command to count the... (2 Replies)
Discussion started by: Val
2 Replies

Featured Tech Videos