Visit Our UNIX and Linux User Community


A problem regarding compiling C prog. in lynux ...


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers A problem regarding compiling C prog. in lynux ...
# 1  
Old 08-30-2001
Network A problem regarding compiling C prog. in lynux ...

Hi mates,
I am using Mandrake 7.1. I am trying to compile my file let is say Firstc.c file. It compiles it without any problem and creates the a.out file too. But when i am trying to execute the a.out file it brings the error: "bash: a.out: command not found!" ...
i don't know what is the problem?

regards abdul;Smilie
# 2  
Old 08-30-2001
your current directory is not in your path.

if you type echo $PATH you will notice it does not contain the location of a.out.

now if you were to type ./a.out your command would execute.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #856
Difficulty: Medium
React was created by Jordan Renke, a software engineer at Facebook.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Compiling problem - AIX 7.2

Hi We meet errors while running configuration scripts to prepare compiling source code on AIX 7.2. This error does not happen on AIX5.3 and AIX6.1 With the “/usr/bin/sh” from AIX7.2, sometimes , the script runs sucessfully, sometimes not. It’s unstable, and I don’t know why. When... (10 Replies)
Discussion started by: bobochacha29
10 Replies

2. Programming

Library problem - not compiling in c

Ok I was trying to test if I installed correctly gsl, I followed the INSTALL file and still I don't know what is wrong. Here is a sample code to test gel,I got it from Random Number Generator Examples - GNU Scientific Library -- Reference Manual (note: made a few changes in the code) #include... (2 Replies)
Discussion started by: joseamck
2 Replies

3. UNIX for Dummies Questions & Answers

Compiling samba problem

People i download the lastest version of samba i`am tryng to compile it in a solaris 9 i'm reading the how to of samba, i am in the first step making the autogen.sh but show me this when i do ./autogen.sh ./autogen.sh: running script/mkversion.sh ./script/mkversion.sh: 'include/version.h'... (0 Replies)
Discussion started by: enkei17
0 Replies

4. HP-UX

Problem in HP-UX compiling

Hi When im trying to do make --version and make --help in HP-UX it throws error Make: Unknown flag argument -. Stop. a soft link is present in this directory /usr/bin/make and hard link is in /usr/ccs/bin/make what could be the reason can any1 ..please tell me how to solve this... (1 Reply)
Discussion started by: vasanthan
1 Replies

5. Programming

Problem with Compiling C on Tiger

I've downloaded Xcode and i've done : which "gcc" which "ggc-4.0" and which "c99" all were found in /usr/bin/ however with the script #include <stdio.h> main() { printf("hello, world\n"); } and when I, in command line use the command while in my home dir: gcc cprog.c -o cprog (4 Replies)
Discussion started by: cleansing_flame
4 Replies

6. Solaris

Problem's compiling Glib

Hello, I am trying to install glib on my development box - with little/no luck. Below are some details of the box: SunOS 5.8 Generic_117350-38 sun4u sparc SUNW,Ultra-Enterprise gcc version 2.95.2 19991024 (release) GNU Make version 3.78.1, by Richard Stallman and Roland McGrath. Glib version:... (2 Replies)
Discussion started by: tetley
2 Replies

7. Solaris

Problem in PowerDNS compiling

PowerDNS is true Power of Internet Name Management. http://www.powerdns.com Now, I compile it on my SunOS system (SunOS 5.8 Generic_117350-05 sun4u sparc SUNW,Ultra-5_10). ./configure -- no error make --> it has error: <i> make: Fatal error: Command failed for target... (0 Replies)
Discussion started by: secret4all
0 Replies

8. Solaris

Compiling problem

I'm trying to install the jed text editor on a SunOS 5.10 box. It depends on the s-lang library, which I installed to ~/lib. I'm trying to install jed to ~/jed (it's a box @ my university, so I don't have rights to install globally), but when I run make I get this error: It looks like it... (1 Reply)
Discussion started by: iandunn
1 Replies

9. UNIX for Dummies Questions & Answers

dos files in lynux

Hi.. I have a batch file in lynux where i have a copy command written..then i copied this batch file and run on the ms dos machine..but when i run this batch file its coming bad command or file name..i opened this with notepad then some junk characters are seen..vat i shoud do to doscp this file... (5 Replies)
Discussion started by: newbuddy
5 Replies

10. Programming

Problem compiling metamail

Hi Guys. I have downloaded metamail from internet e Iīm trying to compile it at a SCO 5.0.5. In this server itīs working fine (letīs name it as mission1) iīm using the developer package in this server (mission1) and when I use mailto, i got the e-mail fine. Itīs forwarding to a exchange server... (2 Replies)
Discussion started by: ahnishimi
2 Replies

Featured Tech Videos