Visit Our UNIX and Linux User Community


Unable to use the CDE Facility


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Unable to use the CDE Facility
# 1  
Old 10-08-2009
Unable to use the CDE Facility

Hello

I have a SunBlade 1000 workstation and I cannot login via CDE. All I get is a console login prompt. I then have to login via root and I just get the command line interface.

I have being doing some research on the UNIX forum and the problem may lie with the content in etc/hosts file. Originally the hostname was set to "unknown" so I changed it to "tim1". Anyway, here is the content of my /etc/hosts file:

Code:
#
#Internet host table
#
127.0.0.1           croydon1 
192.168.1.1.101  tim1      #Added by DHCP

______________________________
Does this look right? "croydon1" is the domain name. Sorry if this is a bit vague but everything was working perfectly up to today.

---------- Post updated 10-08-09 at 06:22 AM ---------- Previous update was 10-07-09 at 09:37 AM ----------

Anybody out there!

Last edited by Yogesh Sawant; 10-08-2009 at 06:51 AM.. Reason: added code tags
# 2  
Old 10-08-2009
Is this is an IP address ?! Smilie

Code:
192.168.1.1.101

# 3  
Old 10-09-2009
Unable to login to theCDE

Hi Thanks for yourreply

When I do cat /etc/hosts, here is the output:

#
#Internet host table
#
127.0.0.1 croydon1
192.168.1.102 tim1 #Added by DHCP

My machine's ip address has changed from 192.168.1.1.101 (the one
you were asking about) to 192.168.1.102. Should this have happened?
I didn't change anything in /etc/hosts. I'm confused.

---------- Post updated 10-09-09 at 04:16 AM ---------- Previous update was 10-08-09 at 11:33 AM ----------

I have issued the following command:
/usr/dt/bin/dtconfig -e

I then rebooted my machine but still got the console login and not the CDE one. I'm really scratching my head on this one.
# 4  
Old 10-11-2009
The 127.0.0.1 should always be set to localhost if you wish to add other aliases to it that is up to you but it is not advisable to remove localhost from it.

Thegeek had a point in that the original IP address quoted had too many octets in it!

CDE will not start unless:
1. You have a graphics card installed (or built into the motherboard).
2. You have a mouse plugged in.

If those have not been fulfilled.

Then check the contents of /var/dt/Xerrors for any clues.

If there is nothing in there what is the default run level set to in /etc/inittab?

Last edited by TonyFullerMalv; 10-12-2009 at 10:15 PM.. Reason: Correcting poor typing
# 5  
Old 10-11-2009
have you considered a clean new install of solaris? a new version (update 8 of solaris 10) is just out...
# 6  
Old 10-13-2009
No CDE

Thankyou all for your feedback. I have managed to resolve the issue by running the "sys-unconfig" command and re-configuring my network settings so that they run via DHCP. I can now log in via CDE.

I don't know what really was the source of the problem but it has now been rectified.

Once again, thanks for your support.
# 7  
Old 12-05-2009
Downloading Solaris 10 10/09 Sparc On Sunblade 1000

Hello,

Pardon my ignorance but I am having trouble opening a new post which is why I'm using this thread to seek advice on another problem I'm experiencing.

I am trying to download the segmented files sol-10-u8-ga-sparc-dvd-iso-a.zip and sol-10-u8-ga-sparc-dvd-iso-b.zip to my /export/home directory but I seem to be running out of disk space.

From the Sun Download Manager window I get the following message:
Paused due to Disk Full or IO Write Error:No space left on device.

Please looked at the following output:

Code:
bash-3.00# cd /export 
bash-3.00# ls
home                                  sol-10-u8-ga-sparc-dvd-iso-b.zip
sol-10-u8-ga-sparc-dvd-iso-a.zip      sol-10-u8-ga-sparc-dvd-iso-b.zip.sdm

When I issued the df -h command I got the following output

Code:
bash-3.00# df -h
Filesystem             size   used  avail capacity  Mounted on
/dev/dsk/c1t1d0s0      4.5G   4.4G    42M   100%    /
/devices                 0K     0K     0K     0%    /devices
ctfs                     0K     0K     0K     0%    /system/contract
proc                     0K     0K     0K     0%    /proc
mnttab                   0K     0K     0K     0%    /etc/mnttab
swap                   1.1G   968K   1.1G     1%    /etc/svc/volatile
objfs                    0K     0K     0K     0%    /system/object
fd                       0K     0K     0K     0%    /dev/fd
swap                   1.1G   400K   1.1G     1%    /tmp
swap                   1.1G    32K   1.1G     1%    /var/run
/dev/dsk/c1t1d0s7       62G    64M    62G     1%    /export/home

As you can see /dev/dsk/c1t1d0s7 is the file system that is mounted on /export/home and it is only using 1% of its capacity. I am puzzled as to why I'm getting the disk full message (Paused due to Disk Full or IO Write Error:No space left on device) on SDM.

I appreciate that I might be overlooking something pretty basic, so can anyone help.

Last edited by DukeNuke2; 12-05-2009 at 10:22 AM..
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #277
Difficulty: Easy
Solaris is a version of UNIX System V Release 4 (SVR4), jointly developed by Sun and AT&T, and was licensed by Sun from DEC to replace SunOS.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Assign Here Document Facility to a Variable

Hello All, I was wondering how I can assign a here document facility to a variable. I have tried the following: menu=$(<<MENU Option1 Option2 Option3 Option4 MENU ) ...but when I echo the $menu variable, the multiline list comes out in a single line such as: Option1 Option2 Option3... (14 Replies)
Discussion started by: techieg
14 Replies

2. Solaris

Connect to SunOS CDE from another CDE

I have two CDE desktop accounts on different server (called this CDE#1, CDE#2) on the same network. However, my current setup is connecting to the Solaris CDE#1,CDE#2 via Citrix. My plan is to connect to CD#1 and then somehow connect to CDE#2. How do I do this? I am just a regular user... (0 Replies)
Discussion started by: tthach830
0 Replies

3. Shell Programming and Scripting

Is there a 'fuzzy search' facility in Linux?

I have over 10m documents that I want to search through against a list of know keywords, however the documents were produced using a technique that isn't perfect in how the data was presented. Is there a fuzzy keyword search available in Linux or can anyone think of a way of doing it that isn't... (5 Replies)
Discussion started by: Bashingaway
5 Replies

4. UNIX Desktop Questions & Answers

How to migrate Solaris 10 CDE config to HP-UX CDE.

Hello, Do you guys by any chance know what is the best (if any ) way to move CDE configuration from a SOLARIS 10 machine to HP-UX? Just the config (actions, text files etc). Thanks in advance! (0 Replies)
Discussion started by: binary0x01
0 Replies

5. AIX

Normal User Unable to Login Through AIX CDE

When we as normal user try to login, the session startup terminates and we are presented with the login screen.The root user is able to login without any problem.I can log in to the Aix server as normal user through telnet & using xmanager but not directly through server terminal .The Aix version... (1 Reply)
Discussion started by: ranadeep
1 Replies

6. Solaris

Unable to get CDE on X86

Hi..., I installed sol 10 in X86 .after installed sol 1 of 1 cd its's asking sol 1of 2 cd.i installed that also.after rebooting the system i'm not getting the CDE.it's directly login console.before that message is "the X server can not be started on display :0".what's wrong in installation.and... (2 Replies)
Discussion started by: rjay.com
2 Replies

7. UNIX Desktop Questions & Answers

How to use mail facility in unix??

I'm a beginner in Unix. Please explain in short, how to send and receive mail in unix. The mail is already configured in the OS. Tell me the steps to send/receive mail in the command prompt. The platform is AIX 5.1. Thanks Karthik (1 Reply)
Discussion started by: fermisoft
1 Replies

8. UNIX for Advanced & Expert Users

PCC-F-NOERRFILE, unable to open error message file, facility PR2

I am trying to build a tuxedo server which in turn depends on several Pro*C programs. I am doing it on HP-UX system. It looks to me that the ORACLE_HOME is set properly. But I am getting error message when trying to build. PCC-F-NOERRFILE, unable to open error message file, facility PR2 exit... (1 Reply)
Discussion started by: asutoshch
1 Replies

9. OS X (Apple)

Unix email facility

Dear all, I am an inexperienced man with Macitosh and green in Apple OS X . I had tried very hard to use Unix, in fact the Terminal, with its Email function. I read some books and came to know that it has Mail, mailx or mail functions that we can use for simple mail. I have try every... (3 Replies)
Discussion started by: Larry LAM
3 Replies

10. UNIX for Dummies Questions & Answers

Using the LOG_AUTH facility

Hi, I am wanting to enable logging of all ftp sessions on my Solaris 8 host. I want to at least log all ftp logins and if possible any commands that the user executes. I have tried various settings in syslog.conf then rereading syslogd but logging still does not happen. I have... (1 Reply)
Discussion started by: blp001
1 Replies

Featured Tech Videos