Visit Our UNIX and Linux User Community


Problem with printing


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem with printing
# 1  
Old 07-07-2001
Question Problem with printing

Hi ,

Can somebody Please help me in finding out where I am going wrong.
Suppose i have a file called r_wer which contains files.
for ex :
LMN20001
LMN20002
LMN20003
Now I want to print them.

The way I am doing is
$ for a in `cat '/r_wer'`
> do
> lp -d printername $a
> done

But it is giving me an error message.
lp: can't access file "LMN20001"
lp: request not accepted. This is with all the files.
Can somebody Please help me.
# 2  
Old 07-08-2001
You Can Use CGI Script To Do This.



#!/usr/bin/perl

print "Content-type:text/html\n\n";

@files = ("LMN20001", "LMN20002", "LMN20003");

print "@files\n";


Smilie
cfir
# 3  
Old 07-08-2001
Alright what if I have around 1000 files then i think just
@files = ("LMN20001", "LMN20002", "LMN20003");
would not be a good idea.

Any other suggestions will be highly appreciated.

Thanks.
# 4  
Old 07-08-2001
Hi

Just check whether all the files that you are trying to print are in the current directory from where you are issuing this command . if not then give the full path names of the files in the file r_wer
I tried the same thing by making a script file and it worked fine.

for a in `cat './files.txt'`
do
lp $a
done

files.txt is the same as your r_wer.
That's it
Smilie

Last edited by kapilv; 07-08-2001 at 05:25 AM..
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #280
Difficulty: Easy
CPU modes (also called processor modes, CPU states, CPU privilege levels and other names) are operating modes for the central processing unit of some computer architectures that place restrictions on the type and scope of operations that can be performed by certain processes being run by the CPU.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Problem with printing

Hi, i am writing a script to generate a summary report for my data text file my data in my text file goes like this: MacOS:Mary Abraham:53.48:88:38 Windows in lala:Mary Abraham:22.30:23:22 lala in Windows:John Goodman:33.60:121:12 Hello world:Mr Tian:23.30:23:10 Windows in 31 days:John... (2 Replies)
Discussion started by: Cheranime
2 Replies

2. SCO

Problem with printing

Does anybody know how I can stop the system slewing pages when a spool file has finished printing. I need to set up a method where all users are printing to the same printer to produce labels. The problem is that when the first users file has been printed the pages are slewed and the label is not... (2 Replies)
Discussion started by: rongrout
2 Replies

3. HP-UX

Printing problem

I have scheduled to print a numerous of report in mid-night. But, I found that some reports have not been printed out. Then, I checked the file /var/spool/lp/log and found that all reports have been submitted to print queue. Could anyone tell me what can be done to ensure all print jobs can be... (2 Replies)
Discussion started by: alfredo
2 Replies

4. UNIX for Advanced & Expert Users

Printing Problem

I am trying to print to an hp printer. i configured it using the hp configuration, entry is in the /etc/hosts file, i can telnet into it using port 9100, ping it and send jobs to it. it just won't print. the jobs stay in the spooler. its telling me to add the printer to the canaccess list. ... (0 Replies)
Discussion started by: Rosario
0 Replies

5. UNIX for Dummies Questions & Answers

Printing problem

Hello, Not sure where to begin on describing the issue; please try to understand that I am not very familiar with SCO UNIXWARE. I am a newbie... We have a SCO UNIXWARE version 7.4 when we restart the computer we are required to enter the command lpstart, without it; people cannot print. ... (1 Reply)
Discussion started by: Yorgy
1 Replies

6. HP-UX

Urgent printing problem

I can no longer print from HP-UX 10. All the printers are network printers. I have already stopped and restarted the spooler (lpshut and lpsched), but still the same problem. The printers react when I ping them. I have also tried with SAM, but the system cannot find the printers. Can somebody... (1 Reply)
Discussion started by: filipd
1 Replies

7. UNIX for Dummies Questions & Answers

Printing problem in the Unix

How do you print a batch of pdf files on solaris 8/9 to a post script printer(HPLaser 4350).so that printing is as both sides of the paper.We have tried to print using XPDF pdftops program but we are able to print only as one side. The switch -o duplex does not seem to work when used with lp... (1 Reply)
Discussion started by: sivamurugan
1 Replies

8. UNIX for Dummies Questions & Answers

printing Problem

When I print a file from an application it never stops printing. Any ideas? (2 Replies)
Discussion started by: 744eagle
2 Replies

9. IP Networking

Printing Problem

I have a printer installed on sun solaris m/c sun os 5.8. It doesn't print more than 52 files i.e if a give lp *.txt and the curent folder contains more than 52 files then it doesn't print them but if print in batches , each containing 52 files then it prints them properly. How do i increase the... (3 Replies)
Discussion started by: kapilv
3 Replies

10. UNIX for Dummies Questions & Answers

printing problem

i can only print from unix when I am logged in as host. When any user logs in (even myself as a user who has root priviledges) I cannot print. Has anyone heard of this problem before and are there any troubleshooting tips out there. HELP......... (3 Replies)
Discussion started by: acarroll
3 Replies

Featured Tech Videos