Help needed to configure GUI with Slackware 7 on an IBM Thinkpad Laptop

Thread Tools Search this Thread
Special Forums UNIX Desktop Questions & Answers Help needed to configure GUI with Slackware 7 on an IBM Thinkpad Laptop
# 1  
Old 06-10-2002
Data Help needed to configure GUI with Slackware 7 on an IBM Thinkpad Laptop

I am using Slackware 7 on my IBM Thinkpad. I am unable to configure it to display a graphical environment. Typing startx usually generates a few errors. The system, however, does boot into the shell environment without any issues or problems. I have been able to setup Slackware 7 successfully on a Dell Optiplex desktop PC. Not sure why the laptop is posing difficulties? Any help will be greatly appreciated! Smilie

After starting startx, here is what I get:

config error: /etc/xf86config:208
protocol "(NULL)"
mouse type not supported by this OS
x connection to :0.0 broken (explicit kill or server shutdown).

Thanks for all replies!!!

Last edited by adrienb; 06-11-2002 at 12:24 AM..
# 2  
Old 06-11-2002
Post the errors you get when using startx.
# 3  
Old 06-11-2002
According to the FAQ on slackware:

How do I add X to this?

Assuming you've got the space to install it, download the X packages (the files ending in .tgz) from this directory:

You might also grab the diskx1 file, which describes each of the packages. You can save disk space if you don't install all of the X servers (you only need the one for your video card), and you might also leave out extra fonts, old X shared libraries (oldlibs*.tgz), and possibly development tools if you're not planning to compile X software yourself. Once you've collected the packages you plan to install into a directory, run this to install them:

installpkg *.tgz

Before running X, you'll need to set it up with 'xf86config'.

Found at
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Red Hat

Need to configure my laptop Thinkpad - T430 as wifi hotspot

Hi All, I have a Thinkpad - T430, which is having the wireless card as "03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205". This one i need to configure as wifi hotspot. which i believe need to configure hostapd.conf, this kind of configuration is new to me anybody done... (1 Reply)
Discussion started by: linux.amrit
1 Replies

2. Ubuntu

Ubuntu Lenovo Thinkpad E520-1143 Laptop

Is it possible to install Ubuntu 11.04 or Ubuntu 11.10 in Lenovo Thinkpad E520-1143 Now it Powerd By windowd Xp Professional is it possible to install Ubuntu in it and supports all drivers for ma laptop such as VGA driver Sound,Wireless,Lan , fingerprint,camera pls reply r is it possible to... (0 Replies)
Discussion started by: babinlonston
0 Replies

3. Slackware

How configure micromax bsnl 3G modem in KPPP on slackware 13.1

How configure micromax bsnl 3G modem in KPPP on slackware 13.1 while it automatically mounted under /dev/sr1 iso9660 /media/modem and in lsusb command add following information: Bus 001 Device 020: ID 1c9e:f000 now i follow these steps for usb switch to modem usb_modeswitch.conf ... (0 Replies)
Discussion started by: hitlar
0 Replies

4. Hardware

Slackware 13.1 can't configure two network cards

Hello everybody, I'm having troubles with Slackware 13.1 and network cards. I have one on-board Ethernet card (which is recognized and works okay) and a PCI Ethernet card (which is also recognized, but doesn't appear in 'ifconfig -a'). If i run a 'lspci', i can see the kernel recognized the... (5 Replies)
Discussion started by: semash!
5 Replies

5. UNIX for Dummies Questions & Answers

Configure wifi throught console problem, GUI is OK

Hi gurus, I am trying to connect to wifi access point with terminal, I set up my own access point (no encryption or MAC filters) I ran followings commands $ sudo iwlist eth1 scanning eth1 Scan completed : Cell 01 - Address: 00:11:2F:A2:99:1C ... (1 Reply)
Discussion started by: wakatana
1 Replies

6. Slackware

installing slackware 10.2 on compaq laptop with Sansung HM121HI hard drive

Hi Guys, I'm trying to install slackware 10.2 on a on compaq laptop with Sansung HM121HI hard drive but I wonder what kernel should I use so it can recognize the had disk. Initially I've tried using sata.i and then try to use the fdisk utility to create the new partiotions but doesn't seem... (0 Replies)
Discussion started by: hariza
0 Replies

7. Linux

GUI builder advice needed ......

Hello all, I need to develop an application that would be used as a simulator to test various custom algorithms. As I have never embarked on this kind of work, I need some advice: 1. Which GUI library to use in Linux, GTK+ or FLTK? The simulator application needs to output various... (2 Replies)
Discussion started by: fox_hound_33
2 Replies

8. Solaris

Solaris 8/x86: issues with video card on IBM ThinkPad A20p

hi there, i'm quite new to solaris and recently i've bought a ibm thinkpad... now i intend to install a dual-boot system. in fact i've got it managed to install the end-user system with dual-boot working. apart from following issue other devices got recognized... this is what i've found out... (2 Replies)
Discussion started by: pseudocoder
2 Replies

9. SCO

configure Adaptec 29320ALP Ultra 320 SCSI Card in IBM X3400

I am installing SCO UNIX 5.0.6 in X3400, every thing are install except Adaptec 29320ALP Card (Attached DAT Drive) because their driver are available in btld formate Fllopy DISk and SCO Unix 5.0.6 not support USB Floppy, Can anybody inform us any other method to installed the Adaptec Ultra 120... (3 Replies)
Discussion started by: hafizurr
3 Replies
Login or Register to Ask a Question