Visit Our UNIX and Linux User Community


Configure wifi throught console problem, GUI is OK


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Configure wifi throught console problem, GUI is OK
# 1  
Old 11-08-2009
Configure wifi throught console problem, GUI is OK

Hi gurus,
I am trying to connect to wifi access point with terminal, I set up my own access point (no encryption or MAC filters)
I ran followings commands

Code:
$ sudo iwlist eth1 scanning 
eth1      Scan completed :
          Cell 01 - Address: 00:11:2F:A2:99:1C
                    ESSID:"esus"
                    Protocol:IEEE 802.11g
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality=97/100  Signal level=-23 dBm  
                    Extra: Last beacon: 48ms ago

Code:
$ sudo iwconfig eth1 mode managed essid esus channel 6

Code:
$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      unassociated  Mode:Managed  Frequency=2.437 GHz  
          Access Point: Not-Associated   Bit Rate:0 kb/s   Tx-Power=20 dBm   
          Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

vboxnet0  no wireless extensions.

But when I use graphic tool in ubuntu 9.10 and then check it with iwconfig everything is OK
Code:
$ iwconfig 
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11g  ESSID:"esus"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:11:2F:A2:99:1C   
          Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=99/100  Signal level=-23 dBm  Noise level=-87 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

vboxnet0  no wireless extensions.

my box and wifi card:

Code:
$ lspci | grep -i wireless
06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

Code:
$ uname -a
Linux cepi-laptop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

Code:
dpkg -l | grep wireless-tools
ii  wireless-tools                       29-2ubuntu6                                Tools for manipulating Linux Wireless Extens


Also I have another question, lets say I am connected to an AP but DHCP is disabled, also there is running web interface on AP throught I can set up DHCP and obtain IP address. How do I know what is IP of the AP which I am connected, is there a solution or I have to reset AP ?

I had idea to scann whole network with
Code:
$ echo -ne {0..255}.{0..255}.{0..255}.{0..255}"\n" > addresses
$ sudo nmap -sS -iL addresses

I know this is terrible waste of system resources, and my box stops responding and start swaping after I issued echo command Smilie, but I dont know anything else, problably set some kind of broadcast ping or something like that, is this possible ?

What I am doing wrong ? Thanks a lot.
# 2  
Old 11-11-2009
nobody Smilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #241
Difficulty: Easy
In 1973, a transatlantic submarine fiber optic link connected the Norwegian Seismic Array (NORSAR) to the ARPANET, making Norway the first country outside the US to be connected to the network.
True or False?

8 More Discussions You Might Find Interesting

1. Red Hat

Need to configure my laptop Thinkpad - T430 as wifi hotspot

Hi All, I have a Thinkpad - T430, which is having the wireless card as "03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205". This one i need to configure as wifi hotspot. which i believe need to configure hostapd.conf, this kind of configuration is new to me anybody done... (1 Reply)
Discussion started by: linux.amrit
1 Replies

2. HP-UX

When connecting to HPUX gui console it is grey screen?

My screen is grey when i connect to gui console (2 Replies)
Discussion started by: kenshinhimura
2 Replies

3. SCO

Console GUI kicks me after 30 seconds. Licensing issue?

I have two SCO servers. On one I can logon to the gui via console with no problem. However, on the other I can logon to the gui but after a few seconds it kicks me back out to the prompt. I asked previous admin about this and he seems to think its a license issue? (7 Replies)
Discussion started by: herot
7 Replies

4. Solaris

configure iplanet DS for SSL without console?

Hey guys, Is it possible to configure iplanet DS for SSL without the DS console? I cannot find any documentation regarding it. The iplanet DS document only references using the DS console which I do not have. In Sun One, you can use dsadm to import certs however that is not available in iplanet... (0 Replies)
Discussion started by: s ladd
0 Replies

5. Linux

How to install or configure my WiFi?

Hi every body i m new using mandriva 2009 spring linux and i need to cofigure my wifi i have nexx card 54M 8085 it drivers in windows say realtec (1 Reply)
Discussion started by: aaa1
1 Replies

6. UNIX for Dummies Questions & Answers

wifi in linux problem

hi, i'm really new at this. i recently installed ubuntu on my machine and have that and vista installed now. but in ubuntu i cant connect wirelessly to the internet. i'm not using a wifi card the wifi is built into the laptop. can anybody help me configure ubuntu to use the wifi. (4 Replies)
Discussion started by: naner9
4 Replies

7. Solaris

Non-gui equivalent to SMC Management Console?

Forgive my naievety, but is there a non-Gui version of the administration tool, SMC? I need to run this on a remote Putty login and it is just plain UNIX. When I invoke SMC, I get java.lang.ClassLoader errors, a bunch of jibberish and a root prompt. I have searched Google, seems as if it... (14 Replies)
Discussion started by: jeffpas
14 Replies

8. UNIX Desktop Questions & Answers

Help needed to configure GUI with Slackware 7 on an IBM Thinkpad Laptop

I am using Slackware 7 on my IBM Thinkpad. I am unable to configure it to display a graphical environment. Typing startx usually generates a few errors. The system, however, does boot into the shell environment without any issues or problems. I have been able to setup Slackware 7 successfully... (2 Replies)
Discussion started by: adrienb
2 Replies

Featured Tech Videos