Visit Our UNIX and Linux User Community


ftp problem


 
Thread Tools Search this Thread
Special Forums UNIX Desktop Questions & Answers ftp problem
# 1  
Old 05-03-2002
ftp problem

I use FTP in a shell script to transfer the files to a remote server.
Sometimes the program hangs without returning any errors
after the command

ftp server_name

How do you detect from within the shell that something is wrong?
How do you trap the errors returned by ftp command?

Any help will be greatly appreciated.

marusia
# 2  
Old 05-03-2002
If it is hanging there it is usually a network issue (slow network, routes not there, too many hops...), a server issue (server is down or non-responsive). If you attempt to ping the server before doing the ftp to the server you may be able to stop it from hanging because of the problems listed. I just tried to ftp to a server I decommissioned and it took 5 minutes for it to come back to tell me that there is no route to host...but it's still trying!
thehoghunter
# 3  
Old 05-03-2002
ftp problem

What you are suggesting is actually what I tried to do - use ping command. The result was:

no answer from server_name

Meanwhile the ftp worked this time around.
Any other suggestions?

marusia
# 4  
Old 05-03-2002
You can put a loop into your script (along with a timer if needed) to keep trying the ping - once it's successful, do the ftp session.
The timer is just in case you don't want it to keep going forever.
All you do is set up a counter and use the sleep command - your code will be different....

sleep 120
@ now = $now + 2
if ($now > 60) then
# send email stating it hit the timeout of one hour
exit
else
keep checking...

I'm sure others will have different ideas.
thehoghunter

Previous Thread | Next Thread
Test Your Knowledge in Computers #63
Difficulty: Easy
Blackberry was the first company to use the Emoji for mobile devices.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Ftp problem

Hi, I have a problem when i want to get a filename from an ftp server when a space is before his name. example: "spacetestFile" The ftp server return an error "no asset or no permission" though the file exist ? Why it behave in this way ? (8 Replies)
Discussion started by: protocomm
8 Replies

2. Red Hat

ftp problem?

Dear All I cannot ftp to my RedHat server from MS Windows machine ,but ping and telnet are ok. I checked as the following : #chkconfig tftp on #setup After enabling tftp service, still the ftp is not ok but ping & telnet are ok. Can you please help me? Thank you (8 Replies)
Discussion started by: hadimotamedi
8 Replies

3. Shell Programming and Scripting

ftp problem

Hello, I have a very simple script that put a file in server ftp #!/bin/bash var="ITW-trail-templiers-samedi" cd /Users/$USER/Desktop ftp -n >&1 << EOF open server quote user "user" cd oberon binary put "$var" bye EOF I have error : 200 Type set to IMAGE. remote:... (2 Replies)
Discussion started by: protocomm
2 Replies

4. Shell Programming and Scripting

FTP Problem

Hello experts, I've got the following script that is supposed to FTP a file to another box. #!/usr/bin/ksh while read line do HOST=`echo "$line" | cut -d" " -f1` USER=`echo "$line" | cut -d" " -f2` PASSWD=`echo "$line" | cut -d" " -f3` PATH=`echo "$line" | cut -d" " -f4` done <... (5 Replies)
Discussion started by: King Nothing
5 Replies

5. Shell Programming and Scripting

problem in FTP

i m able to login to Unix box from window's cmd can anyone tell me how to run a script from window cmd using ftp ? the script is in unix box and i need to run from windows CMD using ftp (2 Replies)
Discussion started by: ali560045
2 Replies

6. Shell Programming and Scripting

problem with ftp:

i have got 2 servers in unix(IBM AIX 5.3) namely below. test1 production1 i m trying to do ftp from test1 to production1. ------------------------------------------------------------ below the script called naveed1.sh which lies in test1,also it have two files called ... (2 Replies)
Discussion started by: ali560045
2 Replies

7. HP-UX

FTP problem

We recently moved offices and checked our network ID. I have configured all the files that I am familiar with and am able to telnet and ping from my pc but I am unable to ftp. Any suggestions...Thanks (5 Replies)
Discussion started by: andrewd
5 Replies

8. Solaris

FTP problem

Hi Guys, Got problem when I tried to get files from Solaris server to my PC. The connection transfer was using FTP and the connection was made from the solaris server to my PC. Here's what happened when the file transfer being made: # ftp 10.192.23.230 Connected to 10.192.23.230. 220... (9 Replies)
Discussion started by: raskita
9 Replies

9. Shell Programming and Scripting

Ftp problem

hi i have written a shell to automate the ftp process for the particular file.iam getting errors when try to ftp it.And i am cant get why the lcd is not being taken properly as it is taking during runtime.can anyone give me a solution here its my code DATE=`date '+%d_%m_%Y'`... (1 Reply)
Discussion started by: cskumar
1 Replies

10. UNIX for Dummies Questions & Answers

FTP problem. please help

can someone tell me how I can deal with a problem am having concerning users that are faliing to use one of the shells specified in the /etc/shells file. as a result, am told, these users are bound fail to connect via FTP. i know i goto check the /etc/shells file on the target host but what... (5 Replies)
Discussion started by: TRUEST
5 Replies

Featured Tech Videos