GETENCSTAT(8) BSD System Manager's Manual GETENCSTAT(8)NAME
getencstat -- get SCSI Environmental Services Device enclosure status
getencstat [-v] device [device ...]
getencstat gets summary and detailed SCSI Environmental Services (or SAF-TE) device enclosure status. The overall status is printed out. If
the overall status is considered okay, nothing else is printed out (unless the -v option is used).
A SCSI Environmental Services device enclosure may be either in the state of being OK, or in one or more of the states of INFORMATIONAL,
NON-CRITICAL, CRITICAL, or UNRECOVERABLE states. These overall states reflect a summary of the states of each object within such a device
(such as power supplies or disk drives).
With the -v option, the status of all objects within the device is printed, whether OK or not. Along with the status of each object is the
The user may then use setencstat(8) to try and clear overall device status, or may use setobjstat(8) to set specific object status.
/dev/sesN SCSI Environmental Services Devices
SEE ALSO ses(4), sesd(8), setencstat(8), setobjstat(8)BSD February 21, 2000 BSD
Check Out this Related Man Page
SES(4) BSD Kernel Interfaces Manual SES(4)NAME
ses -- SCSI Environmental Services Driver
ses* at scsibus? target? lun?
The ses driver provides support for all SCSI devices of the environmental services class that are attached to the system through a supported
SCSI Host Adapter, as well as emulated support for SAF-TE (SCSI Accessible Fault Tolerant Enclosures). The environmental services class gen-
erally are enclosure devices that provide environmental information such as number of power supplies (and state), temperature, device slots,
and so on.
A SCSI Host adapter must also be separately configured into the system before a SCSI Environmental Services device can be configured.
The following ioctl(2) calls apply to SES devices. They are defined in the header file <scsipi/ses.h> (q.v.).
SESIOC_GETNOBJ Used to find out how many SES objects are driven by this particular device instance.
SESIOC_GETOBJMAP Read, from the kernel, an array of SES objects which contains the object identifier, which sub-enclosure it is in, and the
SES type of the object.
SESIOC_GETENCSTAT Get the overall enclosure status.
SESIOC_SETENCSTAT Set the overall enclosure status.
SESIOC_GETOBJSTAT Get the status of a particular object.
SESIOC_SETOBJSTAT Set the status of a particular object.
SESIOC_GETTEXT Get the associated help text for an object (not yet implemented). SES devices often have descriptive text for an object
which can tell you things like location (e.g, "left power supply").
SESIOC_INIT Initialize the enclosure.
/dev/sesN The Nth ses device.
When the kernel is configured with DEBUG enabled, the first open to an SES device will spit out overall enclosure parameters to the console.
SEE ALSO getencstat(8), sesd(8), setencstat(8), setobjstat(8)HISTORY
The ses driver was written for the SCSI subsystem by Matthew Jacob. This is the functional equivalent of a similar driver available in
Solaris, Release 7.
BSD May 24, 2007 BSD
Hi all !
Yesterday I defined an environmental variable PATH, but today when I restarted machine, I could not see that it was stored any place.
Is there any file where I could save the settings ?
I have quite a few env.variables defined, so I need a smarter way to define.
D (5 Replies)
I am new to this socket programming stuff. I have a problem to fix.. i got the error message. "CRITICAL 11/08/05 12:06:26 _getsockopt reports error. errno: 239"
can some please help me with this.. how do i go about fixing this error.
thanx in advance.. (0 Replies)
I invoked this command "errpt -a | more " then I got tis message in the server
Date/Time: Thu Apr 10 19:37:57 SAUS
Sequence Number: 9038
Machine Id: 003AFDBC4C00
Node Id: jbvrprd
Class: H... (1 Reply)
I am trying to start a java program from nagios event handler at CRITICAL + SOFT + 3 or CRITICAL + HARD status.
I used the echo command in mytest.sh and am getting the result in the nagios.debug log file.
But when I am running the java command in mytest.sh... (0 Replies)
I want to be able to access an environment variable to control how a program is compiled.
Then ideally, within my C++ code, I would have
#if MY_VERSN = 9
iret = FRED9()
iret = FRED()
The way I thought I could do it is that in the script that... (2 Replies)
All if you have used RedHat Directory Services, I'm trying to put a posix groupid on the groups and can't figure out a way to do so. If you have had any success in this area please let me know. Thank You (0 Replies)
We have a v245 that powered itself off for no reason. Searching around we discovered there is a bug were a temp error is being reported but doesnt actually exist, SUN released an EPIC update, the README is shown below but even after upgrading the ALOM to the latest v1.6.10 we do not... (8 Replies)
OS: AIX 5.x
I was told that a disk (hdisk 10) is bad. How can I find "the serial # of the storage enclosure" from command line? How do I find which disk is on which enclosure?
Thank you in advance! :)
---------- Post updated at 12:33 PM ---------- Previous update... (2 Replies)
Please find the input file as given below:
2012/02/29 11:00:00~~CRITICAL~For customer 00000476 no daily files were found in the 010137933 account directory.
2012/02/29 11:00:00~~CRITICAL~For customer 05006802 no daily files were found in the 010115166 account directory.
2012/02/29... (0 Replies)
I have got a slot within my C3000 blade enclosure populated with a HP SB40c (StorageWorks). This is essentially a disk array for the blades to access within my C3000 enclosure.
I can see from my OA that it is currently powered off. Can anybody suggest what is required in order to get... (0 Replies)