opensolaris man page for sesio

Query: sesio

OS: opensolaris

Section: 7i

Links: opensolaris man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

sesio(7I)							  Ioctl Requests							 sesio(7I)

NAME
sesio - enclosure services device driver interface
SYNOPSIS
#include <sys/sesio.h>
DESCRIPTION
The ses device driver provides the following ioctls as a means to access SCSI enclosure services devices.
IOCTLS
The ses driver supports the following ioctls: SES_IOCTL_GETSTATE This ioctl obtains enclosure state in the ses_ioctl structure. SES_IOCTL_SETSTATE This ioctl is used to set parameters on the enclosure services device. The ses_ioctl structure is used to pass information into the driver.
ERRORS
EIO The ses driver was unable to obtain data from the enclosure services device or the data transfer could not be completed. ENOTTY The ses driver does not support the requested ioctl function. ENXIO The enclosure services device does not exist. EFAULT The user specified a bad data length.
STRUCTURES
The ses_ioctl structure has the following fields: uint32_t; /* Size of buffer that follows */ uint8_t page_code: /* Page to be read/written */ uint8_t reserved[3]; /* Reserved; Set to 0 */ unit8t buffer[1]; /* Size arbitrary, user specifies */
EXAMPLES
Example 1 Using the SES_IOCTL_GETSTATE ioctl The following example uses the SES_IOCTL_GETSTATE ioctl to recover 20 bytes of page 4 from a previously opened device. char abuf[30]; struct ses_ioctl *sesp; int status; sesp = (ses_ioctl *)abuf; sesp->size = 20; sesp->page_code = 4; status = ioctl(fd, SES_IOCTL_GETSTATE, abuf);
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |SPARC | +-----------------------------+-----------------------------+
SEE ALSO
ses(7D), ioctl(9E) SunOS 5.11 27 Mar 1997 sesio(7I)
Related Man Pages
ses(7d) - sunos
ses(4) - freebsd
pass(4) - debian
ioctl(2) - sunos
pass(4) - suse
Similar Topics in the Unix Linux Community
searching for {
services status finding ...???
Find serial number of storage enclosure?
ILO3 Virtual Media
C-Class Blade storage