|Linux & Unix Commands - Search Man Pages
IIC(4) BSD Kernel Interfaces Manual IIC(4)
iic -- Inter IC (I2C) bus
iic* at alipm? # sparc64
iic* at acpismbus? # amd64 i386
iic* at amdpm? # amd64 i386
iic* at armadillo9iic? # evbarm
iic0 at at91twi? # evbarm
iic0 at ausmbus0 # evbmips
iic0 at cuda0 # macppc
iic0 at gpiic? # evbppc
iic* at gpioiic? # amd64 i386
iic* at gtiic? # evbppc
iic* at gxiic? # evbarm
iic* at ichsmb? # amd64 i386
iic0 at iociic0 # acorn26
iic0 at iomdiic? # acorn32
iic0 at iopiic? # evbarm iyonix
iic* at ki2c? # macppc
iic* at nfsmb? # amd64 i386
iic* at ociic? # sandpoint
iic* at piixpm? # amd64 i386
iic0 at slugiic0 # evbarm
iic* at viapcib? # i386
I2C is a two-wire bus developed by Philips used for connecting integrated circuits. It is
commonly used for connecting devices such as EEPROMs, temperature sensors, fan controllers,
real-time clocks, tuners, and other types of integrated circuits.
The iic driver provides a uniform programming interface layer between I2C master controllers
and various I2C slave devices. Each I2C master controller attaches an iic framework; sev-
eral slave devices can then be attached to the iic bus.
All I2C slave devices are uniquely identified by the address on the bus. The master
accesses a particular slave device using its address.
System Management Bus (SMBus) protocol is also supported by emulating it with the I2C com-
A wide list of I2C masters are supported, among them are:
alipm(4) Acer Labs M7101 SMBus controller
acpismbus(4) ACPI SMBus Control Method Interface
amdpm(4) AMD768 Power Management Controller and AMD8111 System Management
cuda(4) support for CUDA microcontrollers found in many Power Macintosh
and and compatible computers
ichsmb(4) Intel ICH SMBus controller
gpioiic(4) GPIO bit-banging
nfsmb(4) NVIDIA nForce 2/3/4 SMBus controller and SMBus driver
piixpm(4) Intel PIIX and compatible Power Management controller
A wide list of slaves are supported, among them:
dbcool(4) dbCool(tm) family of environmental monitors and fan controllers
rs5c372rtc(4) RICOH RS5C372A and RS5C372B real-time clock
sgsmix(4) driver for SGS 7433 Basic Audio Processor found in some Apple machines
spdmem(4) Generic Memory Module Serial Presence Detect
dtviic(4), intro(4), i2cscan(8), iic(9)
The I2C framework first appeared in NetBSD 2.0. OpenBSD support was added in OpenBSD 3.6.
This manpage first appeared in NetBSD 6.0, it was ported from OpenBSD.
The I2C framework was written by Steve C. Woodford and Jason R. Thorpe for NetBSD and then
ported to OpenBSD by Alexander Yurchenko <firstname.lastname@example.org>.
BSD October 15, 2011 BSD
All times are GMT -4. The time now is 03:06 PM.